summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2005-04-16 12:02:34 +0000
committerStefan Schweizer <genstef@gentoo.org>2005-04-16 12:02:34 +0000
commitc84ce7205aef9e2e8788b1230cfa42c8dbd73218 (patch)
treeac954337954809a86f0ee240448f8f8eaaf2aefc /net-wireless/zd1201/zd1201-0.14.ebuild
parentnew upstream release, fixes #89237. added ~amd64 to KEYWORDS. (diff)
downloadhistorical-c84ce7205aef9e2e8788b1230cfa42c8dbd73218.tar.gz
historical-c84ce7205aef9e2e8788b1230cfa42c8dbd73218.tar.bz2
historical-c84ce7205aef9e2e8788b1230cfa42c8dbd73218.zip
New ebuild thanks to Ajay Gautam <ajaygautam@yahoo.com> in bug 89183
Package-Manager: portage-1.585-cvs
Diffstat (limited to 'net-wireless/zd1201/zd1201-0.14.ebuild')
-rw-r--r--net-wireless/zd1201/zd1201-0.14.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-wireless/zd1201/zd1201-0.14.ebuild b/net-wireless/zd1201/zd1201-0.14.ebuild
new file mode 100644
index 000000000000..d7dd29a74fde
--- /dev/null
+++ b/net-wireless/zd1201/zd1201-0.14.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/zd1201/zd1201-0.14.ebuild,v 1.1 2005/04/16 12:02:34 genstef Exp $
+
+inherit linux-mod
+
+DESCRIPTION="Linux Driver for ZyDAS 1201 (zd1201) based USB 802.11b Network WiFi devices"
+
+S=${WORKDIR}
+FW_VERSION="${PV}"
+HOMEPAGE="http://linux-lc100020.sourceforge.net/"
+SRC_URI="mirror://sourceforge/linux-lc100020/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+RDEPEND="=net-wireless/zd1201-firmware-${FW_VERSION}
+ net-wireless/wireless-tools"
+
+MODULE_NAMES="zd1201(net:)"
+BUILD_TARGETS="clean modules"
+
+CONFIG_CHECK="NET_RADIO USB FW_LOADER"
+NET_RADIO_ERROR="${P} requires support for Wireless LAN drivers (non-hamradio) & Wireless Extensions (CONFIG_NET_RADIO)."
+USB_ERROR="$P requires USB support (CONFIG_USB)"
+FW_LOADER_ERROR="${P} requires Hotplug firmware loading support (CONFIG_FW_LOADER)."
+
+pkg_setup() {
+ if kernel_is lt 2 6 10; then
+ die "Please upgrade to kernel 2.6.10 or above. There is a USB issue with anything lower."
+ fi
+
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNEL_SOURCE=${KV_DIR} KERNEL_VERSION=${KV_MAJOR}.${KV_MINOR}"
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc README
+}