summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenrik Brix Andersen <brix@gentoo.org>2004-11-01 11:53:57 +0000
committerHenrik Brix Andersen <brix@gentoo.org>2004-11-01 11:53:57 +0000
commit2ae056904d62ef15b773bb97b64dc8acb47c15fc (patch)
tree86fab1e06a9e781b92483e949b7034f0922f8c3b /net-wireless
parentFix bug #69281. (diff)
downloadhistorical-2ae056904d62ef15b773bb97b64dc8acb47c15fc.tar.gz
historical-2ae056904d62ef15b773bb97b64dc8acb47c15fc.tar.bz2
historical-2ae056904d62ef15b773bb97b64dc8acb47c15fc.zip
Fix bug #69282.
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/hostapd/ChangeLog6
-rw-r--r--net-wireless/hostapd/hostapd-0.1.0.ebuild6
-rw-r--r--net-wireless/hostapd/hostapd-0.1.3.ebuild6
-rw-r--r--net-wireless/hostapd/hostapd-0.2.4.ebuild6
-rw-r--r--net-wireless/hostapd/hostapd-0.2.5.ebuild6
5 files changed, 17 insertions, 13 deletions
diff --git a/net-wireless/hostapd/ChangeLog b/net-wireless/hostapd/ChangeLog
index d43f3b018852..7fa8b9f45a6a 100644
--- a/net-wireless/hostapd/ChangeLog
+++ b/net-wireless/hostapd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-wireless/hostapd
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/ChangeLog,v 1.7 2004/10/25 15:18:01 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/ChangeLog,v 1.8 2004/11/01 11:53:57 brix Exp $
+
+ 01 Nov 2004; Henrik Brix Andersen <brix@gentoo.org> hostapd-0.1.0.ebuild,
+ hostapd-0.1.3.ebuild, hostapd-0.2.4.ebuild, hostapd-0.2.5.ebuild:
+ Use tc-getCC() from toolchain-funcs.eclass, fixes bug #69282.
*hostapd-0.2.5 (25 Oct 2004)
diff --git a/net-wireless/hostapd/hostapd-0.1.0.ebuild b/net-wireless/hostapd/hostapd-0.1.0.ebuild
index c0217326d05f..97d44e765b98 100644
--- a/net-wireless/hostapd/hostapd-0.1.0.ebuild
+++ b/net-wireless/hostapd/hostapd-0.1.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.1.0.ebuild,v 1.4 2004/07/15 05:27:31 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.1.0.ebuild,v 1.5 2004/11/01 11:53:57 brix Exp $
-inherit eutils
+inherit toolchain-funcs eutils
DESCRIPTION="HostAP wireless daemon"
HOMEPAGE="http://hostap.epitest.fi/"
@@ -14,7 +14,7 @@ IUSE=""
DEPEND=">=net-wireless/hostap-driver-0.1.0"
src_compile() {
- emake CC="${CC}" CFLAGS="${CFLAGS}" || die
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die
}
src_install() {
diff --git a/net-wireless/hostapd/hostapd-0.1.3.ebuild b/net-wireless/hostapd/hostapd-0.1.3.ebuild
index 89e2a795ba42..e4104f3fe85d 100644
--- a/net-wireless/hostapd/hostapd-0.1.3.ebuild
+++ b/net-wireless/hostapd/hostapd-0.1.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.1.3.ebuild,v 1.3 2004/07/15 05:27:31 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.1.3.ebuild,v 1.4 2004/11/01 11:53:57 brix Exp $
-inherit eutils
+inherit toolchain-funcs eutils
DESCRIPTION="HostAP wireless daemon"
HOMEPAGE="http://hostap.epitest.fi/"
@@ -14,7 +14,7 @@ IUSE=""
DEPEND=">=net-wireless/hostap-driver-0.1.0"
src_compile() {
- emake CC="${CC}" CFLAGS="${CFLAGS}" || die
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die
}
src_install() {
diff --git a/net-wireless/hostapd/hostapd-0.2.4.ebuild b/net-wireless/hostapd/hostapd-0.2.4.ebuild
index ec283268705e..0be07e9087fd 100644
--- a/net-wireless/hostapd/hostapd-0.2.4.ebuild
+++ b/net-wireless/hostapd/hostapd-0.2.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.2.4.ebuild,v 1.1 2004/09/14 16:27:09 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.2.4.ebuild,v 1.2 2004/11/01 11:53:57 brix Exp $
-inherit eutils
+inherit toolchain-funcs eutils
DESCRIPTION="HostAP wireless daemon"
HOMEPAGE="http://hostap.epitest.fi/"
@@ -14,7 +14,7 @@ IUSE=""
DEPEND=">=net-wireless/hostap-driver-0.1.0"
src_compile() {
- emake CC="${CC}" CFLAGS="${CFLAGS}" || die
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die
}
src_install() {
diff --git a/net-wireless/hostapd/hostapd-0.2.5.ebuild b/net-wireless/hostapd/hostapd-0.2.5.ebuild
index 292b21b1ae9a..09373af79d53 100644
--- a/net-wireless/hostapd/hostapd-0.2.5.ebuild
+++ b/net-wireless/hostapd/hostapd-0.2.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.2.5.ebuild,v 1.1 2004/10/25 15:18:01 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.2.5.ebuild,v 1.2 2004/11/01 11:53:57 brix Exp $
-inherit eutils
+inherit toolchain-funcs eutils
DESCRIPTION="HostAP wireless daemon"
HOMEPAGE="http://hostap.epitest.fi"
@@ -18,7 +18,7 @@ DEPEND=">=net-wireless/hostap-driver-0.1.0"
src_unpack() {
unpack ${A}
- sed -i "s:^CC=gcc:CC=${CC}:" ${S}/Makefile
+ sed -i "s:^CC=gcc:CC=$(tc-getCC):" ${S}/Makefile
}
src_compile() {