summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2005-08-19 16:06:07 +0000
committerDoug Goldstein <cardoe@gentoo.org>2005-08-19 16:06:07 +0000
commit3e01baa0237a0f15e9fd44beaae03e5f2d3b7928 (patch)
tree9daf073d64f8c2c6b9392f230120a08d5f32ffc9 /net-wireless
parentRemove mask for lighttpd-1.4.0 pre-releases (diff)
downloadhistorical-3e01baa0237a0f15e9fd44beaae03e5f2d3b7928.tar.gz
historical-3e01baa0237a0f15e9fd44beaae03e5f2d3b7928.tar.bz2
historical-3e01baa0237a0f15e9fd44beaae03e5f2d3b7928.zip
upgrading because upstream claims this version is SMP, previous version was
+ not includes some fixes. calling this 0.2.4 even though the file is + 20050811. upstream claims this is version 0.2.4 and dmesg says the same. + Including updates to the firmware. This includes the version upstream says + works best for the acx100, acx111 and the USB adapter. Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/acx100/ChangeLog11
-rw-r--r--net-wireless/acx100/Manifest16
-rw-r--r--net-wireless/acx100/acx100-0.2.4.ebuild54
-rw-r--r--net-wireless/acx100/files/digest-acx100-0.2.42
4 files changed, 80 insertions, 3 deletions
diff --git a/net-wireless/acx100/ChangeLog b/net-wireless/acx100/ChangeLog
index c8969b481863..b027a24d1565 100644
--- a/net-wireless/acx100/ChangeLog
+++ b/net-wireless/acx100/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-wireless/acx100
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/acx100/ChangeLog,v 1.11 2005/07/26 16:31:25 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/acx100/ChangeLog,v 1.12 2005/08/19 16:06:07 cardoe Exp $
+
+*acx100-0.2.4 (19 Aug 2005)
+
+ 19 Aug 2005; Doug Goldstein <cardoe@gentoo.org> +acx100-0.2.4.ebuild:
+ upgrading because upstream claims this version is SMP, previous version was
+ not includes some fixes. calling this 0.2.4 even though the file is
+ 20050811. upstream claims this is version 0.2.4 and dmesg says the same.
+ Including updates to the firmware. This includes the version upstream says
+ works best for the acx100, acx111 and the USB adapter.
26 Jul 2005; Stefan Schweizer <genstef@gentoo.org>
-acx100-0.2.0_pre8-r5.ebuild:
diff --git a/net-wireless/acx100/Manifest b/net-wireless/acx100/Manifest
index b4c52938899e..7ce6ea77c614 100644
--- a/net-wireless/acx100/Manifest
+++ b/net-wireless/acx100/Manifest
@@ -1,4 +1,16 @@
-MD5 cbe55c7c32af7dfead0bb28e9821a9a0 ChangeLog 2187
-MD5 19fd766bac8e110b4620363a1ace26dd metadata.xml 159
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 44ea8fdbb751aaffe960b3753d7bc157 ChangeLog 2645
MD5 b1b1c282801e90a82099b5a384f38dc2 acx100-0.2.0_pre8-r6.ebuild 1526
+MD5 e33a934a5fbdbda18c6de4e049d8e1d3 acx100-0.2.4.ebuild 1524
+MD5 19fd766bac8e110b4620363a1ace26dd metadata.xml 159
MD5 e2e4d69daf2b215f28b9cd5b532b3c88 files/digest-acx100-0.2.0_pre8-r6 147
+MD5 c17c9f12395a46910f1d908b6fcc9f69 files/digest-acx100-0.2.4 120
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDBgOIBtvusYtCZMsRAvvfAJ9as052blkDSxpJTMp4PGg7ShRC/QCfRHa2
+/Trx6oMZ+yVzCWAadlye5xA=
+=0je7
+-----END PGP SIGNATURE-----
diff --git a/net-wireless/acx100/acx100-0.2.4.ebuild b/net-wireless/acx100/acx100-0.2.4.ebuild
new file mode 100644
index 000000000000..e8d60b569728
--- /dev/null
+++ b/net-wireless/acx100/acx100-0.2.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/acx100/acx100-0.2.4.ebuild,v 1.1 2005/08/19 16:06:07 cardoe Exp $
+
+inherit linux-mod
+
+DESCRIPTION="Driver for the ACX100 and ACX111 wireless chipset (CardBus, PCI, USB)"
+
+HOMEPAGE="http://acx100.sourceforge.net/"
+SRC_URI="http://acx100.erley.org/acx-20050811.tar.bz2
+ http://acx100.erley.org/fw.tar.bz2"
+
+LICENSE="GPL-2 as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="pcmcia"
+RESTRICT="nomirror"
+
+RDEPEND=">=sys-apps/hotplug-20040923
+ net-wireless/wireless-tools"
+
+S=${WORKDIR}
+
+MODULE_NAMES="acx_pci(net:${S}) acx_usb(net:${S})"
+CONFIG_CHECK="NET_RADIO FW_LOADER"
+BUILD_PARAMS="-C ${KV_DIR} SUBDIRS=${S}"
+# KERNELVER=${KV_FULL} KERNELDIR=${KV_DIR} KERNEL_BUILD=${KV_DIR}
+#SUBDIRS=${S} WLAN_HOSTIF=WLAN_PCI"
+BUILD_TARGETS="modules"
+MODULESD_ACX_PCI_ADDITIONS=" " #needed to clear out previous setting which caused problems with new ver
+
+#KERNEL_VER=KERNEL_VER=${KV_FULL}
+#KERNEL_BUILD=/lib/modules/\$KERNEL_VER/build:KERNEL_BUILD=${KV_DIR}:
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -e 's:usr/share/acx:lib/firmware:' -i helper.c || die "Fixing firmware directory failed"
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc README doc/*
+
+ insinto /lib/firmware
+ doins ${WORKDIR}/fw/acx111_1.2.1.34/*
+ doins ${WORKDIR}/fw/acx100_1.9.8.b/*
+ doins ${WORKDIR}/fw/acx100_1.0.9-USB/*
+}
+
+pkg_postinst() {
+ einfo "Please run 'etc-update' and then 'update-modules' to complete install"
+}
diff --git a/net-wireless/acx100/files/digest-acx100-0.2.4 b/net-wireless/acx100/files/digest-acx100-0.2.4
new file mode 100644
index 000000000000..0b94c0f5d789
--- /dev/null
+++ b/net-wireless/acx100/files/digest-acx100-0.2.4
@@ -0,0 +1,2 @@
+MD5 08b8b9e197867aa977ca22ffb62d6307 acx-20050811.tar.bz2 315362
+MD5 646f67a8b7c6ec6d942818614394576f fw.tar.bz2 417079