summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-06-02 21:11:17 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-06-02 21:11:17 +0000
commitcc2a22c4b5737609d43a1b4d2ece2b9b159c60da (patch)
tree43f7336d3c5d0102a4e726c7ada833bdd989f0ab /net-www/lynx/lynx-2.8.4a-r4.ebuild
parentGCC3.1 support. Masked until tested by 2.95.3 users. (diff)
downloadhistorical-cc2a22c4b5737609d43a1b4d2ece2b9b159c60da.tar.gz
historical-cc2a22c4b5737609d43a1b4d2ece2b9b159c60da.tar.bz2
historical-cc2a22c4b5737609d43a1b4d2ece2b9b159c60da.zip
GCC3.1 support fix -- thanks to lostlogix and carpaski
Diffstat (limited to 'net-www/lynx/lynx-2.8.4a-r4.ebuild')
-rw-r--r--net-www/lynx/lynx-2.8.4a-r4.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/net-www/lynx/lynx-2.8.4a-r4.ebuild b/net-www/lynx/lynx-2.8.4a-r4.ebuild
new file mode 100644
index 000000000000..f172c302bf6e
--- /dev/null
+++ b/net-www/lynx/lynx-2.8.4a-r4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-www/lynx/lynx-2.8.4a-r4.ebuild,v 1.1 2002/06/02 21:11:17 mkennedy Exp $
+
+S=${WORKDIR}/lynx2-8-4
+HOMEPAGE="http://lynx.browser.org/"
+SRC_URI="ftp://lynx.isc.org/lynx2.8.4/lynx2.8.4.tar.bz2"
+
+DESCRIPTION="An excellent console-based web browser with ssl support"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/zlib-1.1.3
+ nls? ( sys-devel/gettext )
+ ssl? ( >= dev-libs/openssl-0.9.6 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/lynx2.8.4rel.1a.patch || die
+
+ # GCC3.1 support -- check if it's really needed in
+ # future. Some users report complete success with -r3 --
+ # credit to lostlogix and carpaski. Resolves #3172
+ cd src
+ patch LYStrings.c < ${FILESDIR}/lynx-2.8.4a-LYStrings.c-gentoo.patch || die
+}
+
+src_compile() {
+ local myconf
+ use nls && myconf="${myconf} --enable-nls"
+ use ssl && myconf="${myconf} --with-ssl=yes"
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ CFLAGS="${CFLAGS} -DANSI_VARARGS"
+
+ ./configure --prefix=/usr --mandir=/usr/share/man --datadir=/usr/share \
+ --libdir=/etc/lynx --enable-cgi-links --enable-prettysrc \
+ --enable-nsl-fork --enable-file-upload --enable-read-eta \
+ --enable-libjs --enable-color-style --enable-scrollbar \
+ --enable-included-msgs --with-zlib --host=${CHOST} ${myconf}
+ assert
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ make prefix=${D}/usr datadir=${D}/usr/share mandir=${D}/usr/share/man \
+ libdir=${D}/etc/lynx install || die
+
+ dodoc CHANGES COPYHEADER COPYING INSTALLATION PROBLEMS README
+ docinto docs
+ dodoc docs/*
+ docinto lynx_help
+ dodoc lynx_help/*.txt
+ dohtml -r lynx_help
+
+ # small little manpage glitch
+ rm ${D}/usr/share/man/lynx.1
+ newman lynx.man lynx.1
+}