summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2005-02-25 18:12:05 +0000
committerBenedikt Boehm <hollow@gentoo.org>2005-02-25 18:12:05 +0000
commit465b1230fe86055a0e8755111d547a99ec4f44c3 (patch)
treea432d4824ffbe7aba6b8e6a59a8300ccfeab8830 /net-www/mod_encoding/mod_encoding-20021209-r1.ebuild
parentBump (diff)
downloadhistorical-465b1230fe86055a0e8755111d547a99ec4f44c3.tar.gz
historical-465b1230fe86055a0e8755111d547a99ec4f44c3.tar.bz2
historical-465b1230fe86055a0e8755111d547a99ec4f44c3.zip
use apache-module.eclass
Package-Manager: portage-2.0.51.16
Diffstat (limited to 'net-www/mod_encoding/mod_encoding-20021209-r1.ebuild')
-rw-r--r--net-www/mod_encoding/mod_encoding-20021209-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-www/mod_encoding/mod_encoding-20021209-r1.ebuild b/net-www/mod_encoding/mod_encoding-20021209-r1.ebuild
new file mode 100644
index 000000000000..1930a83bb003
--- /dev/null
+++ b/net-www/mod_encoding/mod_encoding-20021209-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_encoding/mod_encoding-20021209-r1.ebuild,v 1.1 2005/02/25 18:12:05 hollow Exp $
+
+inherit apache-module
+
+DESCRIPTION="Apache module for non-ascii filename interoperability"
+HOMEPAGE="http://webdav.todo.gr.jp/"
+SRC_URI="http://webdav.todo.gr.jp/download/${P}.tar.gz"
+
+IUSE=""
+DEPEND=""
+KEYWORDS="x86"
+LICENSE="Apache-1.1"
+SLOT="0"
+
+APACHE1_MOD_CONF="30_${PN}"
+APACHE1_MOD_DEFINE="ENCODING"
+
+DOCFILES="AUTHORS COPYING ChangeLog INSTALL README*"
+
+need_apache1
+
+src_compile() {
+ cd ${S}/lib
+ ./configure --prefix=${WORKDIR}/iconv-hook || die
+ make install || die
+
+ cd ${S}
+ econf --with-iconv-hook=${WORKDIR}/iconv-hook/include/iconv-hook || die
+ emake LIBS="-L${WORKDIR}/iconv-hook/lib -liconv_hook" || die
+}
+
+src_install() {
+ apache-module_src_install
+ dolib.so ${WORKDIR}/iconv-hook/lib/libiconv_hook.so*
+}