summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2002-06-20 15:45:45 +0000
committerThilo Bangert <bangert@gentoo.org>2002-06-20 15:45:45 +0000
commit334f2610d05d255d8e65b9e32a296316af6434d4 (patch)
treeeb394ff0dd6a8bf6e8cb5a3f8b0d9b734bd3d688 /net-www/mod_ssl
parentAdded digest file for ppc + x86 tarballs (diff)
downloadhistorical-334f2610d05d255d8e65b9e32a296316af6434d4.tar.gz
historical-334f2610d05d255d8e65b9e32a296316af6434d4.tar.bz2
historical-334f2610d05d255d8e65b9e32a296316af6434d4.zip
version bump
Diffstat (limited to 'net-www/mod_ssl')
-rw-r--r--net-www/mod_ssl/ChangeLog8
-rw-r--r--net-www/mod_ssl/files/digest-mod_ssl-2.8.91
-rw-r--r--net-www/mod_ssl/mod_ssl-2.8.9.ebuild74
3 files changed, 82 insertions, 1 deletions
diff --git a/net-www/mod_ssl/ChangeLog b/net-www/mod_ssl/ChangeLog
index a1d518931a8a..920ad28fd350 100644
--- a/net-www/mod_ssl/ChangeLog
+++ b/net-www/mod_ssl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/mod_ssl
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/ChangeLog,v 1.1 2002/04/09 23:57:52 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/ChangeLog,v 1.2 2002/06/20 15:45:45 bangert Exp $
+
+*mod_ssl-2.8.9 (20 Jun 2002)
+
+ 20 Jun 2002; Thilo Bangert <bangert@gentoo.org> mod_ssl-2.8.9.ebuild
+
+ version bump - for apache 1.3.26
*mod_ssl-2.8.8 (9 Apr 2002)
diff --git a/net-www/mod_ssl/files/digest-mod_ssl-2.8.9 b/net-www/mod_ssl/files/digest-mod_ssl-2.8.9
new file mode 100644
index 000000000000..f54951b9c020
--- /dev/null
+++ b/net-www/mod_ssl/files/digest-mod_ssl-2.8.9
@@ -0,0 +1 @@
+MD5 aad438a4eaeeee29ae74483f7afe9db0 mod_ssl-2.8.9-1.3.26.tar.gz 752613
diff --git a/net-www/mod_ssl/mod_ssl-2.8.9.ebuild b/net-www/mod_ssl/mod_ssl-2.8.9.ebuild
new file mode 100644
index 000000000000..6b882627ef86
--- /dev/null
+++ b/net-www/mod_ssl/mod_ssl-2.8.9.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/mod_ssl-2.8.9.ebuild,v 1.1 2002/06/20 15:45:45 bangert Exp $
+
+MY_P=${P}-1.3.26
+
+DESCRIPTION="An SSL module for the Apache Web server"
+HOMEPAGE="http://www.modssl.org"
+
+S=${WORKDIR}/${MY_P}
+SRC_URI="http://www.modssl.org/source/${MY_P}.tar.gz"
+
+DEPEND="virtual/glibc =net-www/apache-1.3.26 >=dev-libs/openssl-0.9.6c"
+LICENSE="as-is"
+SLOT="0"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ # proper path to openssl
+ cp pkg.contrib/cca.sh pkg.contrib/cca.sh.orig
+ sed -e 's%^\(openssl=\).*%\1"/usr/bin/openssl"%' \
+ pkg.contrib/cca.sh.orig > pkg.contrib/cca.sh
+}
+
+src_compile() {
+ SSL_BASE=SYSTEM \
+ ./configure \
+ --with-apxs=/usr/sbin/apxs || die "bad ./configure"
+ make || die "compile problem"
+}
+
+src_install() {
+ exeinto /usr/lib/apache-extramodules
+ doexe pkg.sslmod/libssl.so
+
+ exeinto /usr/lib/ssl/mod_ssl
+ doexe pkg.contrib/*.sh ${FILESDIR}/gentestcrt.sh
+
+ dodoc ANNOUNCE CHANGES CREDITS LICENSE NEWS README*
+ mkdir -p ${D}/usr/share/doc/${PF}/html
+ cp -a pkg.ssldoc/* ${D}/usr/share/doc/${PF}/html
+
+ insinto /etc/apache/conf/vhosts
+ doins ${FILESDIR}/ssl.default-vhost.conf
+
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mod_ssl.conf
+}
+
+pkg_postinst() {
+ install -d -o root -g root -m0755 ${ROOT}/etc/apache/conf/ssl
+
+ einfo
+ einfo "Execute \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+ einfo "to have your apache.conf auto-updated for use with this module."
+ einfo "You should then edit your /etc/conf.d/apache file to suit."
+ einfo
+
+ cd ${ROOT}/etc/apache/conf/ssl
+ einfo "Generating self-signed test certificate in /etc/apache/conf/ssl..."
+ einfo "(Ignore any message from the yes command below)"
+ yes "" | ${ROOT}/usr/lib/ssl/mod_ssl/gentestcrt.sh >/dev/null 2>&1
+ einfo
+}
+
+pkg_config() {
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/libssl.so mod_ssl.c ssl_module \
+ define=SSL addconf=conf/addon-modules/mod_ssl.conf
+
+ echo "Include conf/vhosts/ssl.default-vhost.conf" \
+ >> ${ROOT}/etc/apache/conf/apache.conf
+}