summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2004-05-12 04:34:49 +0000
committerChuck Short <zul@gentoo.org>2004-05-12 04:34:49 +0000
commit39468cfecacdcdd3b1990eda3d1ee708f33b3252 (patch)
treeeb10573227e72c80aab455c093dba1b4de334734 /net-www/mod_ssl
parentUpdates, re-added shared core and eapi. (diff)
downloadhistorical-39468cfecacdcdd3b1990eda3d1ee708f33b3252.tar.gz
historical-39468cfecacdcdd3b1990eda3d1ee708f33b3252.tar.bz2
historical-39468cfecacdcdd3b1990eda3d1ee708f33b3252.zip
Verison bump.
Diffstat (limited to 'net-www/mod_ssl')
-rw-r--r--net-www/mod_ssl/ChangeLog7
-rw-r--r--net-www/mod_ssl/files/digest-mod_ssl-2.8.171
-rw-r--r--net-www/mod_ssl/mod_ssl-2.8.17.ebuild75
3 files changed, 82 insertions, 1 deletions
diff --git a/net-www/mod_ssl/ChangeLog b/net-www/mod_ssl/ChangeLog
index 39650f5a105c..a1d2fd51b98d 100644
--- a/net-www/mod_ssl/ChangeLog
+++ b/net-www/mod_ssl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/mod_ssl
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/ChangeLog,v 1.26 2004/04/16 11:27:48 zul Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/ChangeLog,v 1.27 2004/05/12 04:34:49 zul Exp $
+
+*mod_ssl-2.8.17 (12 May 2004)
+
+ 12 May 2004; Chuck Short <zul@gentoo.org> mod_ssl-2.8.17.ebuild:
+ Version bump.
16 Apr 2004; Chuck Short <zul@gentoo.org> files/ssl.default-vhost.conf:
Fixed DocumentRoot. Closes #47988.
diff --git a/net-www/mod_ssl/files/digest-mod_ssl-2.8.17 b/net-www/mod_ssl/files/digest-mod_ssl-2.8.17
new file mode 100644
index 000000000000..d352621fa061
--- /dev/null
+++ b/net-www/mod_ssl/files/digest-mod_ssl-2.8.17
@@ -0,0 +1 @@
+MD5 6c3f726b336f497793567591717d2a6b mod_ssl-2.8.17-1.3.31.tar.gz 754472
diff --git a/net-www/mod_ssl/mod_ssl-2.8.17.ebuild b/net-www/mod_ssl/mod_ssl-2.8.17.ebuild
new file mode 100644
index 000000000000..e8e9a59deed6
--- /dev/null
+++ b/net-www/mod_ssl/mod_ssl-2.8.17.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/mod_ssl-2.8.17.ebuild,v 1.1 2004/05/12 04:34:49 zul Exp $
+
+MY_P=${P}-1.3.31
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="An SSL module for the Apache Web server"
+SRC_URI="http://www.modssl.org/source/${MY_P}.tar.gz"
+HOMEPAGE="http://www.modssl.org/"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa"
+LICENSE="as-is"
+SLOT="0"
+
+DEPEND="=net-www/apache-1.3.31*
+ >=dev-libs/openssl-0.9.6k"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ # proper path to openssl
+ cp pkg.contrib/cca.sh pkg.contrib/cca.sh.orig
+ sed -e 's%^\(openssl=\).*%\1"/usr/bin/openssl"%' \
+ pkg.contrib/cca.sh.orig > pkg.contrib/cca.sh
+}
+
+src_compile() {
+ SSL_BASE=SYSTEM \
+ ./configure \
+ --with-apxs=/usr/sbin/apxs || die "bad ./configure"
+ make || die "compile problem"
+}
+
+src_install() {
+ exeinto /usr/lib/apache-extramodules
+ doexe pkg.sslmod/libssl.so
+
+ exeinto /usr/lib/ssl/mod_ssl
+ doexe pkg.contrib/*.sh ${FILESDIR}/gentestcrt.sh
+
+ dodoc ANNOUNCE CHANGES CREDITS LICENSE NEWS README*
+ dodir /usr/share/doc/${PF}/html
+ cp -a pkg.ssldoc/* ${D}/usr/share/doc/${PF}/html
+
+ insinto /etc/apache/conf/vhosts
+ doins ${FILESDIR}/ssl.default-vhost.conf
+
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mod_ssl.conf
+}
+
+pkg_postinst() {
+ install -d -o root -g root -m0755 ${ROOT}/etc/apache/conf/ssl
+
+ einfo
+ einfo "Execute \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+ einfo "to have your apache.conf auto-updated for use with this module."
+ einfo "You should then edit your /etc/conf.d/apache file to suit."
+ einfo
+
+ cd ${ROOT}/etc/apache/conf/ssl
+ einfo "Generating self-signed test certificate in /etc/apache/conf/ssl..."
+ einfo "(Ignore any message from the yes command below)"
+ yes "" | ${ROOT}/usr/lib/ssl/mod_ssl/gentestcrt.sh >/dev/null 2>&1
+ einfo
+}
+
+pkg_config() {
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/libssl.so mod_ssl.c ssl_module \
+ define=SSL addconf=conf/addon-modules/mod_ssl.conf
+
+ echo "Include conf/vhosts/ssl.default-vhost.conf" \
+ >> ${ROOT}/etc/apache/conf/apache.conf
+}