summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2003-03-13 22:27:40 +0000
committerDylan Carlson <absinthe@gentoo.org>2003-03-13 22:27:40 +0000
commit82a588d1bb12ae44895749df3a49be1aa05f8de1 (patch)
treeb6cba407e596081d7f38faac6649f17574cb1b59 /net-www/orion
parentNow produce libssl.so too for hppa. (diff)
downloadhistorical-82a588d1bb12ae44895749df3a49be1aa05f8de1.tar.gz
historical-82a588d1bb12ae44895749df3a49be1aa05f8de1.tar.bz2
historical-82a588d1bb12ae44895749df3a49be1aa05f8de1.zip
many fixes. this build should work properly.
Diffstat (limited to 'net-www/orion')
-rw-r--r--net-www/orion/ChangeLog11
-rw-r--r--net-www/orion/files/1.5.2b/orion.init1
-rw-r--r--net-www/orion/files/digest-orion-1.5.2b-r1 (renamed from net-www/orion/files/digest-orion-1.5.2b)0
-rw-r--r--net-www/orion/orion-1.5.2b-r1.ebuild (renamed from net-www/orion/orion-1.5.2b.ebuild)50
4 files changed, 48 insertions, 14 deletions
diff --git a/net-www/orion/ChangeLog b/net-www/orion/ChangeLog
index c8c2147207ea..c8e878cc2c68 100644
--- a/net-www/orion/ChangeLog
+++ b/net-www/orion/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-www/orion
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/orion/ChangeLog,v 1.2 2003/03/11 11:58:01 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/orion/ChangeLog,v 1.3 2003/03/13 22:27:40 absinthe Exp $
+
+*orion-1.5.2b-r1 (13 Mar 2003)
+
+ 13 Mar 2003; Dylan Carlson <absinthe@gentoo.org> ChangeLog :
+
+ Log directory gets properly created now. init.d/conf.d is fixed.
+ Improved post_install notices. Changed JDK requirement to virtual/jdk-1.4.
+ /opt/orion/persistence/ is now created properly. Added necessary delay to
+ 'stop' in /etc/init.d/orion.
11 Mar 2003; Dylan Carlson <absinthe@gentoo.org> ChangeLog :
diff --git a/net-www/orion/files/1.5.2b/orion.init b/net-www/orion/files/1.5.2b/orion.init
index cd5340479b65..503c28367423 100644
--- a/net-www/orion/files/1.5.2b/orion.init
+++ b/net-www/orion/files/1.5.2b/orion.init
@@ -15,6 +15,7 @@ start() {
stop () {
ebegin "Stopping orion"
su - orion -c /opt/orion/sbin/stop_orion.sh
+ sleep 2
eend $?
}
diff --git a/net-www/orion/files/digest-orion-1.5.2b b/net-www/orion/files/digest-orion-1.5.2b-r1
index e69de29bb2d1..e69de29bb2d1 100644
--- a/net-www/orion/files/digest-orion-1.5.2b
+++ b/net-www/orion/files/digest-orion-1.5.2b-r1
diff --git a/net-www/orion/orion-1.5.2b.ebuild b/net-www/orion/orion-1.5.2b-r1.ebuild
index e163891e6b2c..43dadb4d14d0 100644
--- a/net-www/orion/orion-1.5.2b.ebuild
+++ b/net-www/orion/orion-1.5.2b-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/orion/orion-1.5.2b.ebuild,v 1.1 2003/03/11 11:54:15 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/orion/orion-1.5.2b-r1.ebuild,v 1.1 2003/03/13 22:27:40 absinthe Exp $
S=${WORKDIR}/${PN}
@@ -56,13 +56,24 @@ src_install() {
doins ${FILESDIR}/${PV}/start_orion.sh
doins ${FILESDIR}/${PV}/stop_orion.sh
+ cp -a ${FILESDIR}/${PV}/orion.init ${S}/orion
insinto /etc/init.d
- insopts -o orion -g orion -m0750
- doins ${FILESDIR}/${PV}/orion.init
-
+ insopts -m0750
+ doins ${S}/orion
+
+ cp -a ${FILESDIR}/${PV}/orion.conf ${S}/orion
insinto /etc/conf.d
- insopts -o orion -g orion -m0750
- doins ${FILESDIR}/${PV}/orion.conf
+ insopts -m0755
+ doins ${S}/orion
+
+ # CREATE DUMMY LOG & PERSISTENCE DIR
+ touch ${S}/stdout.log
+ touch ${S}/dummy
+ insinto /var/log/${PN}
+ insopts -o orion -g orion
+ doins ${S}/stdout.log
+ insinto /opt/${PN}/persistence
+ doins ${S}/dummy
# INSTALL EXTRA FILES
local dirs="applications database default-web-app demo lib persistence autoupdate.properties"
@@ -92,18 +103,31 @@ src_install() {
pkg_postinst() {
einfo " "
+ einfo " NOTICE! User account created: orion"
+ einfo " Please set a password for this account!"
+ einfo " "
+ einfo " Orion's home directory is: /opt/orion"
+ einfo " In this directory you will have all of your application data,"
+ einfo " settings and configurations."
einfo " "
- einfo " To set an administrative password, execute the"
- einfo " following commands as user 'orion':"
+ einfo " Runtime settings, such as CLASSPATH and desired JDK are set"
+ einfo " in /etc/conf.d/orion"
+ einfo " "
+ einfo " Logs can be found in /var/log/orion/"
+ einfo " "
+ einfo " Executables and libraries are in /usr/share/${PN}/"
+ einfo " "
+ einfo " To set an administrative password, execute the following"
+ einfo " commands as user 'orion':"
einfo " \$ java -jar /usr/share/${PN}/lib/orion.jar -install"
- einfo " "
- einfo " "
- einfo " To start/stop orion, use '/etc/init.d/orion' as root."
einfo " "
+ einfo " To start/stop orion, use '/etc/init.d/orion' as root."
einfo " "
- einfo " To test Orion while it's running, point your web"
- einfo " browser to: http://localhost:8080/"
+ einfo " By default, Orion runs on port 8080. You can change this"
+ einfo " value by editing /opt/orion/config/default-web-site.xml."
einfo " "
+ einfo " To test Orion while it's running, point your web browser to:"
+ einfo " http://localhost:8080/"
einfo " "
echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1
sleep 10