summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-12-30 15:09:04 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-12-30 15:09:04 +0000
commitbfe58adffd4c20fb832499205b57d13fda1b86d7 (patch)
tree3b5ee9964416d50727fffcd122f640a6dd301f7f /net-www/publicfile
parentEbuild enhancement submitted by adam morley <axm135@po.cwru.edu> in 31558 (diff)
downloadhistorical-bfe58adffd4c20fb832499205b57d13fda1b86d7.tar.gz
historical-bfe58adffd4c20fb832499205b57d13fda1b86d7.tar.bz2
historical-bfe58adffd4c20fb832499205b57d13fda1b86d7.zip
Ebuild enhancement submitted by adam morley <axm135@po.cwru.edu> in 31558
Diffstat (limited to 'net-www/publicfile')
-rw-r--r--net-www/publicfile/Manifest5
-rw-r--r--net-www/publicfile/files/digest-publicfile-0.52-r13
-rw-r--r--net-www/publicfile/metadata.xml9
-rw-r--r--net-www/publicfile/publicfile-0.52-r1.ebuild61
4 files changed, 76 insertions, 2 deletions
diff --git a/net-www/publicfile/Manifest b/net-www/publicfile/Manifest
index 4db411ff19af..2c10171d4153 100644
--- a/net-www/publicfile/Manifest
+++ b/net-www/publicfile/Manifest
@@ -1,5 +1,6 @@
-MD5 da8d99bda02b7af73e24a387a8e18a77 ChangeLog 922
+MD5 036b8b6c9c3d87f140a34f1d2bb582e6 ChangeLog 1111
MD5 f51b74cdfd1e7285b5f29fed6ff66b48 publicfile-0.52.ebuild 1416
-MD5 2791608b5b721696be422a1aacda6891 publicfile-0.52-r1.ebuild 1629
+MD5 8dbbef1dac09315d136c31318d861dea publicfile-0.52-r1.ebuild 1628
+MD5 c339473e0ff43da76eb2f2607c441921 metadata.xml 280
MD5 47e5a95f216722242ffb60588a0a821e files/digest-publicfile-0.52 66
MD5 41a5f38461e3450d6a3e1a9a8dd93daf files/digest-publicfile-0.52-r1 193
diff --git a/net-www/publicfile/files/digest-publicfile-0.52-r1 b/net-www/publicfile/files/digest-publicfile-0.52-r1
new file mode 100644
index 000000000000..3c763181263c
--- /dev/null
+++ b/net-www/publicfile/files/digest-publicfile-0.52-r1
@@ -0,0 +1,3 @@
+MD5 e493d69627b4fb2c7c764c0ff34330d7 publicfile-0.52.tar.gz 34892
+MD5 6c4dc7f29f2b9961819f3226bd67840e publicfile-0.52-filetype-diff 1101
+MD5 1f26e232f6d1f99268de2bdf6bd64910 ftp-ls-patch 3280
diff --git a/net-www/publicfile/metadata.xml b/net-www/publicfile/metadata.xml
new file mode 100644
index 000000000000..13bc126c7d91
--- /dev/null
+++ b/net-www/publicfile/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>web-apps</herd>
+<maintainer>
+<email>web-apps@gentoo.org</email>
+<name>Gentoo Web Application Packages Maintainers</name>
+</maintainer>
+</pkgmetadata>
diff --git a/net-www/publicfile/publicfile-0.52-r1.ebuild b/net-www/publicfile/publicfile-0.52-r1.ebuild
new file mode 100644
index 000000000000..0a106876f5fd
--- /dev/null
+++ b/net-www/publicfile/publicfile-0.52-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/publicfile/publicfile-0.52-r1.ebuild,v 1.1 2003/12/30 15:08:32 mholzer Exp $
+
+inherit eutils
+
+DESCRIPTION="publish files through FTP and HTTP"
+HOMEPAGE="http://cr.yp.to/publicfile.html"
+SRC_URI="http://cr.yp.to/publicfile/${P}.tar.gz
+ http://www.ohse.de/uwe/patches/${P}-filetype-diff
+ http://www.publicfile.org/ftp-ls-patch"
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+RDEPEND=">=sys-apps/daemontools-0.70
+ >=sys-apps/ucspi-tcp-0.83"
+
+src_unpack() {
+ unpack publicfile-0.52.tar.gz
+
+ # filetypes in env using daemontools
+ cd ${S}
+ epatch ${DISTDIR}/${P}-filetype-diff
+
+ # "normal" ftp listing
+ epatch ${DISTDIR}/ftp-ls-patch
+
+ echo "gcc ${CFLAGS}" > conf-cc
+ echo "gcc" > conf-ld
+ echo "/usr" > conf-home
+
+ # fix for glibc-2.3.2 errno issue
+ sed -i -e 's|extern int errno;|#include <errno.h>|' error.h
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe ftpd httpd
+ newexe configure publicfile-conf
+ dodoc CHANGES FILES README SYSDEPS TARGETS TODO VERSION
+}
+
+pkg_setup() {
+ groupadd nofiles
+ id ftp || useradd -g nofiles -d /home/public ftp
+ id ftplog || useradd -g nofiles -d /home/public ftplog
+}
+
+pkg_postinst() {
+ /usr/bin/publicfile-conf ftp ftplog /home/public `hostname`
+ echo
+ echo -e "\e[32;01m httpd and ftpd are serving out of /home/public.\033[0m"
+ echo -e "\e[32;01m remember to start the servers with:\033[0m"
+ echo -e "\e[32;01m ln -s /home/public/httpd /home/public/home/ftpd /service\033[0m"
+ echo
+}