summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-09-06 01:54:14 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-09-06 01:54:14 +0000
commit40ef09cd21640a39559f2231598140df53e7b5a5 (patch)
tree40704277b42f9d4bb7e680716e86ce721985fbef /net-www/squidalyser
parentheader fix (diff)
downloadhistorical-40ef09cd21640a39559f2231598140df53e7b5a5.tar.gz
historical-40ef09cd21640a39559f2231598140df53e7b5a5.tar.bz2
historical-40ef09cd21640a39559f2231598140df53e7b5a5.zip
whitespace cleanup
Diffstat (limited to 'net-www/squidalyser')
-rw-r--r--net-www/squidalyser/Manifest4
-rw-r--r--net-www/squidalyser/squidalyser-0.2.55.ebuild24
2 files changed, 14 insertions, 14 deletions
diff --git a/net-www/squidalyser/Manifest b/net-www/squidalyser/Manifest
index 04e240786f0d..fdc990b8654a 100644
--- a/net-www/squidalyser/Manifest
+++ b/net-www/squidalyser/Manifest
@@ -1,3 +1,3 @@
-MD5 4f1639f87240e891fee9650bce40b831 files/digest-squidalyser-0.2.55 145
-MD5 ed4acde89a199c0044c1ba04863507a1 squidalyser-0.2.55.ebuild 2746
MD5 8ab371fbcf98e9f658d45ce687f4d546 ChangeLog 641
+MD5 cd21c53079a05e7803efab53b11175c2 squidalyser-0.2.55.ebuild 2735
+MD5 4f1639f87240e891fee9650bce40b831 files/digest-squidalyser-0.2.55 145
diff --git a/net-www/squidalyser/squidalyser-0.2.55.ebuild b/net-www/squidalyser/squidalyser-0.2.55.ebuild
index e41c5dadba21..0ae99c666870 100644
--- a/net-www/squidalyser/squidalyser-0.2.55.ebuild
+++ b/net-www/squidalyser/squidalyser-0.2.55.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/squidalyser/squidalyser-0.2.55.ebuild,v 1.5 2003/07/13 21:44:10 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/squidalyser/squidalyser-0.2.55.ebuild,v 1.6 2003/09/06 01:54:09 msterret Exp $
inherit eutils
@@ -30,7 +30,7 @@ RDEPEND="net-www/squid
dev-db/mysql
net-www/apache
net-www/squid"
-
+
DEPEND="${RDEPEND}"
src_unpack() {
@@ -40,26 +40,26 @@ src_unpack() {
}
src_install() {
-
+
# Create a user directory for squidalyser. Put the squidparse and sql scripts into it
dodir /usr/share/squidalyser/squidparse
cp ${S}/squidparse/squidparse.pl ${D}/usr/share/squidalyser/squidparse/squidparse.pl
dodir /etc/squidalyser
cp ${S}/squidparse/squidalyser.conf ${D}/etc/squidalyser/squidalyser.conf
-
+
dodir /usr/share/squidalyser/sql
cp ${S}/sql/* ${D}/usr/share/squidalyser/sql
dodir /usr/share/squidalyser/docs
cp ${S}/docs/* ${D}/usr/share/squidalyser/docs
-
+
# Put the apache scripts under the apache directory
chown apache ${S}/cgi-bin/*
chmod 755 ${S}/cgi-bin/*
-
+
dodir /home/httpd/cgi-bin
cp ${S}/cgi-bin/* ${D}/home/httpd/cgi-bin
dodir /home/httpd/icons
- cp ${S}/icons/* ${D}/home/httpd/icons
+ cp ${S}/icons/* ${D}/home/httpd/icons
}
pkg_preinst() {
@@ -79,23 +79,23 @@ pkg_postinst() {
ewarn "configure mysql"
mysql --execute="drop database squid"
mysql --execute="create database squid"
- mysql --execute="grant all privileges on squid.* to squidalyser@localhost identified by 'tr!red$';"
+ mysql --execute="grant all privileges on squid.* to squidalyser@localhost identified by 'tr!red$';"
mysql squid < /usr/share/squidalyser/sql/squidalyser.sql
mysql squid --execute="delete from logfile"
-
+
ewarn "update crontab"
# Update the crontab for the squidparse routine
spcount=`grep -c squidparse.pl /etc/crontab`
- if [ ${spcount} -gt 1 ]
+ if [ ${spcount} -gt 1 ]
then
ewarn "More than one entry in /etc/crontab. Please check."
- elif [ ${spcount} -eq 1 ]
+ elif [ ${spcount} -eq 1 ]
then
ewarn "squidparse.pl entry already in /etc/crontab, leaving alone"
else
echo "0 3 * * * root /usr/share/squidalyser/squidparse/squidparse.pl" >> /etc/crontab
fi
-
+
ewarn "Running squidparse for first time, this may take several minutes"
/usr/share/squidalyser/squidparse/squidparse.pl
}