summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Laue <brad@gentoo.org>2003-06-02 21:40:48 +0000
committerBrad Laue <brad@gentoo.org>2003-06-02 21:40:48 +0000
commitabd8f05c519651fdafb6a2134fdac75b4acb3c9f (patch)
treef0da3fee8e85b81cce6633a4df6dcd675e1b9833 /net-www
parentInitial import of mozilla-firebird 0.6. Please report anomalous behavior. (diff)
downloadhistorical-abd8f05c519651fdafb6a2134fdac75b4acb3c9f.tar.gz
historical-abd8f05c519651fdafb6a2134fdac75b4acb3c9f.tar.bz2
historical-abd8f05c519651fdafb6a2134fdac75b4acb3c9f.zip
Initial import of mozilla-firebird 0.6. Please report anomalous behavior.
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mozilla-firebird/Manifest5
-rw-r--r--net-www/mozilla-firebird/files/MozillaFirebird20
-rw-r--r--net-www/mozilla-firebird/files/digest-mozilla-firebird-0.61
-rw-r--r--net-www/mozilla-firebird/mozilla-firebird-0.6.ebuild147
4 files changed, 171 insertions, 2 deletions
diff --git a/net-www/mozilla-firebird/Manifest b/net-www/mozilla-firebird/Manifest
index f9f8dc717dc7..ec970f3d3be1 100644
--- a/net-www/mozilla-firebird/Manifest
+++ b/net-www/mozilla-firebird/Manifest
@@ -1,3 +1,4 @@
-MD5 04bd55fc0524d4e8d89c4cfe18e5e2aa mozilla-firebird-0.6.ebuild 4024
-MD5 cafbba45d2989c7d604742301cbb8c90 files/MozillaFirebird 754
+MD5 8ad1a9937f61623d3014086832409563 mozilla-firebird-0.6.ebuild 3901
+MD5 4746824a56acf37467fdb5eff4f133bf ChangeLog 300
+MD5 6e4352482ed149b3b9aca78d83de1124 files/MozillaFirebird 753
MD5 78b9eef353e1aff29cef379e4de6b9fa files/digest-mozilla-firebird-0.6 81
diff --git a/net-www/mozilla-firebird/files/MozillaFirebird b/net-www/mozilla-firebird/files/MozillaFirebird
new file mode 100644
index 000000000000..6e5054da0eb6
--- /dev/null
+++ b/net-www/mozilla-firebird/files/MozillaFirebird
@@ -0,0 +1,20 @@
+#!/bin/sh
+
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firebird/files/MozillaFirebird,v 1.1 2003/06/02 21:40:42 brad Exp $
+
+# This is the Gentoo Phoenix startup script
+# Additions, suggestions?
+# contact phoen][x <phoenix@gentoo.org>
+
+export MOZILLA_FIVE_HOME="/usr/lib/MozillaFirebird"
+FIREBIRD_PATH="/usr/lib/MozillaFirebird"
+
+if [ -z "`/bin/ps x | /bin/grep \"[0-9] ${FIREBIRD_PATH}/MozillaFirebird-bin\"`" ]; then
+ # No MozillaFirebird running
+ ${FIREBIRD_PATH}/MozillaFirebird $@
+else
+ # MozillaFirebird running - open a new window
+ ${FIREBIRD_PATH}/MozillaFirebird -remote "openURL($@ ,new-window)"
+fi
diff --git a/net-www/mozilla-firebird/files/digest-mozilla-firebird-0.6 b/net-www/mozilla-firebird/files/digest-mozilla-firebird-0.6
new file mode 100644
index 000000000000..7c8e90ff1655
--- /dev/null
+++ b/net-www/mozilla-firebird/files/digest-mozilla-firebird-0.6
@@ -0,0 +1 @@
+MD5 de52dd03f8628724f14f517cd6346755 MozillaFirebird-0.6-source.tar.bz2 31992582
diff --git a/net-www/mozilla-firebird/mozilla-firebird-0.6.ebuild b/net-www/mozilla-firebird/mozilla-firebird-0.6.ebuild
new file mode 100644
index 000000000000..cbdadd7518cd
--- /dev/null
+++ b/net-www/mozilla-firebird/mozilla-firebird-0.6.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+inherit makeedit flag-o-matic gcc nsplugins
+
+# Added to get MozillaFirebird to compile on sparc.
+replace-sparc64-flags
+
+EMVER="0.65.2"
+IPCVER="1.0.0.1"
+
+S=${WORKDIR}/mozilla
+
+DESCRIPTION="The Mozilla Firebird Web Browser"
+HOMEPAGE="http://www.mozilla.org/projects/firebird/"
+SRC_URI="http://komodo.mozilla.org/pub/firebird/releases/${PV}/MozillaFirebird-${PV}-source.tar.bz2"
+
+KEYWORDS="~x86 ~ppc ~sparc"
+SLOT="0"
+LICENSE="MPL-1.1 | NPL-1.1"
+IUSE="java gtk2 ipv6"
+
+RDEPEND="virtual/x11
+ >=dev-libs/libIDL-0.8.0
+ >=gnome-base/ORBit-0.5.10-r1
+ virtual/xft
+ >=sys-libs/zlib-1.1.4
+ >=media-libs/jpeg-6b
+ >=media-libs/libmng-1.0.0
+ >=media-libs/libpng-1.2.1
+ >=sys-apps/portage-2.0.36
+ dev-libs/expat
+ app-arch/zip
+ app-arch/unzip
+ ( gtk2? >=x11-libs/gtk+-2.1.1 :
+ =x11-libs/gtk+-1.2* )
+ java? ( virtual/jre )
+ !net-www/MozillaFirebird-bin"
+
+DEPEND="${RDEPEND}
+ virtual/glibc
+ dev-lang/perl
+ dev-util/cvs
+ java? ( >=dev-java/java-config-0.2.0 )"
+
+# needed by src_compile() and src_install()
+export MOZ_PHOENIX=1
+export MOZ_CALENDAR=0
+export MOZ_ENABLE_XFT=1
+
+src_compile() {
+ local myconf="--disable-composer \
+ --with-x \
+ --with-system-jpeg \
+ --with-system-zlib \
+ --with-system-png \
+ --with-system-mng \
+ --disable-mailnews \
+ --disable-calendar \
+ --enable-xft \
+ --disable-pedantic \
+ --disable-svg \
+ --enable-mathml \
+ --without-system-nspr \
+ --enable-nspr-autoconf \
+ --enable-xsl \
+ --enable-crypto \
+ --enable-xinerama=no \
+ --with-java-supplement \
+ --with-pthreads \
+ --with-default-mozilla-five-home=/usr/lib/MozillaFirebird \
+ --with-user-appdir=.phoenix \
+ --disable-jsd \
+ --disable-accessibility \
+ --disable-tests \
+ --disable-debug \
+ --disable-dtd-debug \
+ --disable-logging \
+ --enable-reorder \
+ --enable-strip \
+ --enable-strip-libs \
+ --enable-cpp-rtti \
+ --enable-xterm-updates \
+ --enable-optimize=-O2 \
+ --disable-ldap \
+ --disable-toolkit-qt \
+ --disable-toolkit-xlib"
+
+ if [ -n "`use gtk2`" ] ; then
+ myconf="${myconf} --enable-toolkit-gtk2 \
+ --enable-default-toolkit=gtk2 \
+ --disable-toolkit-gtk"
+ else
+ myconf="${myconf} --enable-toolkit-gtk \
+ --enable-default-toolkit=gtk \
+ --disable-toolkit-gtk2"
+ fi
+
+ if [ -n "`use ipv6`" ] ; then
+ myconf="${myconf} --enable-ipv6"
+ fi
+
+ # Crashes on start when compiled with -fomit-frame-pointer
+ filter-flags -fomit-frame-pointer
+ append-flags -s -fforce-addr
+
+ if [ "$(gcc-major-version)" -eq "3" ]; then
+ # Currently gcc-3.2 or older do not work well if we specify "-march"
+ # and other optimizations for pentium4.
+ if [ "$(gcc-minor-version)" -lt "3" ]; then
+ replace-flags -march=pentium4 -march=pentium3
+ fi
+
+ # Enable us to use flash, etc plugins compiled with gcc-2.95.3
+ if [ "${ARCH}" = "x86" ]; then
+ myconf="${myconf} --enable-old-abi-compat-wrappers"
+ fi
+ fi
+
+ econf ${myconf} || die
+
+ edit_makefiles
+ emake MOZ_PHOENIX=1 || die
+}
+
+src_install() {
+ # Plugin path creation
+ PLUGIN_DIR="/usr/lib/nsbrowser/plugins"
+ dodir /${PLUGIN_DIR}
+
+ dodir /usr/lib
+ dodir /usr/lib/MozillaFirebird
+ cp -RL --no-preserve=links ${S}/dist/bin/* ${D}/usr/lib/MozillaFirebird
+
+ #fix permissions
+ chown -R root.root ${D}/usr/lib/MozillaFirebird
+
+ # Plugin path setup (rescuing the existent plugins)
+ src_mv_plugins /usr/lib/${PN}/plugins
+
+ dobin ${FILESDIR}/MozillaFirebird
+}
+
+pkg_preinst() {
+ # Remove the old plugins dir
+ pkg_mv_plugins /usr/lib/${PN}/plugins
+}