summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2004-07-31 14:15:58 +0000
committerChuck Short <zul@gentoo.org>2004-07-31 14:15:58 +0000
commitfdb3dc680b2a48e61edcfcbea8751f238299e9d6 (patch)
treec31a20b2db224dbf54e811952c5af86c82b4ee8c /net-www
parentNew digest. (diff)
downloadhistorical-fdb3dc680b2a48e61edcfcbea8751f238299e9d6.tar.gz
historical-fdb3dc680b2a48e61edcfcbea8751f238299e9d6.tar.bz2
historical-fdb3dc680b2a48e61edcfcbea8751f238299e9d6.zip
Added dbm_key support. Closes #58624.
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mod_ssl/ChangeLog5
-rw-r--r--net-www/mod_ssl/Manifest14
-rw-r--r--net-www/mod_ssl/mod_ssl-2.8.19.ebuild8
3 files changed, 17 insertions, 10 deletions
diff --git a/net-www/mod_ssl/ChangeLog b/net-www/mod_ssl/ChangeLog
index b999800163c9..daa93967e918 100644
--- a/net-www/mod_ssl/ChangeLog
+++ b/net-www/mod_ssl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-www/mod_ssl
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/ChangeLog,v 1.48 2004/07/28 05:27:43 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/ChangeLog,v 1.49 2004/07/31 14:15:58 zul Exp $
+
+ 02 Aug 2004; Chuck Short <zul@gentoo.org> mod_ssl-2.8.19.ebuild:
+ Added dbm_key detection support. Closes #58624.
28 Jul 2004; Joshua Kinard <kumba@gentoo.org> mod_ssl-2.8.19.ebuild:
Marked stable on mips.
diff --git a/net-www/mod_ssl/Manifest b/net-www/mod_ssl/Manifest
index 589d5b1e7ef5..40571c391709 100644
--- a/net-www/mod_ssl/Manifest
+++ b/net-www/mod_ssl/Manifest
@@ -1,11 +1,11 @@
-MD5 0da8367f736aea2f309f1604d59ff60a ChangeLog 5769
-MD5 d2da0e45d7e39184d1cb7abbe3879086 metadata.xml 159
-MD5 7f02b177b06559b9aab3444c173343bc mod_ssl-2.8.17.ebuild 2183
MD5 9eba5451e8883ea7e9cedf5b02c97e62 mod_ssl-2.8.18.ebuild 2183
-MD5 51ef19ad84bebcbb4f67b68d92802a2e mod_ssl-2.8.19.ebuild 2174
+MD5 7f02b177b06559b9aab3444c173343bc mod_ssl-2.8.17.ebuild 2183
+MD5 8cd16baaa162f56f1c3c95c34e3927aa mod_ssl-2.8.19.ebuild 2278
+MD5 d4baf648793639708025ead9cf4a6f80 ChangeLog 5885
+MD5 d2da0e45d7e39184d1cb7abbe3879086 metadata.xml 159
+MD5 8270779f233bc311118f53ebce7338e7 files/ssl.default-vhost.conf 6985
+MD5 e92c5d69747a08ae94986ee6d3b024a2 files/mod_ssl.conf 2451
+MD5 dd92adba34e6b36ef6fd2750869e1a18 files/gentestcrt.sh 8801
MD5 9ba9eb8eced950cd59cb8dadd090f908 files/digest-mod_ssl-2.8.17 73
MD5 f53031df0c0d1a5bd75a9151d0810e9e files/digest-mod_ssl-2.8.18 73
-MD5 dd92adba34e6b36ef6fd2750869e1a18 files/gentestcrt.sh 8801
-MD5 e92c5d69747a08ae94986ee6d3b024a2 files/mod_ssl.conf 2451
-MD5 8270779f233bc311118f53ebce7338e7 files/ssl.default-vhost.conf 6985
MD5 89239995d079a1bd9abc580e2264c71b files/digest-mod_ssl-2.8.19 73
diff --git a/net-www/mod_ssl/mod_ssl-2.8.19.ebuild b/net-www/mod_ssl/mod_ssl-2.8.19.ebuild
index 43a402222a77..5cb30a404229 100644
--- a/net-www/mod_ssl/mod_ssl-2.8.19.ebuild
+++ b/net-www/mod_ssl/mod_ssl-2.8.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/mod_ssl-2.8.19.ebuild,v 1.5 2004/07/28 05:27:43 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/mod_ssl-2.8.19.ebuild,v 1.6 2004/07/31 14:15:58 zul Exp $
MY_P=${P}-1.3.31
S=${WORKDIR}/${MY_P}
@@ -24,9 +24,13 @@ src_unpack() {
}
src_compile() {
+ if has_version '=sys-libs/gdbm-1.8.3*' ; then
+ myconf = "--enable-rule=SSL_SDBM"
+ fi
+
SSL_BASE=SYSTEM \
./configure \
- --with-apxs=/usr/sbin/apxs || die "bad ./configure"
+ --with-apxs=/usr/sbin/apxs ${myconf} || die "bad ./configure"
make || die "compile problem"
}