summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-23 22:09:47 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-23 22:09:47 +0000
commit878b34e30cf57acb9212c0d0eec9be952b69fa7e (patch)
tree7cbb13ee66b8f2f08d45190b90541f83e951eec2 /sci-biology/bioperl-run/bioperl-run-1.4.ebuild
parentx86. (diff)
downloadhistorical-878b34e30cf57acb9212c0d0eec9be952b69fa7e.tar.gz
historical-878b34e30cf57acb9212c0d0eec9be952b69fa7e.tar.bz2
historical-878b34e30cf57acb9212c0d0eec9be952b69fa7e.zip
Moved from app-sci/bioperl-run to sci-biology/bioperl-run.
Diffstat (limited to 'sci-biology/bioperl-run/bioperl-run-1.4.ebuild')
-rw-r--r--sci-biology/bioperl-run/bioperl-run-1.4.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sci-biology/bioperl-run/bioperl-run-1.4.ebuild b/sci-biology/bioperl-run/bioperl-run-1.4.ebuild
new file mode 100644
index 000000000000..f6b9aaae4247
--- /dev/null
+++ b/sci-biology/bioperl-run/bioperl-run-1.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/bioperl-run/bioperl-run-1.4.ebuild,v 1.1 2004/12/23 22:09:47 ribosome Exp $
+
+inherit perl-module eutils
+CATEGORY="app-sci"
+
+DESCRIPTION="collection of tools for bioinformatics, genomics and life science research : subset required to run analyses"
+HOMEPAGE="http://www.bioperl.org/"
+#SRC_URI="http://www.cpan.org/modules/by-module/Bio/${P}.tar.gz"
+SRC_URI="http://www.bioperl.org/ftp/DIST/${P}.tar.gz"
+
+LICENSE="Artistic GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc"
+IUSE=""
+
+RDEPEND="
+ dev-perl/Algorithm-Diff
+ dev-perl/File-Temp
+ dev-perl/IO-String
+ dev-perl/XML-Parser"
+
+DEPEND=""
+
+src_compile() {
+ perl-module_src_compile || die "compile failed"
+ # make test
+ #perl-module_src_test || die "src test failed"
+}
+
+src_install() {
+ mydoc="AUTHORS BUGS INSTALL.PROGRAMS README"
+ perl-module_src_install
+
+ # bioperl scripts and examples
+ einfo 'Adding bioperl examples and scripts to /usr/share/...'
+ dodir /usr/share/${PF}/scripts
+ #insinto /usr/share/${PF}/scripts
+ cd ${S}/scripts/
+ tar cf - ./ | ( cd ${D}/usr/share/${PF}/scripts; tar xf -)
+ dodir /usr/share/${PF}/examples
+ cd ${S}/examples/
+ tar cf - ./ | ( cd ${D}/usr/share/${PF}/examples; tar xf -)
+ cd ${S}
+
+}