summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-01-23 10:51:14 +0000
committerJustin Lecher <jlec@gentoo.org>2013-01-23 10:51:14 +0000
commit6dafb5deea3a5531b98b52bc5548aa9a41c7473e (patch)
tree3ff9ced0c0e1fb43745ee480a76b41a71f4b2905 /sci-biology/samtools/samtools-0.1.18-r1.ebuild
parentStable for amd64, wrt bug #452934 (diff)
downloadhistorical-6dafb5deea3a5531b98b52bc5548aa9a41c7473e.tar.gz
historical-6dafb5deea3a5531b98b52bc5548aa9a41c7473e.tar.bz2
historical-6dafb5deea3a5531b98b52bc5548aa9a41c7473e.zip
sci-biology/samtools: Drop old; use pkg-config to check for libncurses
Package-Manager: portage-2.2.0_alpha159/cvs/Linux x86_64 Manifest-Sign-Key: 0x8009D6F070EB7916
Diffstat (limited to 'sci-biology/samtools/samtools-0.1.18-r1.ebuild')
-rw-r--r--sci-biology/samtools/samtools-0.1.18-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sci-biology/samtools/samtools-0.1.18-r1.ebuild b/sci-biology/samtools/samtools-0.1.18-r1.ebuild
new file mode 100644
index 000000000000..30ae8d10d078
--- /dev/null
+++ b/sci-biology/samtools/samtools-0.1.18-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/samtools/samtools-0.1.18-r1.ebuild,v 1.1 2013/01/23 10:51:13 jlec Exp $
+
+EAPI=5
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="Utilities for SAM (Sequence Alignment/Map), a format for large nucleotide sequence alignments"
+HOMEPAGE="http://samtools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+
+src_prepare() {
+ sed \
+ -e '/CC/s:=:?=:g' \
+ -e "/LIBCURSES/s:=.*$:= $(pkg-config --libs ncurses):g" \
+ -e '/^CFLAGS=/d' \
+ -e "s/\$(CC) \$(CFLAGS)/& \$(LDFLAGS)/g" \
+ -e "s/-shared/& \$(LDFLAGS)/" \
+ -i "${S}"/{Makefile,misc/Makefile} || die #358563
+ sed -i 's~/software/bin/python~/usr/bin/env python~' "${S}"/misc/varfilter.py || die
+
+ tc-export CC
+}
+
+src_compile() {
+ emake dylib
+ emake
+}
+
+src_install() {
+ dobin samtools $(find misc -type f -executable)
+
+ dolib.so libbam.so.1
+ dosym libbam.so.1 /usr/$(get_libdir)/libbam.so
+
+ insinto /usr/include/bam
+ doins bam.h bgzf.h faidx.h kaln.h khash.h kprobaln.h kseq.h ksort.h sam.h
+
+ doman ${PN}.1
+ dodoc AUTHORS ChangeLog NEWS
+
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r examples
+ fi
+}