summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2008-06-17 19:34:50 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2008-06-17 19:34:50 +0000
commita0ea6e7654c6a653f925180d52a6c8742a4d7da2 (patch)
tree0867b97ecb9ce2d4b001774e6d154e2cee3cd42a /sci-biology
parentAdd alternative mirror (diff)
downloadhistorical-a0ea6e7654c6a653f925180d52a6c8742a4d7da2.tar.gz
historical-a0ea6e7654c6a653f925180d52a6c8742a4d7da2.tar.bz2
historical-a0ea6e7654c6a653f925180d52a6c8742a4d7da2.zip
Version bump and add gcc-4.3 patch, bug 227597, thanks to Marek Miller
Package-Manager: portage-2.1.5.5
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/amos/Manifest5
-rw-r--r--sci-biology/amos/amos-2.0.7.ebuild (renamed from sci-biology/amos/amos-2.0.5.ebuild)10
-rw-r--r--sci-biology/amos/files/amos-2.0.7-gcc43.patch84
3 files changed, 95 insertions, 4 deletions
diff --git a/sci-biology/amos/Manifest b/sci-biology/amos/Manifest
index 17294095b527..79c1fded0fa2 100644
--- a/sci-biology/amos/Manifest
+++ b/sci-biology/amos/Manifest
@@ -1,4 +1,5 @@
-DIST amos-2.0.5.tar.gz 1749163 RMD160 1984f30ff209e810c85f19b28baf80274890b386 SHA1 16aa94e6052f98232065a1b8eae4043390dd5cd3 SHA256 f3be4e91853f6958d5d5dcfcb8505916dd235b55bfa6e544964999af983b98a1
-EBUILD amos-2.0.5.ebuild 729 RMD160 b9c8dd6b6db22e4cc0628d04bf277659ca6b3733 SHA1 2ecd353bac4c5bf2ae3b5693d10427f1ba690d4e SHA256 540227d83f0656ac91682b044ce1aa9d302695f3ae3747541fdb8dc700721c16
+AUX amos-2.0.7-gcc43.patch 2255 RMD160 6db9a99e8dcb117f8270b3dc66ffae2f5bd3574e SHA1 bb1906a35238dab257bf8fda04861b5b335c8122 SHA256 9feb4d00fc2db3b598da900f062727df436486c2f24bff841117c1128ccdce59
+DIST amos-2.0.7.tar.gz 1800639 RMD160 a4f86474351f13397f568171fd26d3f2479be9dd SHA1 9def28ef77ad11350dfa7a60ff216b5160127838 SHA256 6da8f5d0ec1039edddbc5f8fe268d20f1dd700d48cb93412ee9f84aaf1408674
+EBUILD amos-2.0.7.ebuild 817 RMD160 c935a6b56c682be86653253a9f534e8a818860e2 SHA1 5d26aa742a31989f496819780fe7539ec67df26f SHA256 8782461365992872a9f9fbc242bde3773552e753f8a770531ffcc47c6ca1ffd7
MISC ChangeLog 365 RMD160 0caeb1bf3a3a52be56e8872323f3e0cd89c25269 SHA1 2807f930d328fc36c7cace3595f5d54f2b7284dc SHA256 fd2d63d7994185f16a16fbec25df1bf92912f883eccd6466bf95aa62f041416d
MISC metadata.xml 259 RMD160 d9d81b67d635fabd81aef8ae0edf971211ae9072 SHA1 8e32f751c67ff891fa35405a2cf6fb33752d6eb1 SHA256 541c3fbcf299d9a8ccf4132ee61f9e53a5d737cefdaa6fdc77764d8d4c7f3110
diff --git a/sci-biology/amos/amos-2.0.5.ebuild b/sci-biology/amos/amos-2.0.7.ebuild
index 3fa12ba006e4..ce1038f8c9a5 100644
--- a/sci-biology/amos/amos-2.0.5.ebuild
+++ b/sci-biology/amos/amos-2.0.7.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/amos/amos-2.0.5.ebuild,v 1.1 2008/05/26 14:47:52 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/amos/amos-2.0.7.ebuild,v 1.1 2008/06/17 19:34:49 weaver Exp $
EAPI="1"
-inherit qt3
+inherit qt3 eutils
DESCRIPTION="A Modular, Open-Source whole genome assembler"
HOMEPAGE="http://amos.sourceforge.net/"
@@ -19,6 +19,12 @@ RDEPEND="${DEPEND}
dev-perl/DBI
sci-biology/mummer"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
+
src_compile() {
econf || die "econf failed"
# TODO: fix parallel make. Notified upstream
diff --git a/sci-biology/amos/files/amos-2.0.7-gcc43.patch b/sci-biology/amos/files/amos-2.0.7-gcc43.patch
new file mode 100644
index 000000000000..e9cfcf92c1d2
--- /dev/null
+++ b/sci-biology/amos/files/amos-2.0.7-gcc43.patch
@@ -0,0 +1,84 @@
+--- src/Foundation/ConfigFile.cc.orig 2008-06-16 18:12:13.000000000 +0000
++++ src/Foundation/ConfigFile.cc 2008-06-16 18:12:28.000000000 +0000
+@@ -35,6 +35,8 @@
+
+ #include "ConfigFile.hh"
+
++#include <cstring>
++
+ //! Constructor
+ /*! Creates a ConfigFile class. Also loads, parses, and resolves
+ * variable substitution.
+
+--- src/Foundation/Logger.cc.orig 2008-06-16 18:13:45.000000000 +0000
++++ src/Foundation/Logger.cc 2008-06-16 18:14:03.000000000 +0000
+@@ -58,6 +58,8 @@
+ */
+
+ #include "Logger.hh"
++#include <cstdlib>
++
+
+ //! Sets default values for class
+ /*! Note: Log is disabled until a filter level is set\n
+
+--- src/Foundation/OptionResult.cc.orig 2008-06-16 18:15:41.000000000 +0000
++++ src/Foundation/OptionResult.cc 2008-06-16 18:15:51.000000000 +0000
+@@ -9,6 +9,8 @@
+ //! @brief OptionResult class implementation
+
+ #include "OptionResult.hh"
++#include <cstdlib>
++
+
+ //! Sets defaults for all results
+ OptionResult::OptionResult(const std::string & optionHelp)
+
+--- src/Foundation/Options.cc.orig 2008-06-16 18:17:01.000000000 +0000
++++ src/Foundation/Options.cc 2008-06-16 18:17:11.000000000 +0000
+@@ -26,6 +26,8 @@
+ */
+
+ #include "Options.hh"
++#include <cstring>
++
+
+ //! Constructor takes command line options in standard argc, argv format
+ /*! Initializes application name, filespec, and invocation
+
+--- src/Align/missing-reads.cc.orig 2008-06-16 18:22:21.000000000 +0000
++++ src/Align/missing-reads.cc 2008-06-16 18:22:34.000000000 +0000
+@@ -9,6 +9,8 @@
+ #include <vector>
+ #include <algorithm>
+ #include <cassert>
++#include <cstring>
++
+ using namespace std;
+
+ const int MAX_LINE = 1000;
+
+--- src/Utils/runAmos.cc.orig 2008-06-16 18:30:30.000000000 +0000
++++ src/Utils/runAmos.cc 2008-06-16 18:30:42.000000000 +0000
+@@ -18,6 +18,8 @@
+ #include <dirent.h>
+ #include <fcntl.h>
+ #include <iostream>
++#include <cstdlib>
++
+
+ #define MAX_STRING 256 // length of various char*s in file
+
+
+--- src/bankViewer/HistogramWindow.cc.orig 2008-06-16 18:36:40.000000000 +0000
++++ src/bankViewer/HistogramWindow.cc 2008-06-16 18:37:04.000000000 +0000
+@@ -1,6 +1,8 @@
+ #include "HistogramWindow.hh"
+ #include "HistogramWidget.hh"
+ #include "InsertStats.hh"
++#include <cstdlib>
++
+
+ #include <qspinbox.h>
+ #include <qcheckbox.h>
+