summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-03-12 21:39:00 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-03-12 21:39:00 +0000
commit11f69f572056739354d922e9d31dc3b5387d884e (patch)
tree8420fd642a4933a513f7810e049539dc98b80f31 /sci-calculators/wcalc/wcalc-2.2.1.ebuild
parentCreate a desktop entry. Closes bug #97189, by Sebastian <sebastian_ml at gmx.... (diff)
downloadhistorical-11f69f572056739354d922e9d31dc3b5387d884e.tar.gz
historical-11f69f572056739354d922e9d31dc3b5387d884e.tar.bz2
historical-11f69f572056739354d922e9d31dc3b5387d884e.zip
Version bump. This fixes bug #125477.
Package-Manager: portage-2.1_pre5-r4
Diffstat (limited to 'sci-calculators/wcalc/wcalc-2.2.1.ebuild')
-rw-r--r--sci-calculators/wcalc/wcalc-2.2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-calculators/wcalc/wcalc-2.2.1.ebuild b/sci-calculators/wcalc/wcalc-2.2.1.ebuild
new file mode 100644
index 000000000000..ad401541018c
--- /dev/null
+++ b/sci-calculators/wcalc/wcalc-2.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/wcalc/wcalc-2.2.1.ebuild,v 1.1 2006/03/12 21:39:00 markusle Exp $
+
+DESCRIPTION="A flexible command-line scientific calculator"
+HOMEPAGE="http://w-calc.sourceforge.net"
+SRC_URI="mirror://sourceforge/w-calc/Wcalc-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc-macos"
+IUSE="readline"
+
+DEPEND="readline? ( >=sys-libs/readline-4.3-r4 )
+ >=dev-libs/mpfr-2.1
+ dev-libs/gmp"
+
+S="${WORKDIR}"/Wcalc-${PV}
+
+src_compile() {
+ econf $(use_with readline) || die "Configuration failed."
+ emake || die "Compilation failed."
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog NEWS README
+
+ # Wcalc icons
+ insinto /usr/share/pixmaps
+ newins w.png wcalc.png
+ newins Wred.png wcalc-red.png
+}