summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-10-19 09:52:01 +0000
committerJustin Lecher <jlec@gentoo.org>2012-10-19 09:52:01 +0000
commit0e07df2d82e542b34a7626ee984999e46430b633 (patch)
treebfafbcb32d08b0733e82430d8ee2fd0bed716f9e /sci-chemistry/makecif/makecif-5.6.6.ebuild
parentsci-chemistry/gromacs: Remove virtual/fortran and always call fortran-2_pkg_s... (diff)
downloadhistorical-0e07df2d82e542b34a7626ee984999e46430b633.tar.gz
historical-0e07df2d82e542b34a7626ee984999e46430b633.tar.bz2
historical-0e07df2d82e542b34a7626ee984999e46430b633.zip
sci-chemistry/makecif: Remove virtual/fortran and always call fortran-2_pkg_setup as intend by the updated fortran-2.eclass
Package-Manager: portage-2.2.0_alpha141/cvs/Linux x86_64 Manifest-Sign-Key: 0x70EB7916
Diffstat (limited to 'sci-chemistry/makecif/makecif-5.6.6.ebuild')
-rw-r--r--sci-chemistry/makecif/makecif-5.6.6.ebuild18
1 files changed, 8 insertions, 10 deletions
diff --git a/sci-chemistry/makecif/makecif-5.6.6.ebuild b/sci-chemistry/makecif/makecif-5.6.6.ebuild
index 2ac244edf3be..0bcb9e1d97e3 100644
--- a/sci-chemistry/makecif/makecif-5.6.6.ebuild
+++ b/sci-chemistry/makecif/makecif-5.6.6.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/makecif/makecif-5.6.6.ebuild,v 1.10 2011/06/29 11:51:15 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/makecif/makecif-5.6.6.ebuild,v 1.11 2012/10/19 09:52:00 jlec Exp $
-EAPI=3
+EAPI=4
inherit eutils fortran-2 toolchain-funcs
@@ -17,10 +17,9 @@ IUSE=""
S="${WORKDIR}"/${PN}
-DEPEND="
+DEPEND=""
+RDEPEND="
!>=sci-chemistry/refmac-5.6
- virtual/fortran"
-RDEPEND="${DEPEND}
sci-libs/monomer-db"
src_prepare() {
@@ -31,11 +30,10 @@ src_compile() {
cd src && emake clean
emake \
BLANC_FORT="$(tc-getFC) ${FFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- || die
+ LDFLAGS="${LDFLAGS}"
}
src_install() {
- dobin bin/* || die
- dodoc readme || die
+ dobin bin/*
+ dodoc readme
}