summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-05-16 12:56:16 +0000
committerJustin Lecher <jlec@gentoo.org>2010-05-16 12:56:16 +0000
commit213b168390ed36a30ec9d3a4640518950b3b4caf (patch)
treed24cecf864c3a64df37685b9deeccfca6e6098c6 /sci-chemistry
parentRESTRICT PY ABI 2.5 (diff)
downloadhistorical-213b168390ed36a30ec9d3a4640518950b3b4caf.tar.gz
historical-213b168390ed36a30ec9d3a4640518950b3b4caf.tar.bz2
historical-213b168390ed36a30ec9d3a4640518950b3b4caf.zip
Version Bump
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/refmac/ChangeLog8
-rw-r--r--sci-chemistry/refmac/files/5.6.0075-allow-dynamic-linking.patch45
-rw-r--r--sci-chemistry/refmac/refmac-5.6.0075.ebuild70
3 files changed, 122 insertions, 1 deletions
diff --git a/sci-chemistry/refmac/ChangeLog b/sci-chemistry/refmac/ChangeLog
index 6dcfcb34a444..d6716faaab6d 100644
--- a/sci-chemistry/refmac/ChangeLog
+++ b/sci-chemistry/refmac/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/refmac
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/refmac/ChangeLog,v 1.5 2010/05/13 10:06:31 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/refmac/ChangeLog,v 1.6 2010/05/16 12:56:16 jlec Exp $
+
+*refmac-5.6.0075 (16 May 2010)
+
+ 16 May 2010; Justin Lecher <jlec@gentoo.org>
+ +files/5.6.0075-allow-dynamic-linking.patch, +refmac-5.6.0075.ebuild:
+ Version bump
*refmac-5.5.0110 (13 May 2010)
diff --git a/sci-chemistry/refmac/files/5.6.0075-allow-dynamic-linking.patch b/sci-chemistry/refmac/files/5.6.0075-allow-dynamic-linking.patch
new file mode 100644
index 000000000000..e86a3a69dfd8
--- /dev/null
+++ b/sci-chemistry/refmac/files/5.6.0075-allow-dynamic-linking.patch
@@ -0,0 +1,45 @@
+diff --git a/makefile_refmac.inc1 b/makefile_refmac.inc1
+index 97791e0..6c43c5d 100644
+--- a/makefile_refmac.inc1
++++ b/makefile_refmac.inc1
+@@ -83,9 +83,7 @@ messy_pdb.o \
+ bridge.o \
+ i0.o \
+ i1.o \
+-chbevl.o \
+-$(LLIBCIF) \
+-$(LLIBLAPACK)
++chbevl.o
+
+
+ SUBL = \
+@@ -118,9 +116,8 @@ cell_symm_subrs.o \
+ iheap_sort.o \
+ linalgebra.o \
+ math_refmac.o \
+-subnumrec.o \
+-$(LLIBLAPACK) \
+-$(LLIBCCP)
++subnumrec.o
++
+
+ #--------------------------------------------------------------------------------
+
+@@ -188,7 +185,7 @@ linalgebra_f90.o: linalgebra_f90.f90
+ $(FC) $(FFLAGS) -c linalgebra_f90.f90
+
+ refmac: $(SUBR)
+- $(FC) $(FFLAGS) -o refmac${VERSION} ${SUBR} $(LLIBOTHERS) $(LLIBCCP)
++ $(FC) $(FFLAGS) $(LDFLAGS) -o refmac${VERSION} ${SUBR} $(LLIBOTHERS) $(LLIBCCP) $(LLIBCIF) $(LLIBLAPACK)
+
+ mol2_file.o: mol2_file.f odb_files.f90
+ $(FC) $(FFLAGS) -c odb_files.f90 mol2_file.f
+@@ -209,7 +206,7 @@ libcheck.o: libcheck.f elements_module.f90 pdb2libcheck.f90
+ $(FC) $(FFLAGS) -c elements_module.f90 pdb2libcheck.f90 libcheck.f
+
+ libcheck: $(SUBL)
+- $(FC) $(FFLAGS) -o libcheck${VERSION} $(SUBL)
++ $(FC) $(FFLAGS) $(LDFLAGS) -o libcheck${VERSION} $(SUBL) $(LLIBCCP) $(LLIBCIF) $(LLIBLAPACK)
+
+ clean:
+ /bin/rm *.o
diff --git a/sci-chemistry/refmac/refmac-5.6.0075.ebuild b/sci-chemistry/refmac/refmac-5.6.0075.ebuild
new file mode 100644
index 000000000000..233956daad4e
--- /dev/null
+++ b/sci-chemistry/refmac/refmac-5.6.0075.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/refmac/refmac-5.6.0075.ebuild,v 1.1 2010/05/16 12:56:16 jlec Exp $
+
+EAPI="2"
+
+inherit fortran base toolchain-funcs versionator
+
+MY_PV="$(get_version_component_range 1-2)_source_v${PV}"
+
+DESCRIPTION="Macromolecular crystallographic refinement program"
+HOMEPAGE="http://www.ysbl.york.ac.uk/~garib/refmac/"
+SRC_URI="${HOMEPAGE}data/refmac_experimental/${PN}${MY_PV}.tar.gz
+ test? ( http://dev.gentooexperimental.org/~jlec/distfiles/test-framework.tar.gz )"
+
+SLOT="0"
+LICENSE="ccp4"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ sci-libs/ccp4-libs
+ sci-libs/mmdb
+ virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-allow-dynamic-linking.patch
+ )
+
+src_prepare() {
+ base_src_prepare
+ use test && epatch "${FILESDIR}"/5.5-test.log.patch
+}
+
+src_compile() {
+ emake \
+ FC=$(tc-getFC) \
+ CC=$(tc-getCC) \
+ CXX=$(tc-getCXX) \
+ COPTIM="${CFLAGS}" \
+ FOPTIM="${FFLAGS:- -O2}" \
+ VERSION="" \
+ XFFLAGS="-fno-second-underscore" \
+ LLIBCCP="-lccp4f -lccp4c -lccif -lmmdb -lstdc++" \
+ LLIBLAPACK="$(pkg-config --libs lapack blas)" \
+ || die
+}
+
+src_test() {
+ einfo "Starting tests ..."
+ export PATH="${WORKDIR}/test-framework/scripts:${S}:${PATH}"
+ export CCP4_TEST="${WORKDIR}"/test-framework
+ export CCP4_SCR="${T}"
+ ln -sf refmac "${S}"/refmac5
+ sed '/^ANISOU/d' -i ${CCP4_TEST}/data/pdb/1vr7.pdb
+ ccp4-run-thorough-tests -v test_refmac5 || die
+}
+
+src_install() {
+ for i in refmac libcheck; do
+ exeinto /usr/libexec/ccp4/bin/
+ doexe ${i} || die
+ dosym ../libexec/ccp4/bin/${i} /usr/bin/${i}
+ done
+ dosym refmac /usr/bin/refmac5 || die
+}