summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2012-02-10 06:35:25 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2012-02-10 06:35:25 +0000
commit5acf7e1dc09a21fc3609b866d20963c98347bac1 (patch)
tree3f15d48459d16260ebbc6135ce46bee8ffe908fe /sci-electronics/gerbv/gerbv-2.6.0.ebuild
parentRemove old. (diff)
downloadhistorical-5acf7e1dc09a21fc3609b866d20963c98347bac1.tar.gz
historical-5acf7e1dc09a21fc3609b866d20963c98347bac1.tar.bz2
historical-5acf7e1dc09a21fc3609b866d20963c98347bac1.zip
Version bump (bug #401825). Thanks to A. Walker
Package-Manager: portage-2.1.10.45/cvs/Linux x86_64
Diffstat (limited to 'sci-electronics/gerbv/gerbv-2.6.0.ebuild')
-rw-r--r--sci-electronics/gerbv/gerbv-2.6.0.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sci-electronics/gerbv/gerbv-2.6.0.ebuild b/sci-electronics/gerbv/gerbv-2.6.0.ebuild
new file mode 100644
index 000000000000..0acb260d5672
--- /dev/null
+++ b/sci-electronics/gerbv/gerbv-2.6.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gerbv/gerbv-2.6.0.ebuild,v 1.1 2012/02/10 06:35:25 tomjbe Exp $
+
+EAPI="4"
+
+inherit fdo-mime
+
+DESCRIPTION="A RS-274X (Gerber) and NC drill (Excellon) file viewer"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://gerbv.sourceforge.net/"
+
+IUSE="unit-mm doc examples"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+RESTRICT="test"
+
+RDEPEND="
+ x11-libs/gtk+:2
+ x11-libs/cairo"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable unit-mm) \
+ --disable-update-desktop-database
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS BUGS ChangeLog CONTRIBUTORS HACKING NEWS README* TODO
+
+ rm doc/Doxyfile.nopreprocessing
+ if use doc; then
+ find doc -name "Makefile*" -exec rm -f '{}' \;
+ dodoc -r doc/*
+ fi
+
+ if use examples; then
+ find example -name "Makefile*" -exec rm -f '{}' \;
+ dodoc -r example/*
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}