summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-01-21 09:59:38 +0000
committerMichael Weber <xmw@gentoo.org>2013-01-21 09:59:38 +0000
commit45cffaa406814a2522a73fd3edbde52e93be34d7 (patch)
tree2f5cd288387500a0ac6fe748e92f119239f75738 /sci-electronics
parentVersion bump (diff)
downloadhistorical-45cffaa406814a2522a73fd3edbde52e93be34d7.tar.gz
historical-45cffaa406814a2522a73fd3edbde52e93be34d7.tar.bz2
historical-45cffaa406814a2522a73fd3edbde52e93be34d7.zip
Version bumps
Package-Manager: portage-2.2.0_alpha154/cvs/Linux x86_64 Manifest-Sign-Key: 0x62EEF090
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/xcircuit/ChangeLog11
-rw-r--r--sci-electronics/xcircuit/xcircuit-3.7.48.ebuild63
-rw-r--r--sci-electronics/xcircuit/xcircuit-3.8.36.ebuild63
3 files changed, 135 insertions, 2 deletions
diff --git a/sci-electronics/xcircuit/ChangeLog b/sci-electronics/xcircuit/ChangeLog
index f2b39a376889..62635c93ff82 100644
--- a/sci-electronics/xcircuit/ChangeLog
+++ b/sci-electronics/xcircuit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-electronics/xcircuit
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/ChangeLog,v 1.56 2012/07/11 18:24:21 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/ChangeLog,v 1.57 2013/01/21 09:59:38 xmw Exp $
+
+*xcircuit-3.8.36 (21 Jan 2013)
+*xcircuit-3.7.48 (21 Jan 2013)
+
+ 21 Jan 2013; Michael Weber <xmw@gentoo.org> +xcircuit-3.7.48.ebuild,
+ +xcircuit-3.8.36.ebuild:
+ Version bumps
11 Jul 2012; Justin Lecher <jlec@gentoo.org> xcircuit-3.7.40.ebuild,
xcircuit-3.8.24.ebuild, metadata.xml:
diff --git a/sci-electronics/xcircuit/xcircuit-3.7.48.ebuild b/sci-electronics/xcircuit/xcircuit-3.7.48.ebuild
new file mode 100644
index 000000000000..e419fd1cd0e6
--- /dev/null
+++ b/sci-electronics/xcircuit/xcircuit-3.7.48.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/xcircuit-3.7.48.ebuild,v 1.1 2013/01/21 09:59:38 xmw Exp $
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils multilib
+
+DESCRIPTION="Circuit drawing and schematic capture program."
+SRC_URI="http://opencircuitdesign.com/xcircuit/archive/${P}.tgz"
+HOMEPAGE="http://opencircuitdesign.com/xcircuit"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="
+ app-text/ghostscript-gpl
+ dev-lang/tk
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXpm
+ x11-libs/libSM
+ x11-libs/libICE"
+RDEPEND=${DEPEND}
+
+RESTRICT="test" #131024
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ # automake-1.12
+ sed \
+ -e '/AM_C_PROTOTYPES/d' \
+ -i configure.in || die
+ # automake-1.13
+ mv configure.{in,ac} || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ export loader_run_path="/usr/$(get_libdir)"
+ local myeconfargs=(
+ --disable-dependency-tracking
+ --with-tcl
+ --with-ngspice
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile appdefaultsdir="/usr/share/X11/app-defaults"
+}
+
+src_install () {
+ autotools-utils_src_install \
+ appdefaultsdir="/usr/share/X11/app-defaults" \
+ appmandir="/usr/share/man/man1"
+}
diff --git a/sci-electronics/xcircuit/xcircuit-3.8.36.ebuild b/sci-electronics/xcircuit/xcircuit-3.8.36.ebuild
new file mode 100644
index 000000000000..fd57bd707a18
--- /dev/null
+++ b/sci-electronics/xcircuit/xcircuit-3.8.36.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/xcircuit-3.8.36.ebuild,v 1.1 2013/01/21 09:59:38 xmw Exp $
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils multilib
+
+DESCRIPTION="Circuit drawing and schematic capture program."
+SRC_URI="http://opencircuitdesign.com/xcircuit/archive/${P}.tgz"
+HOMEPAGE="http://opencircuitdesign.com/xcircuit"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="
+ app-text/ghostscript-gpl
+ dev-lang/tk
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXpm
+ x11-libs/libSM
+ x11-libs/libICE"
+RDEPEND=${DEPEND}
+
+RESTRICT="test" #131024
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ # automake-1.12
+ sed \
+ -e '/AM_C_PROTOTYPES/d' \
+ -i configure.in || die
+ # automake-1.13
+ mv configure.{in,ac} || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ export loader_run_path="/usr/$(get_libdir)"
+ local myeconfargs=(
+ --disable-dependency-tracking
+ --with-tcl
+ --with-ngspice
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile appdefaultsdir="/usr/share/X11/app-defaults"
+}
+
+src_install () {
+ autotools-utils_src_install \
+ appdefaultsdir="/usr/share/X11/app-defaults" \
+ appmandir="/usr/share/man/man1"
+}