summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Boeck <hanno@gentoo.org>2008-12-01 18:35:03 +0000
committerHanno Boeck <hanno@gentoo.org>2008-12-01 18:35:03 +0000
commit0a6dd57e6cb84b725ee6837474bd95331671276e (patch)
tree385f6f7996b47fed776920465be82b9b836adc0d /sci-geosciences/gpscorrelate/gpscorrelate-1.5.8.ebuild
parentUnmask rar-3.8.0 and above since it's a native 64bit binary. (diff)
downloadhistorical-0a6dd57e6cb84b725ee6837474bd95331671276e.tar.gz
historical-0a6dd57e6cb84b725ee6837474bd95331671276e.tar.bz2
historical-0a6dd57e6cb84b725ee6837474bd95331671276e.zip
gpscorrelate bump and makefile improvements
Package-Manager: portage-2.2_rc16/cvs/Linux 2.6.28-rc6 x86_64
Diffstat (limited to 'sci-geosciences/gpscorrelate/gpscorrelate-1.5.8.ebuild')
-rw-r--r--sci-geosciences/gpscorrelate/gpscorrelate-1.5.8.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-geosciences/gpscorrelate/gpscorrelate-1.5.8.ebuild b/sci-geosciences/gpscorrelate/gpscorrelate-1.5.8.ebuild
new file mode 100644
index 000000000000..394312697cbd
--- /dev/null
+++ b/sci-geosciences/gpscorrelate/gpscorrelate-1.5.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpscorrelate/gpscorrelate-1.5.8.ebuild,v 1.1 2008/12/01 18:35:02 hanno Exp $
+
+inherit eutils
+
+DESCRIPTION="Tool for adjusting EXIF tags of your photos with a recorded GPS trace"
+HOMEPAGE="http://freefoote.dview.net/linux_gpscorr.html"
+SRC_URI="http://freefoote.dview.net/linux/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="doc gtk"
+DEPEND="dev-libs/libxml2
+ media-gfx/exiv2
+ gtk? ( >=x11-libs/gtk+-2 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-makefile.diff"
+}
+
+src_compile() {
+ emake gpscorrelate gpscorrelate.1 || die
+ if use gtk; then
+ emake gpscorrelate-gui || die
+ fi
+}
+
+src_install() {
+ dobin gpscorrelate
+ if use gtk; then
+ dobin gpscorrelate-gui
+ make_desktop_entry gpscorrelate-gui GPSCorrelate "" "Photography;Graphics;Geography;"
+ fi
+ if use doc; then
+ dohtml doc/* || die
+ fi
+ doman gpscorrelate.1 || die
+}