summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2006-05-17 06:20:53 +0000
committerSteve Arnold <nerdboy@gentoo.org>2006-05-17 06:20:53 +0000
commit30e86b126985e916487e5451dbaf41b88247edfe (patch)
treebc91ae24b24b3c92015ac021d02797f0c16e8667 /sci-libs/cfitsio/files/cfitsio-2.510-configure.patch
parentNew upstream (Debian seems to maintain it now, so use their source archive); ... (diff)
downloadhistorical-30e86b126985e916487e5451dbaf41b88247edfe.tar.gz
historical-30e86b126985e916487e5451dbaf41b88247edfe.tar.bz2
historical-30e86b126985e916487e5451dbaf41b88247edfe.zip
fixed broken configure and bumped to the current release
Package-Manager: portage-2.1_rc1-r2
Diffstat (limited to 'sci-libs/cfitsio/files/cfitsio-2.510-configure.patch')
-rw-r--r--sci-libs/cfitsio/files/cfitsio-2.510-configure.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-libs/cfitsio/files/cfitsio-2.510-configure.patch b/sci-libs/cfitsio/files/cfitsio-2.510-configure.patch
new file mode 100644
index 000000000000..4d4cff0231db
--- /dev/null
+++ b/sci-libs/cfitsio/files/cfitsio-2.510-configure.patch
@@ -0,0 +1,39 @@
+--- Makefile.in.orig 2006-05-16 22:41:42.000000000 -0700
++++ Makefile.in 2006-05-16 22:44:32.000000000 -0700
+@@ -18,8 +18,8 @@
+ # testprog targets. See also changes and comments in configure.in
+ #
+
+-CFITSIO_LIB = @CFITSIO_PREFIX@/lib
+-CFITSIO_INCLUDE = @CFITSIO_PREFIX@/include
++CFITSIO_LIB = @CFITSIO_PREFIX@/${LIBDIR}
++CFITSIO_INCLUDE = @CFITSIO_PREFIX@/${INCLUDEDIR}
+
+ SHELL = /bin/sh
+ RANLIB = @RANLIB@
+@@ -142,4 +142,4 @@
+ objs: ${CORE_OBJECTS}
+
+ ${CFITSIO_LIB} ${CFITSIO_INCLUDE}:
+- @if [ ! -d $@ ]; then mkdir $@; fi
++ @if [ ! -d $@ ]; then mkdir -p $@; fi
+--- configure.orig 2006-05-16 22:41:34.000000000 -0700
++++ configure 2006-05-16 22:46:39.000000000 -0700
+@@ -1230,6 +1230,8 @@
+ ;;
+ lnx)
+ SHLIB_LD=":"
++ LD_FLAGS="-shared -Wl,-soname,libcfitsio.so.0"
++ SHLIB_SUFFIX=".so.0"
+ ;;
+ osf)
+ SHLIB_LD="ld -shared -expect_unresolved '*'"
+@@ -1249,7 +1251,7 @@
+ # Darwin uses gcc (=cc), but needs different flags (see above)
+ # if test "x$GCC" = xyes; then
+ if test "x$GCC" = xyes && test "x$EXT" != xdarwin && test "x$EXT" != xcygwin; then
+- SHLIB_LD="$CC -shared"
++ SHLIB_LD="gcc -shared -Wl,-soname,libcfitsio.so.0"
+ lhea_shlib_cflags='-fPIC'
+ fi
+ if test "x$lhea_shlib_cflags" != x; then