summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-06-09 20:52:31 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-06-09 20:52:31 +0000
commit9d4dbec776cb6a5a9d5a5e620879326982de0089 (patch)
tree1a67896770d50b3763d88e26481bcf8b750d40d2 /sci-libs/cminpack
parentFixed to build against linux-3.x, bug #370857 (diff)
downloadhistorical-9d4dbec776cb6a5a9d5a5e620879326982de0089.tar.gz
historical-9d4dbec776cb6a5a9d5a5e620879326982de0089.tar.bz2
historical-9d4dbec776cb6a5a9d5a5e620879326982de0089.zip
Initial import
Package-Manager: portage-2.1.10/cvs/Linux x86_64
Diffstat (limited to 'sci-libs/cminpack')
-rw-r--r--sci-libs/cminpack/ChangeLog10
-rw-r--r--sci-libs/cminpack/Manifest14
-rw-r--r--sci-libs/cminpack/cminpack-1.1.3.ebuild30
-rw-r--r--sci-libs/cminpack/metadata.xml17
4 files changed, 71 insertions, 0 deletions
diff --git a/sci-libs/cminpack/ChangeLog b/sci-libs/cminpack/ChangeLog
new file mode 100644
index 000000000000..1a62328bf344
--- /dev/null
+++ b/sci-libs/cminpack/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/cminpack
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cminpack/ChangeLog,v 1.1 2011/06/09 20:52:31 bicatali Exp $
+
+*cminpack-1.1.3 (09 Jun 2011)
+
+ 09 Jun 2011; SĂ©bastien Fabbro <bicatali@gentoo.org> +cminpack-1.1.3.ebuild,
+ +metadata.xml:
+ Initial import
+
diff --git a/sci-libs/cminpack/Manifest b/sci-libs/cminpack/Manifest
new file mode 100644
index 000000000000..04bd2bea625f
--- /dev/null
+++ b/sci-libs/cminpack/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST cminpack-1.1.3.tar.gz 189265 RMD160 4ceb95faf271f9788951d1ee2b171eabf84588c2 SHA1 f3ee9aff3a0671930e42b9824a264244db711d9a SHA256 eb319ad3eeb9e54076b2ac484058540dbd5db4a45928302a5fd1469aad5d4467
+EBUILD cminpack-1.1.3.ebuild 737 RMD160 ee6d6db5d45a10b0078c1b9e7e83e223dc1bda82 SHA1 d94a4c88ee21166bc06e4d8e40c17cebbcaccabe SHA256 07d7272945f7d7d809ef736ce0be9e819b09e9c763f8e33d7038362bd5a74ca1
+MISC ChangeLog 354 RMD160 82798e2677363de47bb4527b6c8dc3fe91b88210 SHA1 634673efb5e15842cae6298589ef6a9550c71728 SHA256 b3a8aec1516d02cfca7842a359d0d175eadb287e2ba672f52451ffc01722d08d
+MISC metadata.xml 812 RMD160 a616f44e05c90883f02ac3b4bd8d619820128e0d SHA1 bd88afa5b6042ce8a1236e25a869185a9fd84d49 SHA256 71759a499a78fc44ec35ce8c51ec680652a9a28ccca14c611b54a36dde740358
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.17 (GNU/Linux)
+
+iEYEARECAAYFAk3xMpcACgkQ1ycZbhPLE2B6RgCeMOzrm4+riyVhY4dx8zoWGNRH
+yWcAmwYZ7vt7vx01+g8ZJJYmEq56dVaT
+=ZuFa
+-----END PGP SIGNATURE-----
diff --git a/sci-libs/cminpack/cminpack-1.1.3.ebuild b/sci-libs/cminpack/cminpack-1.1.3.ebuild
new file mode 100644
index 000000000000..e2cb8e60aff7
--- /dev/null
+++ b/sci-libs/cminpack/cminpack-1.1.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cminpack/cminpack-1.1.3.ebuild,v 1.1 2011/06/09 20:52:31 bicatali Exp $
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="C implementation of the MINPACK nonlinear optimization library"
+HOMEPAGE="http://devernay.free.fr/hacks/cminpack/cminpack.html"
+SRC_URI="http://devernay.free.fr/hacks/cminpack/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+src_configure() {
+ mycmakeargs+=(
+ -DSHARED_LIBS=ON
+ $(cmake-utils_use_build test examples)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc readme*
+ use doc && dohtml -A .txt doc/*
+}
diff --git a/sci-libs/cminpack/metadata.xml b/sci-libs/cminpack/metadata.xml
new file mode 100644
index 000000000000..7f432fd0dc55
--- /dev/null
+++ b/sci-libs/cminpack/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ Minpack includes software for solving nonlinear equations and
+ nonlinear least squares problems. Five algorithmic paths each
+ include a core subroutine and an easy-to-use driver. The algorithms
+ proceed either from an analytic specification of the Jacobian matrix
+ or directly from the problem functions. The paths include facilities
+ for systems of equations with a banded Jacobian matrix, for least
+ squares problems with a large amount of data, and for checking the
+ consistency of the Jacobian matrix with the functions.
+ This is the C re-write of the original fortran minpack
+ implementation.
+</longdescription>
+</pkgmetadata>