summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-12-19 23:11:56 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-12-19 23:11:56 +0000
commit1541266f5b730258c7c62cd5cad6934e27ead3aa (patch)
tree753eb51a7ff718906576c57cd2f437c2598077e0 /sci-libs/lapack-atlas
parentStable on amd64 wrt security bug #156023 (diff)
downloadhistorical-1541266f5b730258c7c62cd5cad6934e27ead3aa.tar.gz
historical-1541266f5b730258c7c62cd5cad6934e27ead3aa.tar.bz2
historical-1541266f5b730258c7c62cd5cad6934e27ead3aa.zip
Version bump.
Package-Manager: portage-2.1.2_rc3-r4
Diffstat (limited to 'sci-libs/lapack-atlas')
-rw-r--r--sci-libs/lapack-atlas/ChangeLog8
-rw-r--r--sci-libs/lapack-atlas/files/digest-lapack-atlas-3.7.2412
-rw-r--r--sci-libs/lapack-atlas/lapack-atlas-3.7.24.ebuild166
3 files changed, 185 insertions, 1 deletions
diff --git a/sci-libs/lapack-atlas/ChangeLog b/sci-libs/lapack-atlas/ChangeLog
index e83a8e83a2e2..6e56211527fe 100644
--- a/sci-libs/lapack-atlas/ChangeLog
+++ b/sci-libs/lapack-atlas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/lapack-atlas
# Copyright 2004-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/ChangeLog,v 1.33 2006/12/09 13:56:01 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/ChangeLog,v 1.34 2006/12/19 23:11:56 markusle Exp $
+
+*lapack-atlas-3.7.24 (19 Dec 2006)
+
+ 19 Dec 2006; Markus Dittrich <markusle@gentoo.org>
+ -lapack-atlas-3.7.19.ebuild, +lapack-atlas-3.7.24.ebuild:
+ Version bump.
*lapack-atlas-3.7.23 (09 Dec 2006)
diff --git a/sci-libs/lapack-atlas/files/digest-lapack-atlas-3.7.24 b/sci-libs/lapack-atlas/files/digest-lapack-atlas-3.7.24
new file mode 100644
index 000000000000..6344c175a381
--- /dev/null
+++ b/sci-libs/lapack-atlas/files/digest-lapack-atlas-3.7.24
@@ -0,0 +1,12 @@
+MD5 4d28b9a878db79ba5567c76d225097a1 atlas-3.7.23-shared-libs.patch.bz2 6324
+RMD160 b3fd87430994d09860a6fd1d494934e90c0ecf41 atlas-3.7.23-shared-libs.patch.bz2 6324
+SHA256 895ed8243f23074ad0a343c3aded59468e2f3d6acfa886c840f7f81d32718241 atlas-3.7.23-shared-libs.patch.bz2 6324
+MD5 c9e54c65714afab0007102245860bbf5 atlas3.7.24.tar.bz2 1776317
+RMD160 c7bcfb157aa83a8087a3131342cbd1347f76ce64 atlas3.7.24.tar.bz2 1776317
+SHA256 10436b1aa642d0bd041170db683c119a9581ee5325fed2dc8113f34a2f11f8e4 atlas3.7.24.tar.bz2 1776317
+MD5 c35802e688f28f8f65632fb93aad69d8 lapack-20020531-20021004.patch.bz2 59736
+RMD160 126a579d242664dce53d23cdd7bef935e81b5031 lapack-20020531-20021004.patch.bz2 59736
+SHA256 19bcae60fcec3742563d8b27e21da52677b18520c54cf0cb7a51537ec3dbd29c lapack-20020531-20021004.patch.bz2 59736
+MD5 a24f59304f87b78cdc7da2ae59c98664 lapack.tgz 4991992
+RMD160 630f9d7b4b37b0d39bccd4816198271b7e9e0cce lapack.tgz 4991992
+SHA256 393613641f80745e7e8445fd0f3e4f5f66a5e340c8115cd4d780b0f53e2b31a6 lapack.tgz 4991992
diff --git a/sci-libs/lapack-atlas/lapack-atlas-3.7.24.ebuild b/sci-libs/lapack-atlas/lapack-atlas-3.7.24.ebuild
new file mode 100644
index 000000000000..7eb511f07a7f
--- /dev/null
+++ b/sci-libs/lapack-atlas/lapack-atlas-3.7.24.ebuild
@@ -0,0 +1,166 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.7.24.ebuild,v 1.1 2006/12/19 23:11:56 markusle Exp $
+
+inherit eutils flag-o-matic toolchain-funcs fortran
+
+DESCRIPTION="Full LAPACK implementation using available ATLAS routines"
+LICENSE="BSD"
+HOMEPAGE="http://math-atlas.sourceforge.net/"
+MY_PN="${PN/lapack-/}"
+SRC_URI1="mirror://sourceforge/math-atlas/${MY_PN}${PV}.tar.bz2"
+SRC_URI2="http://www.netlib.org/lapack/lapack.tgz"
+SRC_URI="${SRC_URI1} ${SRC_URI2}
+ mirror://gentoo/lapack-20020531-20021004.patch.bz2
+ mirror://gentoo/${MY_PN}-3.7.23-shared-libs.patch.bz2"
+
+SLOT="0"
+IUSE="doc"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="virtual/blas
+ app-admin/eselect-lapack"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-1.5
+ ~sci-libs/blas-atlas-3.7.24"
+
+PROVIDE="virtual/lapack"
+
+FORTRAN="g77 gfortran"
+
+S="${WORKDIR}/ATLAS"
+S_LAPACK="${WORKDIR}/LAPACK"
+BLD_DIR="${S}/gentoo-build"
+RPATH="${DESTTREE}/$(get_libdir)/lapack/atlas"
+
+pkg_setup() {
+ fortran_pkg_setup
+ echo
+ ewarn "Please make sure to disable CPU throttling completely"
+ ewarn "during the compile of lapack-atlas. Otherwise, all atlas"
+ ewarn "generated timings will be completely random and the"
+ ewarn "performance of the resulting libraries will be degraded"
+ ewarn "considerably."
+ echo
+ epause 8
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${WORKDIR}"
+
+ epatch "${DISTDIR}"/${MY_PN}-3.7.23-shared-libs.patch.bz2
+ epatch "${FILESDIR}"/${MY_PN}-asm-gentoo.patch
+ epatch "${DISTDIR}"/lapack-20020531-20021004.patch.bz2
+ epatch "${FILESDIR}"/lapack-reference-3.0-autotool.patch
+
+ cd "${S}"
+ mkdir ${BLD_DIR} || die "failed to generate build directory"
+ cp "${FILESDIR}"/war "${BLD_DIR}" && chmod a+x "${BLD_DIR}"/war \
+ || die "failed to install war"
+
+ # make sure the compile picks up the proper includes
+ sed -e 's|INCLUDES =|INCLUDES = -I/usr/include/atlas/|' \
+ -i CONFIG/src/SpewMakeInc.c || \
+ die "failed to append proper includes"
+
+ # force proper 32/64bit libs
+ local archselect
+ if [[ "${ARCH}" == "amd64" || "${ARCH}" == "ppc64" ]]; then
+ archselect="-b 64"
+ else
+ archselect="-b 32"
+ fi
+
+ # set up compiler/flags using atlas' native configure
+ local compdefs
+ compdefs="${compdefs} -C xc '$(tc-getCC)' -F xc '${CFLAGS}'"
+ compdefs="${compdefs} -C ic '$(tc-getCC)' -F ic '${CFLAGS}'"
+ compdefs="${compdefs} -C sk '$(tc-getCC)' -F sk '${CFLAGS}'"
+ compdefs="${compdefs} -C dk '$(tc-getCC)' -F dk '${CFLAGS}'"
+ compdefs="${compdefs} -C sm '$(tc-getCC)' -F sm '${CFLAGS}'"
+ compdefs="${compdefs} -C dm '$(tc-getCC)' -F dm '${CFLAGS}'"
+ compdefs="${compdefs} -C if '${FORTRANC}' -F if '${FFLAGS}'"
+ compdefs="${compdefs} -Si cputhrchk 0 ${archselect}"
+
+
+ cd ${BLD_DIR} && ../configure ${compdefs} \
+ || die "configure failed"
+
+ cd "${S_LAPACK}"
+ eautoreconf
+}
+
+src_compile() {
+ # build atlas' part of lapack
+ cd "${BLD_DIR}"/src/lapack
+ make lib || die "Failed to make lib in ${BLD_DIR}/src/lapack"
+
+ cd "${BLD_DIR}"/interfaces/lapack/C/src
+ make lib || die "Failed to make lib in ${BLD_DIR}/interfaces/lapack/C/src"
+
+ cd "${BLD_DIR}"/interfaces/lapack/F77/src
+ make lib || die "Failed to make lib in ${BLD_DIR}/interfaces/lapack/F77/src"
+
+ # build rest of lapack
+ cd "${S_LAPACK}"
+ econf || die "Failed to configure reference lapack lib"
+ emake || die "Failed to make reference lapack lib"
+
+ cd "${S_LAPACK}"/SRC
+ einfo "Copying liblapack.a/*.o to ${S_LAPACK}/SRC"
+ cp -sf "${BLD_DIR}"/gentoo/liblapack.a/*.o .
+ einfo "Copying liblapack.a/*.lo to ${S_LAPACK}/SRC"
+ cp -sf "${BLD_DIR}"/gentoo/liblapack.a/*.lo .
+ einfo "Copying liblapack.a/.libs/*.o to ${S_LAPACK}/SRC"
+ cp -sf "${BLD_DIR}"/gentoo/liblapack.a/.libs/*.o .libs/
+
+ # make sure shared libs link against proper libraries
+ if [[ ${FORTRANC} == "gfortran" ]]; then
+ libs="${LDFLAGS} -lpthread -lgfortran"
+ else
+ libs="${LDFLAGS} -lpthread -lg2c"
+ fi
+
+ ../libtool --mode=link --tag=F77 ${FORTRANC} -lblas -lcblas \
+ -latlas ${libs} -o liblapack.la *.lo -rpath "${RPATH}" \
+ || die "Failed to create liblapack.la"
+}
+
+src_install () {
+ dodir "${RPATH}"
+
+ cd "${S_LAPACK}"/SRC
+ ../libtool --mode=install install -s liblapack.la \
+ "${D}/${RPATH}" \
+ || die "Failed to install lapack-atlas library"
+
+ eselect lapack add $(get_libdir) ${FILESDIR}/eselect.lapack atlas
+
+ insinto /usr/include/atlas
+ cd "${S}"/include
+ doins clapack.h || die "Failed to install clapack.h"
+
+ cd "${S}"
+ dodoc README doc/AtlasCredits.txt doc/ChangeLog || \
+ die "Failed to install docs"
+ if use doc; then
+ dodoc doc/lapackqref.ps || die "Failed to install docs"
+ fi
+}
+
+pkg_postinst() {
+ if [[ -z "$(eselect lapack show)" ]]; then
+ eselect lapack set atlas
+ fi
+
+ elog
+ elog "To link with ATLAS LAPACK from C or Fortran, simply use:"
+ elog
+ elog "-llapack"
+ elog
+ elog "C users: your header is /usr/include/atlas/clapack.h"
+ elog
+ elog "Configuration now uses eselect rather than lapack-config."
+}