summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-08-31 14:28:27 +0000
committerJustin Lecher <jlec@gentoo.org>2011-08-31 14:28:27 +0000
commita2838dbc524cad6d5cee6e05353d1de841127199 (patch)
tree0dfcfa88e4718fd5bcb46773c0887cb2bfe8738b /sci-libs/libcmatrix/libcmatrix-3.9.0.ebuild
parentAdd deblob support (diff)
downloadhistorical-a2838dbc524cad6d5cee6e05353d1de841127199.tar.gz
historical-a2838dbc524cad6d5cee6e05353d1de841127199.tar.bz2
historical-a2838dbc524cad6d5cee6e05353d1de841127199.zip
Version bump
Package-Manager: portage-2.2.0_alpha51/cvs/Linux x86_64
Diffstat (limited to 'sci-libs/libcmatrix/libcmatrix-3.9.0.ebuild')
-rw-r--r--sci-libs/libcmatrix/libcmatrix-3.9.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sci-libs/libcmatrix/libcmatrix-3.9.0.ebuild b/sci-libs/libcmatrix/libcmatrix-3.9.0.ebuild
new file mode 100644
index 000000000000..4da9c6dac23e
--- /dev/null
+++ b/sci-libs/libcmatrix/libcmatrix-3.9.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libcmatrix/libcmatrix-3.9.0.ebuild,v 1.1 2011/08/31 14:28:27 jlec Exp $
+
+EAPI="3"
+
+inherit autotools eutils
+
+MY_P="${PN}${PV}_lite"
+
+DESCRIPTION="lite version of pNMRsim"
+HOMEPAGE="http://www.dur.ac.uk/paul.hodgkinson/pNMRsim/"
+#SRC_URI="${HOMEPAGE}/${MY_P}.tar.gz"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="atlas sse threads"
+
+RDEPEND="
+ sci-libs/minuit
+ atlas? ( || ( sci-libs/blas-atlas sci-libs/atlas ) )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${PN}R3
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/3.2.1-shared.patch \
+ "${FILESDIR}"/3.2.1-minuit2.patch \
+ "${FILESDIR}"/3.2.1-gcc4.4.patch \
+ "${FILESDIR}"/3.2.1-gcc4.6.patch \
+ "${FILESDIR}"/${PV}-atlas.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-minuit \
+ $(use_with atlas) \
+ $(use_with sse) \
+ $(use_with threads)
+}
+
+src_install() {
+ dolib.so lib/*.so* || die "install failed"
+
+ insinto /usr/include/${PN}R3
+ doins include/* || die "no includes"
+
+ dodoc CHANGES docs/* || die "no docs"
+}