summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-04-29 14:57:02 +0000
committerJustin Lecher <jlec@gentoo.org>2010-04-29 14:57:02 +0000
commitdb2efe43f4aef40fdaf8358600ec37e608a66c04 (patch)
tree53e231dabb3e06b7225ce7584973bc9e5e8450d3 /sci-libs/pycifrw/pycifrw-3.3-r1.ebuild
parentVersion bump from NX overlay, update to qt4-r2, drop 2.x versions (diff)
downloadhistorical-db2efe43f4aef40fdaf8358600ec37e608a66c04.tar.gz
historical-db2efe43f4aef40fdaf8358600ec37e608a66c04.tar.bz2
historical-db2efe43f4aef40fdaf8358600ec37e608a66c04.zip
Corrected usage of PYTHON_MODNAME, restrict to <python-3, thanks Arfrever for watching my python stuff
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'sci-libs/pycifrw/pycifrw-3.3-r1.ebuild')
-rw-r--r--sci-libs/pycifrw/pycifrw-3.3-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sci-libs/pycifrw/pycifrw-3.3-r1.ebuild b/sci-libs/pycifrw/pycifrw-3.3-r1.ebuild
new file mode 100644
index 000000000000..9c65d8634068
--- /dev/null
+++ b/sci-libs/pycifrw/pycifrw-3.3-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/pycifrw/pycifrw-3.3-r1.ebuild,v 1.1 2010/04/29 14:57:02 jlec Exp $
+
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+PYTHON_MODNAME="CifFile.py StarFile.py yapps3_compiled_rt.py YappsStarParser_1_0.py YappsStarParser_1_1.py YappsStarParser_DDLm.py"
+MY_PN="PyCifRW"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Provides support for reading and writing of CIF using python"
+HOMEPAGE="http://pycifrw.berlios.de/"
+SRC_URI="mirror://berlios/${PN}/${MY_P}.tar.gz"
+
+LICENSE="ASRP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"