summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-10-11 17:04:17 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-10-11 17:04:17 +0000
commit59c402434ff8048d08ce0481c542a5d0a7ac43fd (patch)
tree4a09b4770aa7e7b45e44aad409ddc8949f8856d4 /sci-libs
parentfixed lib->get_libdir for eselect bug workaround. Removed PROVIDE for older b... (diff)
downloadhistorical-59c402434ff8048d08ce0481c542a5d0a7ac43fd.tar.gz
historical-59c402434ff8048d08ce0481c542a5d0a7ac43fd.tar.bz2
historical-59c402434ff8048d08ce0481c542a5d0a7ac43fd.zip
fixed lib->get_libdir for eselect bug workaround
Package-Manager: portage-2.1.3.12
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/lapack-atlas/ChangeLog6
-rw-r--r--sci-libs/lapack-atlas/lapack-atlas-3.7.39.ebuild19
2 files changed, 10 insertions, 15 deletions
diff --git a/sci-libs/lapack-atlas/ChangeLog b/sci-libs/lapack-atlas/ChangeLog
index fd36296f1b2a..f892408a4b95 100644
--- a/sci-libs/lapack-atlas/ChangeLog
+++ b/sci-libs/lapack-atlas/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/lapack-atlas
# Copyright 2004-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/ChangeLog,v 1.47 2007/10/10 10:04:59 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/ChangeLog,v 1.48 2007/10/11 17:04:17 bicatali Exp $
+
+ 11 Oct 2007; SĂ©bastien Fabbro <bicatali@gentoo.org>
+ lapack-atlas-3.7.39.ebuild:
+ fixed lib->get_libdir for eselect bug workaround
*lapack-atlas-3.7.39 (09 Oct 2007)
diff --git a/sci-libs/lapack-atlas/lapack-atlas-3.7.39.ebuild b/sci-libs/lapack-atlas/lapack-atlas-3.7.39.ebuild
index 06327c8c2acd..d2272786abef 100644
--- a/sci-libs/lapack-atlas/lapack-atlas-3.7.39.ebuild
+++ b/sci-libs/lapack-atlas/lapack-atlas-3.7.39.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.7.39.ebuild,v 1.1 2007/10/10 10:04:59 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.7.39.ebuild,v 1.2 2007/10/11 17:04:17 bicatali Exp $
inherit eutils flag-o-matic toolchain-funcs fortran autotools versionator
@@ -164,21 +164,12 @@ src_test() {
pkg_postinst() {
local current_lib=$(eselect lapack show | cut -d' ' -f2)
- # uncomment below when eselect bug #189942 is fixed, together with DEPEND
- #if [[ -z ${current_p} || ${current_p} == ${ESELECT_PROF} ]]; then
-
# this snippet works around the eselect bug #189942 and makes
- # sure that users upgrading from a previous lapack-atlas
+ # sure that users upgrading from a previous lapack-atlas
# version pick up the new pkg-config files
- if [[ ${current_lib} == ${ESELECT_PROF} ]]; then
- local configfile="${ROOT}"/etc/env.d/lapack/lib/config
- if [[ -e ${configfile} ]]; then
- rm -f ${configfile}
- eselect lapack set ${ESELECT_PROF}
- fi
- fi
-
- if [[ -z ${current_lib} ]]; then
+ if [[ ${current_lib} == ${ESELECT_PROF} || -z ${current_lib} ]]; then
+ local configfile="${ROOT}"/etc/env.d/lapack/$(get_libdir)/config
+ [[ -e ${configfile} ]] && rm -f ${configfile}
eselect lapack set ${ESELECT_PROF}
elog "lapack has been eselected to ${ESELECT_PROF}"
else