summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-10-06 01:55:06 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-10-06 01:55:06 +0000
commit9c8e647018e9ac575c3a3bb71255192d07630785 (patch)
tree29e699a7a2f39ee9d61f889cd566bf1d1f2ddd27 /sci-mathematics/calc/calc-2.12.1.5.ebuild
parentNuking ~sparc until DEPs are properly handled (diff)
downloadhistorical-9c8e647018e9ac575c3a3bb71255192d07630785.tar.gz
historical-9c8e647018e9ac575c3a3bb71255192d07630785.tar.bz2
historical-9c8e647018e9ac575c3a3bb71255192d07630785.zip
Version bump.
Package-Manager: portage-2.1.2_pre2
Diffstat (limited to 'sci-mathematics/calc/calc-2.12.1.5.ebuild')
-rw-r--r--sci-mathematics/calc/calc-2.12.1.5.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-mathematics/calc/calc-2.12.1.5.ebuild b/sci-mathematics/calc/calc-2.12.1.5.ebuild
new file mode 100644
index 000000000000..f97f42e22160
--- /dev/null
+++ b/sci-mathematics/calc/calc-2.12.1.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/calc/calc-2.12.1.5.ebuild,v 1.1 2006/10/06 01:55:06 markusle Exp $
+
+DESCRIPTION="An arbitrary precision C-like arithmetic system"
+HOMEPAGE="http://www.isthe.com/chongo/tech/comp/calc/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc-macos ~x86"
+
+IUSE=""
+
+DEPEND=">=sys-libs/ncurses-5.2
+ >=sys-libs/readline-4.2"
+
+RDEPEND=">=sys-apps/less-348"
+
+src_compile() {
+ make \
+ T=${D} \
+ DEBUG="${CFLAGS}" \
+ CALCPAGER=less \
+ USE_READLINE="-DUSE_READLINE" \
+ READLINE_LIB="-lreadline -lhistory -lncurses" \
+ all \
+ || die
+ if echo "${LD_PRELOAD}" | grep -q "sandbox"; then
+ ewarn "Can't run check when running in sandbox - see bug #59676"
+ else
+ make chk || die "Check failed"
+ fi
+}
+
+src_install() {
+ make T=${D} install || die
+ dodoc BUGS CHANGES COPYING COPYING-LGPL LIBRARY README
+}