summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2005-11-09 16:23:26 +0000
committerGeorge Shapovalov <george@gentoo.org>2005-11-09 16:23:26 +0000
commit8776eda2ce5c718e055a81c7ae8a7522eab2f0c3 (patch)
tree3ddee0368d6a3f8a9debaa06a349fea42e1045e6 /sci-mathematics
parentfix invalid atoms (diff)
downloadhistorical-8776eda2ce5c718e055a81c7ae8a7522eab2f0c3.tar.gz
historical-8776eda2ce5c718e055a81c7ae8a7522eab2f0c3.tar.bz2
historical-8776eda2ce5c718e055a81c7ae8a7522eab2f0c3.zip
new version (#110772)
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/pari/ChangeLog8
-rw-r--r--sci-mathematics/pari/Manifest4
-rw-r--r--sci-mathematics/pari/files/digest-pari-2.1.71
-rw-r--r--sci-mathematics/pari/pari-2.1.7.ebuild87
4 files changed, 98 insertions, 2 deletions
diff --git a/sci-mathematics/pari/ChangeLog b/sci-mathematics/pari/ChangeLog
index 9723e4783d13..5fe04d0fd205 100644
--- a/sci-mathematics/pari/ChangeLog
+++ b/sci-mathematics/pari/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/pari
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/ChangeLog,v 1.19 2005/11/08 17:41:36 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/ChangeLog,v 1.20 2005/11/09 16:23:26 george Exp $
+
+*pari-2.1.7 (09 Nov 2005)
+
+ 09 Nov 2005; <gerr@gentoo.org> +pari-2.1.7.ebuild:
+ new version (#110772), the patch to sources seems no longer necessary,
+ as the corresponding upstream bug said "it's in cvs" for previous version (and it tests fine).
08 Nov 2005; George Shapovalov <george@gentoo.org> pari-2.1.6.ebuild:
fix for sparc arch (#87790)
diff --git a/sci-mathematics/pari/Manifest b/sci-mathematics/pari/Manifest
index 3466490fd6b0..0ff0a9156e40 100644
--- a/sci-mathematics/pari/Manifest
+++ b/sci-mathematics/pari/Manifest
@@ -1,9 +1,11 @@
-MD5 55086a810d57dfb4c89392f4a64e80e7 ChangeLog 5426
+MD5 b9ee81070b9fa2036a267df0e97a06f8 ChangeLog 5678
MD5 ee951aeeb2122fab2aaf9803097fad76 files/digest-pari-2.1.5-r4 63
MD5 2fd9906f2bf293fdad42d572846508de files/digest-pari-2.1.6 60
+MD5 af657a173514360dabaac40ecd6ee695 files/digest-pari-2.1.7 60
MD5 c3f89da5ddbdb73646e3d64ee31ea887 files/docs.patch 915
MD5 dccf7ef464f99fa750a5c7fc3ec67e8f files/wrong_functype-r1.patch 1498
MD5 cbd309a01e2fee1a5ba6cb3a93ba5708 files/wrong_functype.patch 1946
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 c49cfeebeab95672f9d228b76c63522b pari-2.1.5-r4.ebuild 2520
MD5 8aca1c2d2f15f55900235c498da7a34a pari-2.1.6.ebuild 2482
+MD5 b46e81d1d0ac1468e9705febc1e5291f pari-2.1.7.ebuild 2454
diff --git a/sci-mathematics/pari/files/digest-pari-2.1.7 b/sci-mathematics/pari/files/digest-pari-2.1.7
new file mode 100644
index 000000000000..8f7c18b600af
--- /dev/null
+++ b/sci-mathematics/pari/files/digest-pari-2.1.7
@@ -0,0 +1 @@
+MD5 357b7a42e89e2761a5367bbcbfcca5f2 pari-2.1.7.tgz 1542137
diff --git a/sci-mathematics/pari/pari-2.1.7.ebuild b/sci-mathematics/pari/pari-2.1.7.ebuild
new file mode 100644
index 000000000000..c3209d10f9de
--- /dev/null
+++ b/sci-mathematics/pari/pari-2.1.7.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.1.7.ebuild,v 1.1 2005/11/09 16:23:26 george Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="pari (or pari-gp) : a software package for computer-aided number theory"
+HOMEPAGE="http://pari.math.u-bordeaux.fr/"
+SRC_URI="http://pari.math.u-bordeaux.fr/pub/pari/unix/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="doc emacs"
+
+DEPEND="doc? ( virtual/tetex )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/docs.patch
+}
+
+src_compile() {
+ # Fix usage of toolchain
+ tc-getAS; tc-getLD; tc-getCC; tc-getCXX
+
+ # Special handling for sparc
+ local myhost
+ [ "${PROFILE_ARCH}" == "sparc64" ] && myhost="sparc64-linux" \
+ || myhost="$(echo ${CHOST} | cut -f "1 3" -d '-')"
+ einfo "Building for ${myhost}"
+
+ #need to force optimization here, as it breaks without
+ if is-flag -O0; then
+ replace-flags -O0 -O2
+ elif ! is-flag -O?; then
+ append-flags -O2
+ fi
+ #we also need to force -fPIC throughout on amd64
+ if [ "${ARCH}" = "amd64" ] && ! is-flag -fPIC; then append-flags -fPIC; fi
+
+ ./Configure \
+ --host=${myhost} \
+ --prefix=/usr \
+ --miscdir=/usr/share/doc/${PF} \
+ --datadir=/usr/share/${P} \
+ --libdir=/usr/$(get_libdir) \
+ --mandir=/usr/share/man/man1 || die "./configure failed"
+ addwrite "/var/lib/texmf"
+ addwrite "/usr/share/texmf"
+ addwrite "/var/cache/fonts"
+
+ if use hppa
+ then
+ mymake=DLLD\=/usr/bin/gcc\ DLLDFLAGS\=-shared\ -Wl,-soname=\$\(LIBPARI_SONAME\)\ -lm
+ fi
+
+ # Shared libraries should be PIC on ALL architectures.
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/31
+ # Fixes BUG #49583
+ einfo "Building shared library..."
+ cd Olinux-* || die "Bad directory. File a BUG!"
+ emake ${mymake} CFLAGS="${CFLAGS} -DGCC_INLINE -fPIC" lib-dyn || die "Building shared library failed!"
+
+ einfo "Building executables..."
+ emake ${mymake} CFLAGS="${CFLAGS} -DGCC_INLINE" gp ../gp || die "Building executables failed!"
+
+ use doc || rm -rf doc/*.tex
+ use doc && emake doc
+}
+
+src_test() {
+ cd ${S}
+ ebegin "Testing pari kernel"
+ make CFLAGS="-Wl,-lpari" test-kernel > /dev/null
+ eend $?
+}
+
+src_install() {
+ make DESTDIR=${D} LIBDIR=${D}/usr/$(get_libdir) install || die
+ if use emacs; then
+ insinto /usr/share/emacs/site-lisp
+ doins emacs/pari.el
+ fi
+ dodoc AUTHORS Announce.2.1 CHANGES README TODO
+}