summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2005-12-29 23:32:31 +0000
committerTim Yamin <plasmaroo@gentoo.org>2005-12-29 23:32:31 +0000
commit98ac4f4e8ab250eddca92a535fe8372360abd0bf (patch)
treedaa684f73a61d83e2191e9b1ead3f5ea290d5b29 /sci-mathematics
parentStable on amd64 (diff)
downloadhistorical-98ac4f4e8ab250eddca92a535fe8372360abd0bf.tar.gz
historical-98ac4f4e8ab250eddca92a535fe8372360abd0bf.tar.bz2
historical-98ac4f4e8ab250eddca92a535fe8372360abd0bf.zip
Add snapshot; bug #117097.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/axiom/ChangeLog7
-rw-r--r--sci-mathematics/axiom/Manifest4
-rw-r--r--sci-mathematics/axiom/axiom-3.9.ebuild74
-rw-r--r--sci-mathematics/axiom/files/digest-axiom-3.91
4 files changed, 84 insertions, 2 deletions
diff --git a/sci-mathematics/axiom/ChangeLog b/sci-mathematics/axiom/ChangeLog
index 1d9dad595b5d..7afc0fd81485 100644
--- a/sci-mathematics/axiom/ChangeLog
+++ b/sci-mathematics/axiom/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/axiom
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/axiom/ChangeLog,v 1.3 2005/12/13 23:26:13 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/axiom/ChangeLog,v 1.4 2005/12/29 23:32:31 plasmaroo Exp $
+
+*axiom-3.9 (29 Dec 2005)
+
+ 29 Dec 2005; <plasmaroo@gentoo.org> +axiom-3.9.ebuild:
+ Add snapshot; bug #117097.
13 Dec 2005; <plasmaroo@gentoo.org> axiom-9999.ebuild:
Update Savannah CVS info; #115327.
diff --git a/sci-mathematics/axiom/Manifest b/sci-mathematics/axiom/Manifest
index 5ae2d85c56e4..9f477a226332 100644
--- a/sci-mathematics/axiom/Manifest
+++ b/sci-mathematics/axiom/Manifest
@@ -1,6 +1,8 @@
-MD5 c31af99006f4df7be468663b64304182 ChangeLog 729
+MD5 b62e3367eea0fae6709c4088ae0d0455 ChangeLog 842
MD5 9e4cd8bd2f0c8e1d698928766e4bb1cc axiom-9999.ebuild 2640
MD5 e49bb02132d2cd74ad4e6ee291e102d9 metadata.xml 220
+MD5 b69afc95b5e9c2466b594b33b68a9bb9 axiom-3.9.ebuild 2417
+MD5 5e0239b67a06d3ea02047349b2e48e0d files/digest-axiom-3.9 69
MD5 84829d019c500de4d62b6f0e79fa9e0f files/gcl-2.6.7.fix-out-of-build-root-compile.Makefile.patch 1422
MD5 43fa5bf93354597104a9752dea29743f files/gcl-2.6.7.fix-out-of-build-root-compile.patch.input 843
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-axiom-9999 0
diff --git a/sci-mathematics/axiom/axiom-3.9.ebuild b/sci-mathematics/axiom/axiom-3.9.ebuild
new file mode 100644
index 000000000000..8f4e50456496
--- /dev/null
+++ b/sci-mathematics/axiom/axiom-3.9.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/axiom/axiom-3.9.ebuild,v 1.1 2005/12/29 23:32:31 plasmaroo Exp $
+
+inherit eutils
+
+DESCRIPTION="Axiom is a general purpose Computer Algebra system"
+HOMEPAGE="http://axiom.axiom-developer.org/index.html"
+SRC_URI="http://axiom.axiom-developer.org/axiom-website/DOWNLOADS/axiom-Sept2005-src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/x11
+ virtual/tetex"
+
+S="${WORKDIR}/axiom"
+
+src_setenv() {
+ export AXIOM=`pwd`/mnt/linux
+ export PATH=${AXIOM}/bin:${PATH}
+}
+
+src_compile() {
+ src_setenv
+
+ # Patch the lsp Makefile since GCL goes kaboom with newer BFDs
+ # from Portage, so we need to use the BFD distributed with GCL for
+ # things to compile and work.
+ sed -i -e 's/--enable-statsysbfd/--enable-locbfd --disable-statsysbfd/' Makefile.pamphlet || die 'Failed to patch the lsp Makefile!'
+
+ # Fix gcl so the "real" Axiom can compile code after we're out of the chroot
+ cp ${FILESDIR}/gcl-2.6.7.fix-out-of-build-root-compile.patch.input ${S}/zips/gcl-2.6.7.fix-out-of-build-root-compile.patch
+ epatch ${FILESDIR}/gcl-2.6.7.fix-out-of-build-root-compile.Makefile.patch || die 'Failed to patch the lsp pamphlet!'
+
+ # Sandbox happiness, fix noweb
+ cd ${WORKDIR}
+ mkdir noweb
+ cd noweb
+ tar zxf ${S}/zips/noweb-2.10a.tgz
+ sed -i -e 's/-texhash || echo "Program texhash not found or failed"//' src/Makefile* ${S}/zips/noweb.src.Makefile*
+ tar czf ${S}/zips/noweb-2.10a.tgz *
+ cd ${S}
+ rm ${WORKDIR}/noweb -rf
+
+ # Fix compile bugs (if sed fails, it's fixed; so we don't || die :-])
+ # (plasmaroo; 20050116)
+ sed -e 's/struct termio ptermio;/struct termios ptermio;/' -i src/clef/edible.c.pamphlet
+ mkdir src/graph/viewports
+
+ # Let the fun begin...
+ ./configure
+ make || die # -jX breaks
+}
+
+src_install() {
+ src_setenv
+
+ dodir /usr/bin
+ einstall INSTALL=${D}/opt/axiom COMMAND=${D}/usr/bin/axiom || die 'Failed to install Axiom!'
+ sed -e '2d;3i AXIOM=/opt/axiom' -i ${D}/usr/bin/axiom ${D}/opt/axiom/mnt/linux/bin/axiom || die 'Failed to patch axiom runscript!'
+
+ # Get rid of /mnt/linux
+ cd ${D}/opt/axiom
+ mv mnt/linux/* .
+ rm -rf mnt
+
+ sed -e 's/AXIOMsys/sman/g' ${D}/usr/bin/axiom > ${D}/usr/bin/sman
+ sed -e 's:$AXIOM/bin/clef -e ::g' ${D}/usr/bin/axiom > ${D}/usr/bin/AXIOMsys
+ chmod +x ${D}/usr/bin/sman
+ chmod +x ${D}/usr/bin/AXIOMsys
+}
diff --git a/sci-mathematics/axiom/files/digest-axiom-3.9 b/sci-mathematics/axiom/files/digest-axiom-3.9
new file mode 100644
index 000000000000..72d51f09c1a5
--- /dev/null
+++ b/sci-mathematics/axiom/files/digest-axiom-3.9
@@ -0,0 +1 @@
+MD5 6b107a03b03595703d5e3e6bdd12f8c1 axiom-Sept2005-src.tgz 41447064