summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-24 12:51:38 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-24 12:51:38 +0000
commit05588b9b6568493178c1fd1b8bd7b2956656a405 (patch)
tree0099f75f23d587d5e55b7ef5c2bc6451bd3e58c1 /sci-misc/gato/gato-1.02.ebuild
parentRemove app-emulation/libvirt from dependencies. Use elog information instead (diff)
downloadhistorical-05588b9b6568493178c1fd1b8bd7b2956656a405.tar.gz
historical-05588b9b6568493178c1fd1b8bd7b2956656a405.tar.bz2
historical-05588b9b6568493178c1fd1b8bd7b2956656a405.zip
Version Bump, QA cleanup
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'sci-misc/gato/gato-1.02.ebuild')
-rw-r--r--sci-misc/gato/gato-1.02.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sci-misc/gato/gato-1.02.ebuild b/sci-misc/gato/gato-1.02.ebuild
new file mode 100644
index 000000000000..44b2fbf40560
--- /dev/null
+++ b/sci-misc/gato/gato-1.02.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/gato/gato-1.02.ebuild,v 1.1 2010/06/24 12:51:38 jlec Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="tk"
+
+inherit eutils python
+
+MY_PN="Gato"
+MY_PV=$(echo ${PV} | tr '[:lower:]' '[:upper:]')
+
+DESCRIPTION="Graph Animation Toolbox"
+HOMEPAGE="http://gato.sourceforge.net/"
+SRC_URI="http://gato.sourceforge.net/Download/${MY_PN}-${MY_PV}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # change TKinter call to avoid crashing of X
+ sed -i \
+ -e 's:self.overrideredirect(1):self.overrideredirect(0):' \
+ "${S}"/GatoDialogs.py || die "failed to patch GatoDialogs.py"
+}
+
+src_install() {
+ # install python code
+ local instdir=$(python_get_sitedir)/${PN}
+ insinto ${instdir}
+ doins *.py || die "Failed to install python files"
+ fperms 755 ${instdir}/{Gato,Gred}.py
+ python_convert_shebangs -r 2 "${ED}"
+
+ # create symlinks
+ dosym ${instdir}/Gato.py /usr/bin/gato || die
+ dosym ${instdir}/Gred.py /usr/bin/gred || die
+
+ # install data files
+ insinto /usr/share/${PN}
+ doins BFS.* DFS.* sample.cat || die "failed to data files"
+}
+
+pkg_postinst() {
+ python_mod_optimize ${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${PN}
+}