summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-09-07 22:13:50 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-09-07 22:13:50 +0000
commitd9cac53925f7dd33d33e3b595984545449172ba4 (patch)
treea00bacf260cc753d8d091bfd9fb45f9f75744207 /sci-physics/hepmc
parentInitial import, inspired from Benjamin Bannier's work (bug #236719) (diff)
downloadhistorical-d9cac53925f7dd33d33e3b595984545449172ba4.tar.gz
historical-d9cac53925f7dd33d33e3b595984545449172ba4.tar.bz2
historical-d9cac53925f7dd33d33e3b595984545449172ba4.zip
Initial import, inspired from Benjamin Bannier's work (bug #236718)
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.23-gentoo-r9 x86_64
Diffstat (limited to 'sci-physics/hepmc')
-rw-r--r--sci-physics/hepmc/ChangeLog10
-rw-r--r--sci-physics/hepmc/hepmc-2.04.00.ebuild48
-rw-r--r--sci-physics/hepmc/metadata.xml25
3 files changed, 83 insertions, 0 deletions
diff --git a/sci-physics/hepmc/ChangeLog b/sci-physics/hepmc/ChangeLog
new file mode 100644
index 000000000000..10a01c94fe6b
--- /dev/null
+++ b/sci-physics/hepmc/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-physics/hepmc
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/hepmc/ChangeLog,v 1.1 2008/09/07 22:13:50 bicatali Exp $
+
+*hepmc-2.04.00 (07 Sep 2008)
+
+ 07 Sep 2008; SĂ©bastien Fabbro <bicatali@gentoo.org> +metadata.xml,
+ +hepmc-2.04.00.ebuild:
+ Initial import, inspired from Benjamin Bannier's work (bug #236718)
+
diff --git a/sci-physics/hepmc/hepmc-2.04.00.ebuild b/sci-physics/hepmc/hepmc-2.04.00.ebuild
new file mode 100644
index 000000000000..599394f410cc
--- /dev/null
+++ b/sci-physics/hepmc/hepmc-2.04.00.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/hepmc/hepmc-2.04.00.ebuild,v 1.1 2008/09/07 22:13:50 bicatali Exp $
+
+MYP=HepMC-${PV}
+
+DESCRIPTION="Event Record for Monte Carlo Generators"
+HOMEPAGE="https://savannah.cern.ch/projects/hepmc/"
+SRC_URI="http://lcgapp.cern.ch/project/simu/HepMC/download/${MYP}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples gev cm"
+
+DEPEND=""
+
+S="${WORKDIR}/${MYP}"
+
+src_compile() {
+ # random default choice: use MeV over GeV and mm over cm
+ local length_conf="MM"
+ use cm && length_conf="CM"
+ local momentum_conf="MEV"
+ use gev && momentum_conf="GEV"
+ econf \
+ --with-length=${length_conf} \
+ --with-momentum=${momentum_conf} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ INSTALLDIR=/usr/share/doc/${PF}/examples \
+ doc_installdir=/usr/share/doc/${PF} \
+ install || die "emake install failed"
+
+ dodoc README AUTHORS ChangeLog
+ insinto /usr/share/doc/${PF}
+ if use doc; then
+ doins -r doc/html || die
+ else
+ rm -f "${D}"/usr/share/doc/${PF}/*pdf
+ fi
+ use examples || rm -rf "${D}"/usr/share/doc/${PF}/examples
+}
diff --git a/sci-physics/hepmc/metadata.xml b/sci-physics/hepmc/metadata.xml
new file mode 100644
index 000000000000..5733312e2b08
--- /dev/null
+++ b/sci-physics/hepmc/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-physics</herd>
+<longdescription lang="en">
+ The HepMC package is an object oriented event record written in C++
+ for High Energy Physics Monte Carlo Generators. Many extensions from
+ HEPEVT, the Fortran HEP standard, are supported: the number of entries
+ is unlimited, spin density matrices can be stored with each vertex,
+ flow patterns (such as color) can be stored and traced, integers
+ representing random number generator states can be stored, and an
+ arbitrary number of event weights can be included. Particles and
+ vertices are kept separate in a graph structure, physically similar to
+ a physics event. The added information supports the modularisation of
+ event generators. The package has been kept as simple as possible with
+ minimal internal/external dependencies. Event information is accessed
+ by means of iterators supplied with the package.
+
+ Reference: M. Dobbs and J.B. Hansen, Comput. Phys. Commun. 134 (2001)41.
+</longdescription>
+<use>
+ <flag name='gev'>Build with GeV instead of default MeV for momentum units</flag>
+ <flag name='cm'>Build with cm instead of default mm for length units</flag>
+</use>
+</pkgmetadata>