summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-08-04 13:49:50 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-08-04 13:49:50 +0000
commit03806039da6ab6bd670e1657406c1807575d9de3 (patch)
tree88c33a6a0217972e966db4330a35f648e153e3d8 /sci-visualization/gwyddion/gwyddion-2.10.ebuild
parentx86 stable wrt #207548 (diff)
downloadhistorical-03806039da6ab6bd670e1657406c1807575d9de3.tar.gz
historical-03806039da6ab6bd670e1657406c1807575d9de3.tar.bz2
historical-03806039da6ab6bd670e1657406c1807575d9de3.zip
Version bump (fixes bug #233355).
Package-Manager: portage-2.2_rc5/cvs/Linux 2.6.26-SENTINEL-1 i686
Diffstat (limited to 'sci-visualization/gwyddion/gwyddion-2.10.ebuild')
-rw-r--r--sci-visualization/gwyddion/gwyddion-2.10.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sci-visualization/gwyddion/gwyddion-2.10.ebuild b/sci-visualization/gwyddion/gwyddion-2.10.ebuild
new file mode 100644
index 000000000000..9dedde068d44
--- /dev/null
+++ b/sci-visualization/gwyddion/gwyddion-2.10.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gwyddion/gwyddion-2.10.ebuild,v 1.1 2008/08/04 13:49:50 markusle Exp $
+
+DESCRIPTION="A software framework for SPM data analysis"
+HOMEPAGE="http://gwyddion.net/"
+SRC_URI="http://gwyddion.net/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python perl ruby nls tiff fftw"
+
+RDEPEND="virtual/opengl
+ python? ( virtual/python )
+ perl? ( dev-lang/perl )
+ ruby? ( virtual/ruby )
+ tiff? ( media-libs/tiff )
+ fftw? ( >=sci-libs/fftw-3 )
+ >=x11-libs/gtk+-2.8
+ x11-libs/pango
+ x11-libs/cairo
+ x11-libs/gtkglext"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf \
+ $(use_enable python) \
+ $(use_enable perl) \
+ $(use_enable ruby) \
+ $(use_enable nls) \
+ $(use_with fftw fftw3 ) \
+ $(use_with tiff ) \
+ --disable-desktop-file-update \
+ || die "econf failed."
+ emake || die "emake failed."
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed."
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}