summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-03-20 19:40:05 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-03-20 19:40:05 +0000
commit5b6e71989c69670569712bfef8ad9fdd174f6ced (patch)
treecd0cbde238e8a475a01121cbf308ce4be42455aa /sci-visualization
parentversion bump (diff)
downloadhistorical-5b6e71989c69670569712bfef8ad9fdd174f6ced.tar.gz
historical-5b6e71989c69670569712bfef8ad9fdd174f6ced.tar.bz2
historical-5b6e71989c69670569712bfef8ad9fdd174f6ced.zip
Initial import from the science overlay to the main tree, with a patch for graphviz > 2.22 from Guillaume Horel, bug #262595
Package-Manager: portage-2.2_rc25/cvs/Linux x86_64
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/ggobi/ChangeLog15
-rw-r--r--sci-visualization/ggobi/Manifest15
-rw-r--r--sci-visualization/ggobi/files/ggobi-2.1.8-graphviz.patch14
-rw-r--r--sci-visualization/ggobi/ggobi-2.1.8.ebuild42
-rw-r--r--sci-visualization/ggobi/metadata.xml12
5 files changed, 98 insertions, 0 deletions
diff --git a/sci-visualization/ggobi/ChangeLog b/sci-visualization/ggobi/ChangeLog
new file mode 100644
index 000000000000..e00ae5fe3ce3
--- /dev/null
+++ b/sci-visualization/ggobi/ChangeLog
@@ -0,0 +1,15 @@
+# ChangeLog for sci-visualization/ggobi
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/ggobi/ChangeLog,v 1.1 2009/03/20 19:40:05 bicatali Exp $
+
+*ggobi-2.1.8 (20 Mar 2009)
+
+ 20 Mar 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/ggobi-2.1.8-graphviz.patch, +metadata.xml, +ggobi-2.1.8.ebuild:
+ Initial import from the science overlay to the main tree, with a patch for
+ graphviz > 2.22 from Guillaume Horel, bug #262595
+
+ 29 Jan 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +sci-visualization/ggobi/metadata.xml:
+ Initial import
+
diff --git a/sci-visualization/ggobi/Manifest b/sci-visualization/ggobi/Manifest
new file mode 100644
index 000000000000..cfc1e7c337a5
--- /dev/null
+++ b/sci-visualization/ggobi/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+AUX ggobi-2.1.8-graphviz.patch 664 RMD160 f90bd73d5f08d244e1a7504a849c746e8fa38d32 SHA1 181479b25be55c1af2668c37e16e876835e64b84 SHA256 b0c0e0fe8f1033485e2216678ce4df80674fba2ce3313272724e446b15c1f081
+DIST ggobi-2.1.8.tar.bz2 2531628 RMD160 b53276e5cf499668d6d1e190be4ba1e81e128e2e SHA1 62946881137b9262141961464bfe3c0090cc5b32 SHA256 2f814376d08a783628d2150d64cddda2e86b71f12847f1d51ba977197102fa8f
+EBUILD ggobi-2.1.8.ebuild 1025 RMD160 7e911e425a69084b463eb8a4b2e27781afc27908 SHA1 36fec86d7e608d4001b9d4a11ea0c270321fa768 SHA256 189efa441740964fdee10ccbb755de8c20e786c7194bd13cfd2db1613de28546
+MISC ChangeLog 621 RMD160 51e8edb758443df45dd4c53966d9f4f3ba297bf9 SHA1 1980d408bf8b0eba5e9f2f1ce6d977c852384a22 SHA256 68a5d972b6aa364efd37ebd931f587a0754fc94e3911bc2ea687216789653f54
+MISC metadata.xml 545 RMD160 c8166487902557abb8340cd16cd6b470922886fb SHA1 dbb38c10cd325aeb22ae7a0218855f54cbe1a2b6 SHA256 b97654ddf10a91587e919de7219320124f1c65b17d3b6fb1521c7701a80d8de1
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.10 (GNU/Linux)
+
+iEYEARECAAYFAknD8SAACgkQ1ycZbhPLE2AWewCdEppoQhO5qCFrjSFcxnH8Z/HX
+pRcAn0bgzLHirNlA1YjUfI/ELGCo/ncA
+=+EbK
+-----END PGP SIGNATURE-----
diff --git a/sci-visualization/ggobi/files/ggobi-2.1.8-graphviz.patch b/sci-visualization/ggobi/files/ggobi-2.1.8-graphviz.patch
new file mode 100644
index 000000000000..ac7313381bee
--- /dev/null
+++ b/sci-visualization/ggobi/files/ggobi-2.1.8-graphviz.patch
@@ -0,0 +1,14 @@
+diff -urN ggobi-2.1.8-orig/plugins/GraphLayout/graphviz.c ggobi-2.1.8/plugins/GraphLayout/graphviz.c
+--- ggobi-2.1.8-orig/plugins/GraphLayout/graphviz.c 2009-03-15 15:03:18.000000000 -0400
++++ ggobi-2.1.8/plugins/GraphLayout/graphviz.c 2009-03-15 15:04:30.000000000 -0400
+@@ -267,8 +267,8 @@
+ m = visible[i];
+ name = (gchar *) g_array_index (d->rowlab, gchar *, m);
+ node = agfindnode (graph, name);
+- pos[i][0] = (gdouble) ND_coord_i(node).x;
+- pos[i][1] = (gdouble) ND_coord_i(node).y;
++ pos[i][0] = (gdouble) ND_coord(node).x;
++ pos[i][1] = (gdouble) ND_coord(node).y;
+ }
+
+ } else if (layout_type == TWOPI_LAYOUT) {
diff --git a/sci-visualization/ggobi/ggobi-2.1.8.ebuild b/sci-visualization/ggobi/ggobi-2.1.8.ebuild
new file mode 100644
index 000000000000..caffe975ed65
--- /dev/null
+++ b/sci-visualization/ggobi/ggobi-2.1.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/ggobi/ggobi-2.1.8.ebuild,v 1.1 2009/03/20 19:40:05 bicatali Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Visualization program for exploring high-dimensional data"
+HOMEPAGE="http://www.ggobi.org"
+SRC_URI="http://www.ggobi.org/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal"
+
+RDEPEND=">=media-gfx/graphviz-2.6
+ >=x11-libs/gtk+-2.6
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ has_version ">=media-gfx/graphviz-2.22" && \
+ epatch "${FILESDIR}"/${P}-graphviz.patch
+}
+
+src_configure() {
+ econf $(use_with !minimal all-plugins)
+}
+
+src_compile() {
+ emake || die "emake failed"
+ # generate default configuration
+ emake ggobirc || die "ggobi configuration generation failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ insinto /etc/xdg/ggobi
+ doins ggobirc || die
+}
diff --git a/sci-visualization/ggobi/metadata.xml b/sci-visualization/ggobi/metadata.xml
new file mode 100644
index 000000000000..0148f71eb90d
--- /dev/null
+++ b/sci-visualization/ggobi/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ GGobi is an open source visualization program for exploring
+ high-dimensional data. It provides highly dynamic and interactive
+ graphics such as tours, as well as familiar graphics such as the
+ scatterplot, barchart and parallel coordinates plots. Plots are
+ interactive and linked with brushing and identification.
+ </longdescription>
+</pkgmetadata>