summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2004-04-19 01:04:26 +0000
committerChris PeBenito <pebenito@gentoo.org>2004-04-19 01:04:26 +0000
commit59597eaea2cc1ebf416944cc6e1f01f8380ca834 (patch)
tree4eea3921cd5e53c6dd1c916e216a14c1d75d18ba /sec-policy/selinux-base-policy
parentnew upstream release (diff)
downloadhistorical-59597eaea2cc1ebf416944cc6e1f01f8380ca834.tar.gz
historical-59597eaea2cc1ebf416944cc6e1f01f8380ca834.tar.bz2
historical-59597eaea2cc1ebf416944cc6e1f01f8380ca834.zip
new release for checkpolicy 1.10
Diffstat (limited to 'sec-policy/selinux-base-policy')
-rw-r--r--sec-policy/selinux-base-policy/ChangeLog8
-rw-r--r--sec-policy/selinux-base-policy/Manifest4
-rw-r--r--sec-policy/selinux-base-policy/files/digest-selinux-base-policy-200404181
-rw-r--r--sec-policy/selinux-base-policy/selinux-base-policy-20040418.ebuild87
4 files changed, 98 insertions, 2 deletions
diff --git a/sec-policy/selinux-base-policy/ChangeLog b/sec-policy/selinux-base-policy/ChangeLog
index c4bed4fd059e..11195b06316d 100644
--- a/sec-policy/selinux-base-policy/ChangeLog
+++ b/sec-policy/selinux-base-policy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sec-policy/selinux-base-policy
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/ChangeLog,v 1.19 2004/04/14 19:34:30 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/ChangeLog,v 1.20 2004/04/19 01:04:26 pebenito Exp $
+
+*selinux-base-policy-20040418 (18 Apr 2004)
+
+ 18 Apr 2004; Chris PeBenito <pebenito@gentoo.org>
+ +selinux-base-policy-20040418.ebuild:
+ New release for checkpolicy 1.10
*selinux-base-policy-20040414 (14 Apr 2004)
diff --git a/sec-policy/selinux-base-policy/Manifest b/sec-policy/selinux-base-policy/Manifest
index 89723731c30b..8780f5bb518b 100644
--- a/sec-policy/selinux-base-policy/Manifest
+++ b/sec-policy/selinux-base-policy/Manifest
@@ -1,6 +1,8 @@
MD5 2b9a3f12ac151d0b4c71816e637589b9 selinux-base-policy-20040225.ebuild 2199
MD5 26febc0d378194c942b3c319000416bb selinux-base-policy-20040414.ebuild 2705
-MD5 8cbe3de74ceb041c424a087b363a6754 ChangeLog 6598
+MD5 93384cbab4f3c62ccfefca33aaaa16f4 ChangeLog 6771
MD5 808b5f7f5d6654666e9193672d463229 metadata.xml 473
+MD5 c15cebafef1b8189f8c99de59a81a1b1 selinux-base-policy-20040418.ebuild 2674
MD5 e3ef36d7c3722c35db97e8256f800831 files/digest-selinux-base-policy-20040414 80
MD5 7afea4eea1a3c5611ca773551fbd1bb5 files/digest-selinux-base-policy-20040225 80
+MD5 f952bc21c0f26d0805ac84774c656930 files/digest-selinux-base-policy-20040418 80
diff --git a/sec-policy/selinux-base-policy/files/digest-selinux-base-policy-20040418 b/sec-policy/selinux-base-policy/files/digest-selinux-base-policy-20040418
new file mode 100644
index 000000000000..347ef7dcdbcd
--- /dev/null
+++ b/sec-policy/selinux-base-policy/files/digest-selinux-base-policy-20040418
@@ -0,0 +1 @@
+MD5 d77b7672c66f8e10fe6a728be3d61d3a selinux-base-policy-20040418.tar.bz2 67396
diff --git a/sec-policy/selinux-base-policy/selinux-base-policy-20040418.ebuild b/sec-policy/selinux-base-policy/selinux-base-policy-20040418.ebuild
new file mode 100644
index 000000000000..d53d8355a90a
--- /dev/null
+++ b/sec-policy/selinux-base-policy/selinux-base-policy-20040418.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/selinux-base-policy-20040418.ebuild,v 1.1 2004/04/19 01:04:26 pebenito Exp $
+
+IUSE="build"
+
+inherit eutils
+
+DESCRIPTION="Gentoo base policy for SELinux"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/selinux/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+DEPEND="build? ( sys-devel/make
+ sys-devel/m4 )"
+RDEPEND="sys-devel/m4
+ sys-devel/make"
+
+S=${WORKDIR}/base-policy
+
+[ -z ${POLICYDIR} ] && POLICYDIR="/etc/security/selinux/src/policy"
+
+# deprecated policies:
+DEPRECATED="domains/program/devfsd.te domains/program/opt.te
+ file_contexts/program/devfsd.fc file_contexts/program/opt.fc
+ file_contexts/users.fc"
+
+src_install() {
+ if use build; then
+ # generate a file_contexts
+ dodir ${POLICYDIR}/file_contexts
+ einfo "Ignore the checkpolicy error on the next line."
+ make -C ${S} \
+ FC=${D}/${POLICYDIR}/file_contexts/file_contexts \
+ ${D}/${POLICYDIR}/file_contexts/file_contexts
+
+ [ ! -f ${D}/${POLICYDIR}/file_contexts/file_contexts ] && \
+ die "file_contexts was not generated."
+ else
+ # install full policy
+ dodir /etc/security/selinux/src
+
+ insinto /etc/security
+ doins ${S}/appconfig/*
+
+ cp -a ${S} ${D}/${POLICYDIR}
+ rm -fR ${D}/${POLICYDIR}/appconfig
+ fi
+}
+
+pkg_postinst() {
+ local isdeprecated
+ echo
+ einfo "This is the base policy for SELinux on Gentoo. This policy"
+ einfo "package only covers the applications in the system profile."
+ einfo "More policy may need to be added according to your requirements."
+ echo
+ eerror "It is STRONGLY suggested that you evaluate and merge the"
+ eerror "policy changes. If any of the file contexts (*.fc) have"
+ eerror "changed, you should also relabel."
+ echo
+ ewarn "Please check the Changelog, there may be important information."
+ echo
+ echo
+
+ einfo "Checking for deprecated policy..."
+ for i in $DEPRECATED; do
+ if [ -f "${POLICYDIR}/${i}" ]; then
+ eerror "${POLICYDIR}/${i}"
+ isdeprecated="y"
+ fi
+ done
+ [ "${isdeprecated}" ] && \
+ eerror "The above policy file(s) should be removed if possible." || \
+ einfo "None found."
+
+ echo -ne "\a" ; sleep 0.1 ; echo -ne "\a" ; sleep 1
+ echo -ne "\a" ; sleep 0.1 ; echo -ne "\a" ; sleep 1
+ echo -ne "\a" ; sleep 0.1 ; echo -ne "\a" ; sleep 1
+ echo -ne "\a" ; sleep 0.1 ; echo -ne "\a" ; sleep 1
+ echo -ne "\a" ; sleep 0.1 ; echo -ne "\a" ; sleep 1
+ echo -ne "\a" ; sleep 0.1 ; echo -ne "\a" ; sleep 1
+ echo -ne "\a" ; sleep 0.1 ; echo -ne "\a" ; sleep 1
+ echo -ne "\a" ; sleep 0.1 ; echo -ne "\a" ; sleep 1
+ sleep 4
+}