summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-12-21 23:32:10 +0000
committerMike Frysinger <vapier@gentoo.org>2010-12-21 23:32:10 +0000
commit683b8b331f85ccb0768140ee27ffb9dd02ecf028 (patch)
treea2a29427953c49ec206fd66b76acf6e888fb616e /sys-apps/busybox
parentAdd support for multiple python slots, bug #309045. (diff)
downloadhistorical-683b8b331f85ccb0768140ee27ffb9dd02ecf028.tar.gz
historical-683b8b331f85ccb0768140ee27ffb9dd02ecf028.tar.bz2
historical-683b8b331f85ccb0768140ee27ffb9dd02ecf028.zip
tweak src_install too to handle static build with USE=pam #345665
Diffstat (limited to 'sys-apps/busybox')
-rw-r--r--sys-apps/busybox/busybox-1.17.4.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-apps/busybox/busybox-1.17.4.ebuild b/sys-apps/busybox/busybox-1.17.4.ebuild
index b04010655ca0..92ab00bd0f72 100644
--- a/sys-apps/busybox/busybox-1.17.4.ebuild
+++ b/sys-apps/busybox/busybox-1.17.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.17.4.ebuild,v 1.2 2010/11/27 00:45:02 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.17.4.ebuild,v 1.3 2010/12/21 23:32:10 vapier Exp $
EAPI=2
inherit eutils flag-o-matic savedconfig toolchain-funcs
@@ -196,13 +196,13 @@ src_install() {
into /
newbin busybox_unstripped busybox || die
- if use static || use pam ; then
+ if use static ; then
dosym busybox /bin/bb || die
dosym bb /bin/busybox.static || die
else
dobin bb || die
fi
- if use mdev; then
+ if use mdev ; then
dodir /$(get_libdir)/mdev/
use make-symlinks || dosym /bin/bb /sbin/mdev
cp "${S}"/examples/mdev_fat.conf "${D}"/etc/mdev.conf