summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Brindle <method@gentoo.org>2003-04-05 06:40:46 +0000
committerJoshua Brindle <method@gentoo.org>2003-04-05 06:40:46 +0000
commit1505c58503b27a5ba55d7ae6c934a980daa998ba (patch)
treed9787cb2b491567f4794ed9df1ef3136568c9767 /sys-apps/coreutils
parentfixo (diff)
downloadhistorical-1505c58503b27a5ba55d7ae6c934a980daa998ba.tar.gz
historical-1505c58503b27a5ba55d7ae6c934a980daa998ba.tar.bz2
historical-1505c58503b27a5ba55d7ae6c934a980daa998ba.zip
version bump
Diffstat (limited to 'sys-apps/coreutils')
-rw-r--r--sys-apps/coreutils/ChangeLog7
-rw-r--r--sys-apps/coreutils/coreutils-5.0.ebuild99
-rw-r--r--sys-apps/coreutils/files/digest-coreutils-5.04
3 files changed, 109 insertions, 1 deletions
diff --git a/sys-apps/coreutils/ChangeLog b/sys-apps/coreutils/ChangeLog
index 19562c169009..66a017f3ea52 100644
--- a/sys-apps/coreutils/ChangeLog
+++ b/sys-apps/coreutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/coreutils
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.13 2003/03/21 02:47:15 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.14 2003/04/05 06:40:46 method Exp $
+
+*coreutils-5.0 (04 Apr 2003)
+
+ 04 Apr 2003; Joshua Brindle <method@gentoo.org> coreutils-5.0.ebuild:
+ bumped to upstream stable release version
*coreutils-4.5.11 (20 Mar 2003)
diff --git a/sys-apps/coreutils/coreutils-5.0.ebuild b/sys-apps/coreutils/coreutils-5.0.ebuild
new file mode 100644
index 000000000000..2e8f621bcc1c
--- /dev/null
+++ b/sys-apps/coreutils/coreutils-5.0.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.0.ebuild,v 1.1 2003/04/05 06:40:46 method Exp $
+
+inherit eutils
+
+IUSE="nls build selinux"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls...), text utilities (sort, tr, head, wc..), and shell utilities (whoami, who,...)"
+HOMEPAGE="http://www.gnu.org/software/coreutils/"
+SRC_URI="http://ftp.gnu.org/pub/gnu/coreutils/${P}.tar.bz2
+ mirror://gentoo/${PN}-gentoo.tar.bz2
+ selinux? mirror://gentoo/${P}-selinux.patch.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc sparc ~alpha ~hppa arm"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )
+ selinux? ( >=sys-apps/selinux-small-2003011510-r2 )"
+
+PROVIDE="sys-apps/sh-utils
+ sys-apps/fileutils
+ sys-apps/textutils"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ use selinux && epatch ${DISTDIR}/${P}-selinux.patch.bz2
+
+ # patch to remove Stallman's su/wheel group rant (which doesn't apply,
+ # since Gentoo's su is not GNU/su, but that from shadow.
+ epatch ${WORKDIR}/${PN}-gentoo-patches/${PN}-gentoo-rms.patch
+
+ # Patch to add processor specific info to the uname output
+ if [ -z "`use hppa`" ] && [ -z "`use arm`" ]
+ then
+ epatch ${WORKDIR}/${PN}-gentoo-patches/${PN}-gentoo-uname.patch
+ fi
+}
+
+src_compile() {
+ local myconf=""
+ use nls || myconf="--disable-nls"
+
+ econf \
+ --bindir=/bin \
+ ${myconf} || die
+
+ if [ "`use static`" ]
+ then
+ emake LDFLAGS=-static || die
+ else
+ emake || die
+ fi
+}
+
+src_install() {
+ einstall \
+ bindir=${D}/bin || die
+
+ # hostname comes from net-base
+ # hostname does not work with the -f switch, which breaks gnome2
+ # amongst other things
+ rm -f ${D}/{bin,usr/bin}/hostname ${D}/usr/share/man/man1/hostname.*
+
+ # /bin/su comes from sys-apps/shadow
+ rm -f ${D}/{bin,usr/bin}/su ${D}/usr/share/man/man1/su.*
+
+ # /usr/bin/uptime comes from the sys-apps/procps packaga
+ rm -f ${D}/{bin,usr/bin}/uptime ${D}/usr/share/man/man1/uptime*
+
+ cd ${D}
+ dodir /usr/bin
+ rm -rf usr/lib
+ cd usr/bin
+ ln -s ../../bin/* .
+
+ if [ -z "`use build`" ]
+ then
+ cd ${S}
+ dodoc AUTHORS ChangeLog* COPYING NEWS README* THANKS TODO
+ else
+ rm -rf ${D}/usr/share
+ fi
+}
+
+pkg_postinst() {
+ # hostname does not get removed as it is included with older stage1
+ # tarballs, and net-tools installs to /bin
+ if [ -e ${ROOT}/usr/bin/hostname ] && [ ! -L ${ROOT}/usr/bin/hostname ]
+ then
+ rm -f ${ROOT}/usr/bin/hostname
+ fi
+}
diff --git a/sys-apps/coreutils/files/digest-coreutils-5.0 b/sys-apps/coreutils/files/digest-coreutils-5.0
new file mode 100644
index 000000000000..04ac73cadcb3
--- /dev/null
+++ b/sys-apps/coreutils/files/digest-coreutils-5.0
@@ -0,0 +1,4 @@
+MD5 4c3ea9caedc3126681407d8252199f68 /coreutils-5.0.ebuild 2503
+MD5 94e5558ee2a65723d4840bfde2d323f0 coreutils-5.0.tar.bz2 3952653
+MD5 756b3fae8ad0eb7a6d3c573a659216dd coreutils-gentoo.tar.bz2 2335
+MD5 a2ac2771e84905282b5653c9b35a58d6 coreutils-5.0-selinux.patch.bz2 20084