summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2002-10-05 08:25:36 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2002-10-05 08:25:36 +0000
commit3b7bb73023f00fa0126f4a3865349c6388bd5882 (patch)
treec412d7bcd88f583007c1bc3e0424a50708689069 /sys-apps/dmapi/dmapi-2.0.5.ebuild
parentModernized ebuilds and fixed symlinks (diff)
downloadhistorical-3b7bb73023f00fa0126f4a3865349c6388bd5882.tar.gz
historical-3b7bb73023f00fa0126f4a3865349c6388bd5882.tar.bz2
historical-3b7bb73023f00fa0126f4a3865349c6388bd5882.zip
Modernized ebuilds and fixed symlinks
Diffstat (limited to 'sys-apps/dmapi/dmapi-2.0.5.ebuild')
-rw-r--r--sys-apps/dmapi/dmapi-2.0.5.ebuild29
1 files changed, 18 insertions, 11 deletions
diff --git a/sys-apps/dmapi/dmapi-2.0.5.ebuild b/sys-apps/dmapi/dmapi-2.0.5.ebuild
index 1683219badca..f4d1479cfb49 100644
--- a/sys-apps/dmapi/dmapi-2.0.5.ebuild
+++ b/sys-apps/dmapi/dmapi-2.0.5.ebuild
@@ -1,37 +1,44 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmapi/dmapi-2.0.5.ebuild,v 1.2 2002/10/04 06:24:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmapi/dmapi-2.0.5.ebuild,v 1.3 2002/10/05 08:25:36 bcowan Exp $
S=${WORKDIR}/${P}
+
DESCRIPTION="XFS data management API library"
+
SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz"
HOMEPAGE="http://oss.sgi.com/projects/xfs"
+
KEYWORDS="x86 ppc sparc sparc64"
SLOT="0"
LICENSE="LGPL-2.1"
-DEPEND="virtual/glibc sys-devel/autoconf sys-devel/make sys-apps/xfsprogs"
-RDEPEND="virtual/glibc"
+DEPEND="sys-apps/xfsprogs"
+RDEPEND="${DEPEND}"
src_compile() {
- cd ${S}
- export OPTIMIZER="${CFLAGS}"
- export DEBUG=-DNDEBUG
+ OPTIMIZER="${CFLAGS}"
+ DEBUG=-DNDEBUG
+
autoconf || die
- ./configure --prefix=/usr || die
- # 1) add a ${DESTDIR} prefix to all install paths so we can relocate during the "install" phase
- # 2) we also set the /usr/share/doc/ directory to the correct value.
- # 3) we remove a hard-coded "-O1"
- # 4) we fix some Makefile-created library symlinks that contains absolute paths
+
+ ./configure --prefix=/usr \
+ --libexecdir=/lib || die
+
cp include/builddefs include/builddefs.orig
sed -e 's:^PKG_\(.*\)_DIR = \(.*\)$:PKG_\1_DIR = ${DESTDIR}\2:' \
-e "s:/usr/share/doc/${PN}:/usr/share/doc/${PF}:" \
-e 's:-O1::' \
-e 's:../$(INSTALL) -S \(.*\) $(PKG_.*_DIR)/\(.*$\)::' \
include/builddefs.orig > include/builddefs || die
+
emake || die
}
src_install() {
make DESTDIR=${D} install install-dev || die
+
+ dosym /lib/libdm.a /usr/lib/libdm.a
+ dosym /lib/libdm.la /usr/lib/libdm.la
+ dosym /usr/lib/libdm.so /lib/libdm.so
}