summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChad Huneycutt <chadh@gentoo.org>2001-08-03 23:13:40 +0000
committerChad Huneycutt <chadh@gentoo.org>2001-08-03 23:13:40 +0000
commitcc676c993a5adeaaf3099e6111ecfb4398147d61 (patch)
treeaec1c58cc54c887d560f62582cb4ab7283c2d548 /sys-apps/ed
parentfixed info warnings. (diff)
downloadhistorical-cc676c993a5adeaaf3099e6111ecfb4398147d61.tar.gz
historical-cc676c993a5adeaaf3099e6111ecfb4398147d61.tar.bz2
historical-cc676c993a5adeaaf3099e6111ecfb4398147d61.zip
fixed info directory entry.
Diffstat (limited to 'sys-apps/ed')
-rw-r--r--sys-apps/ed/ed-0.2-r2.ebuild35
-rw-r--r--sys-apps/ed/files/ed-0.2-r2-gentoo.diff15
2 files changed, 50 insertions, 0 deletions
diff --git a/sys-apps/ed/ed-0.2-r2.ebuild b/sys-apps/ed/ed-0.2-r2.ebuild
new file mode 100644
index 000000000000..d1ae979fce0a
--- /dev/null
+++ b/sys-apps/ed/ed-0.2-r2.ebuild
@@ -0,0 +1,35 @@
+#!/usr/bin/ebuild
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ed/ed-0.2-r2.ebuild,v 1.1 2001/08/03 23:13:40 chadh Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Your basic line editor"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/ed/${A}
+ ftp://ftp.gnu.org/pub/gnu/ed/${A}"
+HOMEPAGE="http://www.gnu.org/software/ed/"
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+
+ try ./configure --prefix=/ --host=${CHOST}
+ try pmake
+}
+
+src_install() {
+
+ try make prefix=${D}/ mandir=${D}/usr/share/man/man1 infodir=${D}/usr/share/info \
+ install
+ dodoc COPYING ChangeLog NEWS POSIX README THANKS TODO
+
+}
+
+
diff --git a/sys-apps/ed/files/ed-0.2-r2-gentoo.diff b/sys-apps/ed/files/ed-0.2-r2-gentoo.diff
new file mode 100644
index 000000000000..f99b00fd7626
--- /dev/null
+++ b/sys-apps/ed/files/ed-0.2-r2-gentoo.diff
@@ -0,0 +1,15 @@
+diff -r -C2 ed-0.2.orig/ed.texinfo ed-0.2/ed.texinfo
+*** ed-0.2.orig/ed.texinfo Sat Nov 19 07:38:01 1994
+--- ed-0.2/ed.texinfo Fri Aug 3 19:03:33 2001
+***************
+*** 8,11 ****
+--- 8,16 ----
+
+ @ifinfo
++
++ @direntry
++ * ed: (ed). line editor.
++ @end direntry
++
+ This file documents the @code{ed} command, which has the purpose of
+ editing text files.