summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-10-16 02:08:17 +0000
committerMike Frysinger <vapier@gentoo.org>2006-10-16 02:08:17 +0000
commit4fed44ab7dbce92fcae4974c16170055de80e316 (patch)
treec9ca88899a87a277ded07e0a25d824ebe6f56c8e /sys-apps/eject/eject-2.1.5-r1.ebuild
parentMarking amd64 stable; cleaning up ebuilds (diff)
downloadhistorical-4fed44ab7dbce92fcae4974c16170055de80e316.tar.gz
historical-4fed44ab7dbce92fcae4974c16170055de80e316.tar.bz2
historical-4fed44ab7dbce92fcae4974c16170055de80e316.zip
Handle spaces in mounts #151257 by Adam Goossens.
Package-Manager: portage-2.1.2_pre2-r9
Diffstat (limited to 'sys-apps/eject/eject-2.1.5-r1.ebuild')
-rw-r--r--sys-apps/eject/eject-2.1.5-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-apps/eject/eject-2.1.5-r1.ebuild b/sys-apps/eject/eject-2.1.5-r1.ebuild
new file mode 100644
index 000000000000..dee27fb076f6
--- /dev/null
+++ b/sys-apps/eject/eject-2.1.5-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/eject/eject-2.1.5-r1.ebuild,v 1.1 2006/10/16 02:08:17 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="A command to eject a disc from the CD-ROM drive"
+HOMEPAGE="http://eject.sourceforge.net/ http://ca.geocities.com/jefftranter@rogers.com/eject.html"
+SRC_URI="http://www.ibiblio.org/pub/Linux/utils/disk-management/${P}.tar.gz
+ http://www.pobox.com/~tranter/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls"
+
+DEPEND="!virtual/eject"
+PROVIDE="virtual/eject"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}"-2.0.13-xmalloc.patch
+ epatch "${FILESDIR}/${PN}"-2.1.4-scsi-rdwr.patch
+ epatch "${FILESDIR}/${PN}"-2.1.5-handle-spaces.patch #151257
+}
+
+src_compile() {
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog README PORTING TODO AUTHORS NEWS PROBLEMS
+}