summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-09-30 03:53:22 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-09-30 03:53:22 +0000
commitc27cd6142859831b6b54f326f369fa36b021d367 (patch)
treeb2e9e7b9e8a198c99a0b3703ad5b0db9604e30fc /sys-apps/fakeroot/fakeroot-0.4.4-r1.ebuild
parentTightened the gimp dependancy to =gimp-1.2* (diff)
downloadhistorical-c27cd6142859831b6b54f326f369fa36b021d367.tar.gz
historical-c27cd6142859831b6b54f326f369fa36b021d367.tar.bz2
historical-c27cd6142859831b6b54f326f369fa36b021d367.zip
resolves bug 8538
Diffstat (limited to 'sys-apps/fakeroot/fakeroot-0.4.4-r1.ebuild')
-rw-r--r--sys-apps/fakeroot/fakeroot-0.4.4-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-apps/fakeroot/fakeroot-0.4.4-r1.ebuild b/sys-apps/fakeroot/fakeroot-0.4.4-r1.ebuild
new file mode 100644
index 000000000000..b4b2dce8f97b
--- /dev/null
+++ b/sys-apps/fakeroot/fakeroot-0.4.4-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fakeroot/fakeroot-0.4.4-r1.ebuild,v 1.1 2002/09/30 03:53:22 mkennedy Exp $
+
+MY_P="${PN}_${PV}-4.1"
+
+DESCRIPTION="Run commands in an environment faking root privileges"
+HOMEPAGE="http://joostje.op.het.net/fakeroot/index.html"
+SRC_URI="http://ftp.debian.org/debian/dists/potato/main/source/utils/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+RDEPEND=">=virtual/glibc-2.2.2"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} && patch -p1 <${FILESDIR}/fakeroot-gcc3-gentoo.patch || die
+}
+
+src_compile() {
+ econf || die "configure problem"
+ emake || die "compile problem"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "install problem"
+}