summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-27 16:34:41 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-27 16:34:41 +0000
commit0885c6078c014b1b87cefda98fe614c170af18ce (patch)
tree547a058b6ad6c694fe02879bd5deb8c83739232a /sys-apps/fileutils
parentReplaced manual install with DESTDIR=${D} method (diff)
downloadhistorical-0885c6078c014b1b87cefda98fe614c170af18ce.tar.gz
historical-0885c6078c014b1b87cefda98fe614c170af18ce.tar.bz2
historical-0885c6078c014b1b87cefda98fe614c170af18ce.zip
Now uses USE nls and build
Diffstat (limited to 'sys-apps/fileutils')
-rw-r--r--sys-apps/fileutils/fileutils-4.0.36-r3.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sys-apps/fileutils/fileutils-4.0.36-r3.ebuild b/sys-apps/fileutils/fileutils-4.0.36-r3.ebuild
new file mode 100644
index 000000000000..24e01dde78df
--- /dev/null
+++ b/sys-apps/fileutils/fileutils-4.0.36-r3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fileutils/fileutils-4.0.36-r3.ebuild,v 1.1 2001/02/27 16:34:41 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls, etc)"
+SRC_URI="ftp://alpha.gnu.org/gnu/fetish/${A}"
+HOMEPAGE="http://www.gnu.org/software/fileutils/fileutils.html"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="virtual/glibc"
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+ try ./configure --prefix=/usr --mandir=/usr/share/man \
+ --infodir=/usr/share/info --bindir=/bin ${myconf}
+ if [ -z "`use static`" ]
+ then
+ try make ${MAKEOPTS}
+ else
+ try make ${MAKEOPTS} LDFLAGS=-static
+ fi
+}
+
+src_install() {
+
+ if [ -z "`use build`" ]
+ then
+ make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info bindir=${D}/bin install
+ cd ${D}
+ dodir /usr/bin
+ rm -rf usr/lib
+ cd usr/bin
+ ln -s ../../bin/* .
+ cd ${S}
+ dodoc COPYING NEWS README* THANKS TODO ChangeLog ChangeLog-1997 AUTHORS
+ else
+ cd ${S}/src
+ into /
+ dobin chgrp chown dd dir du ln mkdir mknod rm touch \
+ chmod cp df ls mkfifo mv rmdir sync
+ newbin ginstall install
+ dosym /bin/install /usr/bin/install
+ fi
+
+}
+