summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Guertin <gerk@gentoo.org>2002-06-21 20:47:50 +0000
committerMark Guertin <gerk@gentoo.org>2002-06-21 20:47:50 +0000
commit5c5a5fb79746a1e190179cff8c40afc6de04e0b9 (patch)
treeea92ecd6f6e1550989f71ca808177296ad74c615 /sys-apps/gtkpbbuttons/gtkpbbuttons-0.4.6b.ebuild
parentunmask new ethereal, works here, haven't heard any issues (diff)
downloadhistorical-5c5a5fb79746a1e190179cff8c40afc6de04e0b9.tar.gz
historical-5c5a5fb79746a1e190179cff8c40afc6de04e0b9.tar.bz2
historical-5c5a5fb79746a1e190179cff8c40afc6de04e0b9.zip
updated arch detect setup
Diffstat (limited to 'sys-apps/gtkpbbuttons/gtkpbbuttons-0.4.6b.ebuild')
-rw-r--r--sys-apps/gtkpbbuttons/gtkpbbuttons-0.4.6b.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sys-apps/gtkpbbuttons/gtkpbbuttons-0.4.6b.ebuild b/sys-apps/gtkpbbuttons/gtkpbbuttons-0.4.6b.ebuild
index 295e55a1a537..cdc88e5e84fb 100644
--- a/sys-apps/gtkpbbuttons/gtkpbbuttons-0.4.6b.ebuild
+++ b/sys-apps/gtkpbbuttons/gtkpbbuttons-0.4.6b.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author David Chamberlain <daybird@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gtkpbbuttons/gtkpbbuttons-0.4.6b.ebuild,v 1.2 2002/05/09 15:36:34 daybird Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gtkpbbuttons/gtkpbbuttons-0.4.6b.ebuild,v 1.3 2002/06/21 20:42:58 gerk Exp $
S=${WORKDIR}/${P}
DESCRIPTION="gtkpbbuttons is a PPC-only program to monitor special Powerbook/iBook keys in Linux"
@@ -12,6 +12,11 @@ DEPEND="x11-libs/gtk+ media-libs/audiofile sys-apps/pbbuttonsd"
src_compile() {
+ if [ ${ARCH} = "x86" ] ; then
+ einfo "PPC Only build, sorry"
+ exit 1
+ fi
+
./configure --prefix=/usr || die "sorry, ppc-only package"
make || die "sorry, gtkpbbuttons compile failed"
}