summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Guertin <gerk@gentoo.org>2002-06-21 20:47:50 +0000
committerMark Guertin <gerk@gentoo.org>2002-06-21 20:47:50 +0000
commit5c5a5fb79746a1e190179cff8c40afc6de04e0b9 (patch)
treeea92ecd6f6e1550989f71ca808177296ad74c615 /sys-apps/hfsutils
parentunmask new ethereal, works here, haven't heard any issues (diff)
downloadhistorical-5c5a5fb79746a1e190179cff8c40afc6de04e0b9.tar.gz
historical-5c5a5fb79746a1e190179cff8c40afc6de04e0b9.tar.bz2
historical-5c5a5fb79746a1e190179cff8c40afc6de04e0b9.zip
updated arch detect setup
Diffstat (limited to 'sys-apps/hfsutils')
-rw-r--r--sys-apps/hfsutils/hfsutils-3.2.6.ebuild35
1 files changed, 11 insertions, 24 deletions
diff --git a/sys-apps/hfsutils/hfsutils-3.2.6.ebuild b/sys-apps/hfsutils/hfsutils-3.2.6.ebuild
index b626795229ac..4934a341d79f 100644
--- a/sys-apps/hfsutils/hfsutils-3.2.6.ebuild
+++ b/sys-apps/hfsutils/hfsutils-3.2.6.ebuild
@@ -1,38 +1,25 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Maintainer: Kain X <kain@kain.org>
-# $Id: hfsutils-3.2.6.ebuild,v 1.1 2002/04/27 10:28:33 pvdabeel Exp $
+# $ Header: $
-# Source directory; the dir where the sources can be found
-# (automatically unpacked) inside ${WORKDIR}. Usually you can just
-# leave this as-is.
S=${WORKDIR}/${P}
-
-# Short one-line description of this package.
DESCRIPTION="HFS FS Access utils"
-
-# Point to any required sources; these will be automatically
-# downloaded by Portage.
SRC_URI="ftp://ftp.mars.org/pub/hfs/${P}.tar.gz"
-
-# Homepage, not used by Portage directly but handy for developer reference
HOMEPAGE="http://www.mars.org/home/rob/proj/hfs/"
-
-# Build-time dependencies, such as
-# ssl? ( >=openssl-0.9.6b )
-# >=perl-5.6.1-r1
-# It is advisable to use the >= syntax show above, to reflect what you
-# had installed on your system when you tested the package. Then
-# other users hopefully won't be caught without the right version of
-# a dependency.
-DEPEND=""
-
-# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
-#RDEPEND=""
+DEPEND="virtual/glibc"
+RDEPEND=""
+SLOT="0"
+LICENSE="0"
MAKEOPTS='PREFIX=/usr MANDIR=/usr/share/man'
src_compile() {
+
+ if [ ${ARCH} = "x86" ] ; then
+ einfo "PPC Only build, sorry"
+ exit 1
+ fi
+
./configure \
--host=${CHOST} \
--prefix=/usr \