summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-04-14 10:31:18 +0000
committerMichael Weber <xmw@gentoo.org>2012-04-14 10:31:18 +0000
commit5296c46db55c89921fc9a98a0f6310a5556c4bb9 (patch)
tree9f35e5685ed080e13894c67c32882d9b34258521 /sys-apps/i2c-tools/i2c-tools-3.1.0.ebuild
parentBump hashtables to 1.0.1.3. EAPI=4. [profile?] on haskell libs, part of fix f... (diff)
downloadhistorical-5296c46db55c89921fc9a98a0f6310a5556c4bb9.tar.gz
historical-5296c46db55c89921fc9a98a0f6310a5556c4bb9.tar.bz2
historical-5296c46db55c89921fc9a98a0f6310a5556c4bb9.zip
Version bump (non-maint commit, bug 410277).
Package-Manager: portage-2.1.10.49/cvs/Linux x86_64
Diffstat (limited to 'sys-apps/i2c-tools/i2c-tools-3.1.0.ebuild')
-rw-r--r--sys-apps/i2c-tools/i2c-tools-3.1.0.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/sys-apps/i2c-tools/i2c-tools-3.1.0.ebuild b/sys-apps/i2c-tools/i2c-tools-3.1.0.ebuild
new file mode 100644
index 000000000000..e82d85e5cdde
--- /dev/null
+++ b/sys-apps/i2c-tools/i2c-tools-3.1.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c-tools/i2c-tools-3.1.0.ebuild,v 1.1 2012/04/14 10:31:18 xmw Exp $
+
+EAPI="4"
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit flag-o-matic toolchain-funcs distutils
+
+DESCRIPTION="I2C tools for bus probing, chip dumping, register-level access helpers, EEPROM decoding scripts, and more"
+HOMEPAGE="http://www.lm-sensors.org/wiki/I2CTools"
+SRC_URI="http://dl.lm-sensors.org/i2c-tools/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~sparc ~x86"
+IUSE="python"
+
+DEPEND="!<sys-apps/lm_sensors-3"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ use python && python_pkg_setup
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}"
+ emake -C eepromer CC=$(tc-getCC) CFLAGS="${CFLAGS} -I../include"
+ if use python ; then
+ cd py-smbus || die
+ append-cppflags -I../include
+ distutils_src_compile
+ fi
+}
+
+src_install() {
+ emake install prefix="${D}"/usr
+ dosbin eepromer/eepro{g,m{,er}}
+ rm -rf "${D}"/usr/include # part of linux-headers
+ dodoc CHANGES README
+ local d
+ for d in eeprom eepromer ; do
+ docinto ${d}
+ dodoc ${d}/README*
+ done
+
+ if use python ; then
+ cd py-smbus || die
+ docinto py-smbus
+ dodoc README*
+ distutils_src_install
+ fi
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}