summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-08-25 17:57:04 +0000
committerMike Frysinger <vapier@gentoo.org>2007-08-25 17:57:04 +0000
commit71ad2ac80b4e18e8818cb6a5bf3afe6550e2b51b (patch)
tree0342ab37d34c2e680bc2d2d24aa761cb6a968a6c /sys-apps/initng
parentamd64 stable (diff)
downloadhistorical-71ad2ac80b4e18e8818cb6a5bf3afe6550e2b51b.tar.gz
historical-71ad2ac80b4e18e8818cb6a5bf3afe6550e2b51b.tar.bz2
historical-71ad2ac80b4e18e8818cb6a5bf3afe6550e2b51b.zip
old
Diffstat (limited to 'sys-apps/initng')
-rw-r--r--sys-apps/initng/files/digest-initng-0.6.73
-rw-r--r--sys-apps/initng/files/initng-0.6.7-inotify-ppc.patch11
-rw-r--r--sys-apps/initng/initng-0.6.7.ebuild68
3 files changed, 0 insertions, 82 deletions
diff --git a/sys-apps/initng/files/digest-initng-0.6.7 b/sys-apps/initng/files/digest-initng-0.6.7
deleted file mode 100644
index a3b60b28c7e5..000000000000
--- a/sys-apps/initng/files/digest-initng-0.6.7
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 8d13fe887623762599a55c4e9640c010 initng-0.6.7.tar.bz2 366277
-RMD160 4945faae124ceca2450ac5e33ffbbcbae7e3dc72 initng-0.6.7.tar.bz2 366277
-SHA256 9e6dbf8a9163d428cad828e704b05af0c6a204cc91ddeaad8e9180d6cf0aca09 initng-0.6.7.tar.bz2 366277
diff --git a/sys-apps/initng/files/initng-0.6.7-inotify-ppc.patch b/sys-apps/initng/files/initng-0.6.7-inotify-ppc.patch
deleted file mode 100644
index 5371d0a800d8..000000000000
--- a/sys-apps/initng/files/initng-0.6.7-inotify-ppc.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- initng-0.6.7/plugins/fmon/inotify-syscalls.h
-+++ initng-0.6.7/plugins/fmon/inotify-syscalls.h
-@@ -11,7 +11,7 @@
- # define __NR_inotify_init 253
- # define __NR_inotify_add_watch 254
- # define __NR_inotify_rm_watch 255
--#elif defined(__ppc__)
-+#elif defined(__powerpc__)
- # define __NR_inotify_init 275
- # define __NR_inotify_add_watch 276
- # define __NR_inotify_rm_watch 277
diff --git a/sys-apps/initng/initng-0.6.7.ebuild b/sys-apps/initng/initng-0.6.7.ebuild
deleted file mode 100644
index ea5ce9c975a7..000000000000
--- a/sys-apps/initng/initng-0.6.7.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/initng/initng-0.6.7.ebuild,v 1.4 2006/08/31 02:20:58 vapier Exp $
-
-inherit eutils
-
-DESCRIPTION="A next generation init replacement"
-HOMEPAGE="http://initng.org/"
-SRC_URI="http://download.initng.org/initng/v${PV:0:3}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- >=dev-util/cmake-2.1"
-PDEPEND="sys-apps/initng-ifiles"
-
-plugin_warning() {
- if [[ -z ${INITNG_PLUGINS} ]] ; then
- einfo "If you want to customize the list of initng plugins, please"
- einfo "set the INITNG_PLUGINS variable in your make.conf."
- einfo "See http://www.initng.org/wiki/Documents_Plugins for a list of"
- einfo "valid plugins for you to choose from."
- fi
-}
-
-pkg_setup() {
- plugin_warning
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-inotify-ppc.patch #145595
- sed -i -e 's:-Werror::' CMakeLists.txt #136992
-}
-
-src_compile() {
- local x default_opts valid_opts cmake_opts=""
- valid_opts=$(sed -n '/^OPTION/ s:.*(\([[:alpha:]_]*\).*:\1:p' CMakeLists.txt)
- default_opts=$(sed -n '/^OPTION(.*ON)$/ s:.*(\([[:alpha:]_]*\).*:\1:p' CMakeLists.txt)
- INITNG_PLUGINS=$(echo ${INITNG_PLUGINS} | tr '[:lower:]' '[:upper:]')
- INITNG_PLUGINS=${INITNG_PLUGINS:-${default_opts}}
- for x in ${valid_opts} ; do
- if hasq ${x} ${INITNG_PLUGINS} || hasq ${x#BUILD_} ${INITNG_PLUGINS} ; then
- cmake_opts="${cmake_opts} -D${x}=ON"
- else
- cmake_opts="${cmake_opts} -D${x}=OFF"
- fi
- done
- cmake -DCMAKE_INSTALL_PREFIX=/ ${cmake_opts} || die
- emake || die
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- find "${D}" -name '*.a' -exec rm "{}" \;
- dodoc AUTHORS ChangeLog NEWS README TODO
-}
-
-pkg_postinst() {
- plugin_warning
- einfo "Remember to add init=/sbin/initng in your grub or lilo config"
- einfo " in order to use initng. Happy testing!"
-}