summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-10-18 21:41:55 +0000
committerMike Frysinger <vapier@gentoo.org>2011-10-18 21:41:55 +0000
commit7d8e2d84a83183f1018e4f8b5100a5a9fc32a39a (patch)
tree2f8772072ace4624361a57df46a44dddec4bcce2 /sys-apps/iproute2/files
parentOnly skip KDE for gdu-notification-daemon autostart. (diff)
downloadhistorical-7d8e2d84a83183f1018e4f8b5100a5a9fc32a39a.tar.gz
historical-7d8e2d84a83183f1018e4f8b5100a5a9fc32a39a.tar.bz2
historical-7d8e2d84a83183f1018e4f8b5100a5a9fc32a39a.zip
Fix parallel builds in the tc subdir.
Package-Manager: portage-2.2.0_alpha65/cvs/Linux x86_64
Diffstat (limited to 'sys-apps/iproute2/files')
-rw-r--r--sys-apps/iproute2/files/iproute2-2.6.38-parallel-build.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/iproute2/files/iproute2-2.6.38-parallel-build.patch b/sys-apps/iproute2/files/iproute2-2.6.38-parallel-build.patch
new file mode 100644
index 000000000000..7966cfce5044
--- /dev/null
+++ b/sys-apps/iproute2/files/iproute2-2.6.38-parallel-build.patch
@@ -0,0 +1,40 @@
+sent upstream already
+
+From f8a783bbe98b0fe5aaedbf623bc70471b88c9187 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Tue, 18 Oct 2011 17:36:55 -0400
+Subject: [PATCH] tc: fix parallel build file with lex/yacc
+
+Building iproute2 in parallel might hit the race failure:
+ emp_ematch.l:2:30: fatal error: emp_ematch.yacc.h:
+ No such file or directory
+ make[1]: *** [emp_ematch.lex.o] Error 1
+
+This is because we currently allow the yacc/lex files to generate and
+compile in parallel. So add a simple dependency to make sure yacc has
+finished before we attempt to compile the lex output.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ tc/Makefile | 5 +++++
+ 1 files changed, 5 insertions(+), 0 deletions(-)
+
+diff --git a/tc/Makefile b/tc/Makefile
+index 08aa4ce..b2ca165 100644
+--- a/tc/Makefile
++++ b/tc/Makefile
+@@ -136,6 +136,11 @@ m_xt_old.so: m_xt_old.c
+ %.lex.c: %.l
+ $(LEX) $(LEXFLAGS) -o$@ $<
+
++# our lexer includes the header from yacc, so make sure
++# we don't attempt to compile it before the header has
++# been generated as part of the yacc step.
++emp_ematch.lex.o: emp_ematch.yacc.c
++
+ ifneq ($(SHARED_LIBS),y)
+
+ tc: static-syms.o
+--
+1.7.6.1
+