summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2008-03-21 09:43:55 +0000
committerStefan Schweizer <genstef@gentoo.org>2008-03-21 09:43:55 +0000
commitaedf91baf5a690606d47d1242962211b4835321b (patch)
tree526cae052820b8b632bfda553e1181611cff29af /sys-apps/kexec-tools/files
parentversion bump, bug 212821 (diff)
downloadhistorical-aedf91baf5a690606d47d1242962211b4835321b.tar.gz
historical-aedf91baf5a690606d47d1242962211b4835321b.tar.bz2
historical-aedf91baf5a690606d47d1242962211b4835321b.zip
remove failing patch thanks to pioto in bug 213426 and fix init script for openrc, bug 214018
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'sys-apps/kexec-tools/files')
-rw-r--r--sys-apps/kexec-tools/files/kexec-tools-9999-LDFLAGS.patch14
-rwxr-xr-xsys-apps/kexec-tools/files/kexec.init4
2 files changed, 2 insertions, 16 deletions
diff --git a/sys-apps/kexec-tools/files/kexec-tools-9999-LDFLAGS.patch b/sys-apps/kexec-tools/files/kexec-tools-9999-LDFLAGS.patch
deleted file mode 100644
index c982a3579509..000000000000
--- a/sys-apps/kexec-tools/files/kexec-tools-9999-LDFLAGS.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-this should really be rewritten to invoke the compiler driver (gcc) rather than
-the linker (ld) ...
-
---- purgatory/Makefile
-+++ purgatory/Makefile
-@@ -59,7 +59,7 @@
-
- $(PURGATORY): $(PURGATORY_OBJS) $(UTIL_LIB)
- $(MKDIR) -p $(@D)
-- $(LD) $(LDFLAGS) $(EXTRA_LDFLAGS) --no-undefined -e purgatory_start -r -o $@ $(PURGATORY_OBJS) $(UTIL_LIB)
-+ $(LD) $(EXTRA_LDFLAGS) --no-undefined -e purgatory_start -r -o $@ $(PURGATORY_OBJS) $(UTIL_LIB)
-
- echo::
- @echo "PURGATORY_C_SRCS $(PURGATORY_C_SRCS)"
diff --git a/sys-apps/kexec-tools/files/kexec.init b/sys-apps/kexec-tools/files/kexec.init
index 10cf6e58a63a..7fb12935c2f3 100755
--- a/sys-apps/kexec-tools/files/kexec.init
+++ b/sys-apps/kexec-tools/files/kexec.init
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kexec-tools/files/kexec.init,v 1.10 2008/01/21 08:51:10 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kexec-tools/files/kexec.init,v 1.11 2008/03/21 09:43:55 genstef Exp $
depend() {
need localmount
@@ -83,7 +83,7 @@ stop() {
[ "${LOAD_DURING_SHUTDOWN:-yes}" != "yes" ] && return 0
ebegin "Configuring kexec"
- if [ "${RC_SOFTLEVEL:-${SOFTLEVEL}}" != "reboot" ] || ! is_runlevel_stop ; then
+ if [ "${RC_SOFTLEVEL:-${SOFTLEVEL}}" != "reboot" ]; then
einfo "Not rebooting, so disabling"
kexec -u
return 0