summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-09-07 01:35:25 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-09-07 01:35:25 +0000
commitb86c7e321ac8c7fce61aaf9877309fa693843521 (patch)
treeb8f193974f6a4703fd2b951796ff90f736e9a2b9 /sys-apps/lilo/lilo-22.5.6-r3.ebuild
parentInitial import of supertab vim plugin, submitted by Ciaran McCreesh in bug 27782 (diff)
downloadhistorical-b86c7e321ac8c7fce61aaf9877309fa693843521.tar.gz
historical-b86c7e321ac8c7fce61aaf9877309fa693843521.tar.bz2
historical-b86c7e321ac8c7fce61aaf9877309fa693843521.zip
repoman: whitespace cleanup
Diffstat (limited to 'sys-apps/lilo/lilo-22.5.6-r3.ebuild')
-rw-r--r--sys-apps/lilo/lilo-22.5.6-r3.ebuild68
1 files changed, 34 insertions, 34 deletions
diff --git a/sys-apps/lilo/lilo-22.5.6-r3.ebuild b/sys-apps/lilo/lilo-22.5.6-r3.ebuild
index 7587b27ea7d3..7662a4fd8638 100644
--- a/sys-apps/lilo/lilo-22.5.6-r3.ebuild
+++ b/sys-apps/lilo/lilo-22.5.6-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/lilo-22.5.6-r3.ebuild,v 1.2 2003/08/03 21:02:20 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/lilo-22.5.6-r3.ebuild,v 1.3 2003/09/07 01:28:12 msterret Exp $
inherit mount-boot eutils
@@ -49,10 +49,10 @@ src_install() {
make ROOT=${D} install || die
into /usr
dosbin keytab-lilo.pl
-
+
insinto /etc
newins ${FILESDIR}/lilo.conf lilo.conf.example
-
+
doman manPages/*.[5-8]
dodoc CHANGES COPYING INCOMPAT README*
docinto samples ; dodoc sample/*
@@ -74,16 +74,16 @@ pkg_preinst() {
lilocheck () {
local bootpart=
local rootpart="$(rdev 2> /dev/null | cut -d ' ' -f 1 2> /dev/null)"
-
+
echo
- einfon "Checking for LILO ..."
-
- if [ "$(whoami)" != "root" ]
+ einfon "Checking for LILO ..."
+
+ if [ "$(whoami)" != "root" ]
then
echo; echo
- eerror "Only root can check for LILO!"
- return 1
- fi
+ eerror "Only root can check for LILO!"
+ return 1
+ fi
if [ -z "${rootpart}" ]
then
@@ -91,32 +91,32 @@ lilocheck () {
eerror "Could not determine root partition!"
return 1
fi
-
- if [ ! -f /etc/lilo.conf -o ! -x /sbin/lilo ]
+
+ if [ ! -f /etc/lilo.conf -o ! -x /sbin/lilo ]
then
- echo " No"
- return 1
- fi
-
- bootpart="$(perl -ne 'print $1 if /^\s*boot\s*=\s*(\S*)/' /etc/lilo.conf)"
-
- if [ -z "${bootpart}" ]
+ echo " No"
+ return 1
+ fi
+
+ bootpart="$(perl -ne 'print $1 if /^\s*boot\s*=\s*(\S*)/' /etc/lilo.conf)"
+
+ if [ -z "${bootpart}" ]
then
- # lilo defaults to current root when 'boot=' is not present
- bootpart="${rootpart}"
- fi
-
- if ! dd if=${bootpart} ibs=16 count=1 2>&- | grep -q 'LILO'
+ # lilo defaults to current root when 'boot=' is not present
+ bootpart="${rootpart}"
+ fi
+
+ if ! dd if=${bootpart} ibs=16 count=1 2>&- | grep -q 'LILO'
then
echo; echo
- ewarn "Yes, but I couldn't find a LILO signature on ${bootpart}"
- ewarn "Check your /etc/lilo.conf, or run /sbin/lilo by hand."
- return 1
- fi
-
- echo " Yes, on ${bootpart}"
-
- return 0
+ ewarn "Yes, but I couldn't find a LILO signature on ${bootpart}"
+ ewarn "Check your /etc/lilo.conf, or run /sbin/lilo by hand."
+ return 1
+ fi
+
+ echo " Yes, on ${bootpart}"
+
+ return 0
}
@@ -134,13 +134,13 @@ pkg_postinst() {
einfo "Running LILO to complete the install ..."
# do not redirect to /dev/null because it may display some input
# prompt
- /sbin/lilo
+ /sbin/lilo
if [ "$?" -ne 0 ]
then
echo
ewarn "Running /sbin/lilo failed! Please check what the problem is"
ewarn "before your next reboot."
-
+
echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1
echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1
sleep 5