summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2002-02-04 12:52:58 +0000
committerGeert Bevin <gbevin@gentoo.org>2002-02-04 12:52:58 +0000
commita2b2acc54cfb06628c525510a220f0be8e8ebe86 (patch)
treed9c46f956fe0641c5fbfa455b1878c17381b7a61 /sys-apps/lilo
parentMoved xmame to app-emulation with other emulators (Bug 421) (diff)
downloadhistorical-a2b2acc54cfb06628c525510a220f0be8e8ebe86.tar.gz
historical-a2b2acc54cfb06628c525510a220f0be8e8ebe86.tar.bz2
historical-a2b2acc54cfb06628c525510a220f0be8e8ebe86.zip
added pkg-setup() function which checks for /boot being mounted, if this
is not the case the ebuilds try to mount it themselves and in case of failure exit with an error message
Diffstat (limited to 'sys-apps/lilo')
-rw-r--r--sys-apps/lilo/ChangeLog12
-rw-r--r--sys-apps/lilo/files/digest-lilo-22.1-r21
-rw-r--r--sys-apps/lilo/lilo-22.1-r2.ebuild85
3 files changed, 96 insertions, 2 deletions
diff --git a/sys-apps/lilo/ChangeLog b/sys-apps/lilo/ChangeLog
index 59d7cb56cca6..8a86e15f89de 100644
--- a/sys-apps/lilo/ChangeLog
+++ b/sys-apps/lilo/ChangeLog
@@ -1,10 +1,18 @@
# ChangeLog for sys-apps/lilo
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/ChangeLog,v 1.2 2002/02/03 03:46:22 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/ChangeLog,v 1.3 2002/02/04 12:52:58 gbevin Exp $
+*lilo-21.7.5-r2 (4 Feb 2002)
+
+ 4 Feb 2002; G.Bevin <gbevin@gentoo.org> lilo-22.1-r2.ebuild :
+
+ Added new setup function which detects if /boot is mounted or not, in case
+ it's not mounted it will try to do it automatically and in case of a failure
+ exit with an error message.
+
*lilo-21.7.5-r1 (2 Feb 2002)
- 2 Feb 2002; Donny Davies <woodchip@gentoo.org> :
+ 2 Feb 2002; Donny Davies <woodchip@gentoo.org> lilo-22.1-r1.ebuild:
Added several patches from SuSE for animated boot logos. Not completly finished
yet, but totally usable. Please read the ebuild first before merging this!
diff --git a/sys-apps/lilo/files/digest-lilo-22.1-r2 b/sys-apps/lilo/files/digest-lilo-22.1-r2
new file mode 100644
index 000000000000..cec554c6e99d
--- /dev/null
+++ b/sys-apps/lilo/files/digest-lilo-22.1-r2
@@ -0,0 +1 @@
+MD5 ba6830b939e6eeaadf450c68c96a42fb lilo-22.1.tar.gz 319754
diff --git a/sys-apps/lilo/lilo-22.1-r2.ebuild b/sys-apps/lilo/lilo-22.1-r2.ebuild
new file mode 100644
index 000000000000..8b9dcdfe7a8a
--- /dev/null
+++ b/sys-apps/lilo/lilo-22.1-r2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/lilo-22.1-r2.ebuild,v 1.1 2002/02/04 12:52:58 gbevin Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard Linux boot loader"
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/${P}.tar.gz"
+
+DEPEND="virtual/glibc >=sys-devel/bin86-0.15.5"
+
+RDEPEND="virtual/glibc"
+
+pkg_setup() {
+ if [ `cut -f 2 -d " " /proc/mounts | grep "/boot"` ]
+ then
+ einfo "Your boot partition was detected as being mounted as /boot."
+ einfo "Files will be installed there for lilo to function correctly."
+ else
+ mount /boot
+ if [ `cut -f 2 -d " " /proc/mounts | grep "/boot"` ]
+ then
+ einfo "Your boot partition was not mounted as /boot, but portage was able to mount"
+ einfo "it without additional intervention."
+ einfo "Files will be installed there for lilo to function correctly."
+ else
+ eerror "Your boot partition has to be mounted on /boot before the installation"
+ eerror "can continue. Lilo needs to install important files there."
+ die "Please mount your /boot partition."
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp Makefile Makefile.orig
+ sed -e "s:-g:${CFLAGS}:" Makefile.orig > Makefile
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ into /
+ dosbin lilo
+ into /usr
+ dosbin keytab-lilo.pl
+ dodir /boot
+ insinto /boot
+ doins boot-text.b boot-menu.b boot-bmp.b chain.b os2_d.b
+ doman manPages/*.[5-8]
+ dodoc CHANGES COPYING INCOMPAT QuickInst README*
+}
+
+pkg_preinst() {
+ if [ ! -L $ROOT/boot/boot.b -a -f $ROOT/boot/boot.b ]
+ then
+ echo "Saving old boot.b..."
+ mv $ROOT/boot/boot.b $ROOT/boot/boot.old;
+ fi
+
+ if [ ! -L $ROOT/boot/chain.b -a -f $ROOT/boot/chain.b ]
+ then
+ echo "Saving old chain.b..."
+ mv $ROOT/boot/chain.b $ROOT/boot/chain.old;
+ fi
+
+ if [ ! -L $ROOT/boot/os2_d.b -a -f $ROOT/boot/os2_d.b ]
+ then
+ echo "Saving old os2_d.b..."
+ mv $ROOT/boot/os2_d.b $ROOT/boot/os2_d.old;
+ fi
+}
+
+pkg_postinst() {
+
+ . ${ROOT}/etc/init.d/functions.sh
+
+ einfo "Activating boot-menu..."
+ ln -sf boot-menu.b $ROOT/boot/boot.b;
+}
+
+